Sign in with
Sign up | Sign in
Your question
Solved

Tech Help - System Interrupts Hogging 40 - 60%

Last response: in Windows 7
Share
July 27, 2010 3:42:24 PM

Well... I am at a loss and willing to try what ever to remedy the situation.

I'm running an older rig that was meant for XP, has the specs for W7, but I never decided to make the leap with it because it was always dragged down. But now I have another system that works just fine with 7 and I'm looking to find out what the problem is with this one...

The system I'm having problems with is a HP Media Center PC m7470n.
Seems that the CPU usage is constantly around the 50% mark with windows 7 (runs flawless with xp).
I'm assuming there is a hardware/driver issue, but alas I cannot find it!!

So I'm giving my pride up and asking for some tech help.... any takers?

(A virus is out of the question, it is a clean install)

Included is a screen shot of the running processes and resource mon.
http://img819.imageshack.us/img819/5037/desktopss.png


Any suggestions...? I'm open for ideas here.

More about : tech system interrupts hogging

a b $ Windows 7
July 27, 2010 3:47:45 PM

The best advice that I can give is for you to read this article by Mark Russinovich. It gives a very good description of analyzing this sort of problem. You might also want to check out Mark's other articles; he is extremely knowledgeable about Windows internals.
m
0
l
July 27, 2010 4:31:06 PM

Well through using his investigation tactics it leads me to a start address "ntoskml.exe!KeUpdateSystemTime+0x420" which is taking about 30% of CPU usage. Through google searching & variations it leads me to foreign websites in different languages and a kernel based keylogger..... which I don't find possible unless Windows Auto-Installed an infected driver...? I'm assuming this is all leading me in the wrong direction, unless there is something bigger that I am missing?
m
0
l
Related resources
a b $ Windows 7
July 27, 2010 4:44:28 PM

Try Googling "ntoskml.exe!KeUpdateSystemTime"; you'll get a lot more hits (many of them in English!). The consensus seems to be that it's probably a driver issue, possibly graphics. Have you checked that all drivers are up-to-date?
m
0
l
July 27, 2010 4:52:07 PM

Yes.
ATI Radeon HD 4670.

Up to date with the latest W7 drivers.
There were a lot of related driver issues with my search.
I tried disabling & uninstalling many of them 1 by 1 and nothing seemed to work.
I also unplugged everything in the USB... doesn't seem to be any connected devices.

I'll take it my previous post was a complete miss hah.
m
0
l
a b $ Windows 7
July 27, 2010 5:47:48 PM

Try removing things you aren't using in bios.
m
0
l
July 27, 2010 6:52:54 PM

mhelm1 said:
Try removing things you aren't using in bios.


Disabled everything in BIOS besides onboard video and a SATA for the hard drive.... still has the problem.

The only thing I can think of is maybe striping the actual hardware out 1 thing at a time?

I'm seriously at a loss with what is not working right.... did another clean install with no drivers installed to start from scratch again and tried all the disabling/enabling.... still no positive results.
m
0
l
a b $ Windows 7
July 27, 2010 7:00:37 PM

If you have a ATI Radeon HD 4670 installed, the problem is the onboard video.
disable and see what happens.
m
0
l
a b $ Windows 7
July 27, 2010 7:02:24 PM

Make sure your not running Catalyst 10.5 (any one but this one)
m
0
l
July 27, 2010 7:06:34 PM

meh... i figured this wouldn't work but tried it anyways.... I guess I should have rephrased my post.

My BIOS has a "primary graphics" option... I set it to onboard from my previous post and from your recommendation set it to recognize only the PCI-E .... still nothing.
m
0
l
Anonymous
a b $ Windows 7
July 27, 2010 10:28:37 PM

Try removing the hard drive controller driver and then rebooting to reinstall it. This fixed a HP laptop with XP that had a similar problem.
m
0
l

Best solution

July 28, 2010 6:27:38 AM

5n4p said:
meh... i figured this wouldn't work but tried it anyways.... I guess I should have rephrased my post.

My BIOS has a "primary graphics" option... I set it to onboard from my previous post and from your recommendation set it to recognize only the PCI-E .... still nothing.


I recently had a problem similar to this after I put a couple of ATI 4650's in the kid's computers. Try disabling the HD audio device. This link isn't the exact one I used, but same basic procedure...go to device manager, system devices, and disable the High Definition Audio Controller

http://www.sevenforums.com/graphic-cards/68199-ati-rade...
Share
August 14, 2010 12:17:13 AM

Just to bring this situation up to date... I ended up swapping out my (ATI RADEON 4670) graphics card with my other machine and Windows 7 is running flawlessly now. Even though I disabled the device and only used the on board video, it wasn't until I removed the actual hardware that the problem was resolved.
PastorOfMuppets response could have been the correct answer, but I never got around to it. Overall, there seemed to be an issue with the graphics card and I ended up putting it in a machine that would utilize it more efficiently.

Problem solved! Thanks for the help guys.
m
0
l
August 14, 2010 12:17:22 AM

Best answer selected by 5n4p.
m
0
l
!