Sign in with
Sign up | Sign in
Your question

Enabling DMA on XP

Last response: in Windows XP
Share
January 4, 2004 12:54:20 AM

Built a new system. On IDE1 have 120 GB HDD as Master On IDE2, have Liteon 48XDVD/CDR combo as master and 52X LG CD_Rom as slave. Took a long time to copy a CD< think I need to enable DMA, but don't know where/how. Thanks

More about : enabling dma

January 4, 2004 3:34:46 AM

You need to go in to device manager and find the properties for IDE ATA/ATAPI Controlls then Primary and Secondary IDE Controllers. Open the properties menu for those items and select the Advanced Settings tab. Under Transfer Mode for Device 0 and Device 1, select "DMA if Available."

And that should do it.
January 5, 2004 1:01:06 AM

Control Panel - System - Hardware - Device Manager - expand IDE ATA/ATAPI Controllers - right click on Primary IDE - Properties - Advanced Settings - make sure that Device 0 and Device 1 Transfer Mode is set to DMA if available - OK. Now right click on Secondary IDE and do the same.

For it is not what is seen, but what is not seen. :eek: 
Related resources
January 5, 2004 10:49:20 AM

What you really need to do is remove the CDROM drive from the system, WinXP defaults the transfer mode to PIO mode with CDROM drives, and even if you take the above suggestions, the first error WinXP runs into its going to default back to PIO mode. Drives that will run in DMA mode are DVDROM, CDRW, and DVDRW drives, but CDROM drives will default to PIO mode, which makes it in the long run, simpler, to just remove it from the system, you can use the Liteon 48XDVD/CDR, as your CDROM drive anyway, so you don't really need it with your setup. Most think well I spent money on it, I want to use it, but if its robbing system performance loose it, thank you Microsoft, for eventually making a CDROM graveyard.(Sarcasm)

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">My Rig</A>
January 5, 2004 3:25:59 PM

Actually, although 4ryan6 is right in most respects, the problem is not exactly as described. WinXP will set the default mode to PIO for CD-ROM devices, initially, but this can easily be changed for devices that support DMA, and your LG CD-ROM should support Multi-DMA Mode 2.

It takes 6 Cyclic Redundancy Checks or DMA timeouts when an individual device is accessed before WinXP will reset the mode to PIO. This can be caused by things like damaged or improperly connected cables, or even by chipsets that don't completely support CR Checks. The same goes for devices that are damaged, or that don't support CRC.

Of course, as 4ryan6 noted, there also appears to be a bug in WinXP that logs CRC errors due to DMA timeouts with certain optical devices, although the chipset, chipset drivers, the cable, and the device are in perfect working order. And it's not just limited to CD-ROM drives, either. For instance, I've got a Plextor 12/10/32A CD-RW running as a slave on a secondary channel, with a Plextor PX-504A DVD-RW set as the Master. The Master drive never creates CRC errors, but the slaved device does, each time it is accessed. Interestingly enough, the slaved device, when shifted on the cable, and set as the Master, does NOT produce CRC errors. This is despite the fact that each device runs in a different DMA mode, with the DVD-RW drive running at Ultra DMA Mode 2, and the CD-RW running at Multi-DMA Mode 2.

Because of this, it can become necessary to remove the secondary IDE channel from the Device Manager, if the slaved drive suddenly defaults to PIO mode. After a reboot, Windows redetects and reinstalls the channel, which allows the devices on the cable to again function as DMA. However, this has only happened once to me personally, in over a year of regular operation, with the CD-RW mounted as a slave on the secondary channel.

It's *&^%! irritating, but not such a problem that the user <i>must</i> remove any non-Ultra DMA optical devices from the system if WinXP is installed.

It's worth noting that this happens only to my systems that are using VIA chipsets, and never to any systems using Intel chipsets. All with the latest chipset drivers, and cables of good quality and condition. But ... both produce CRC errors when the non-Ultra DMA drives are accessed (when jumpered as slaves) ... it's just the system with the VIA chipset that seems to allow Windows to log enough CRC errors to finally shift the slaved optical device to PIO.

It's something you'll have to keep an eye on, and check occasionally, but it shouldn't stop you from using the device. It's just a pain that it happens at all, so I echo 4ryan6's sentiment, and thank MS for making things just a little more difficult, for no particularly good reason. It's not exactly a graveyard for CD-ROM devices, and more like suffering from a nasty Flu in the privacy of your home, but it's there, and I don't care much for it, either.

Toey

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=32..." target="_new"><font color=green>My System Rigs</font color=green></A>
___________________________________________

<A HREF="http://forums.btvillarin.com/" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>Your Computer Questions Answered</font color=orange></i>
January 6, 2004 7:32:18 AM

Removing the CDROM sounds troublesome. Why not try removing the secondary IDE channel through the device manager and then rescan for new hardware change, then let windows reinstall it. It works for my case.

It always turn back to PIO mode when my CDROM cannot read certain disc. So, no matter I turn it to DMA if available or not, it still PIO mode. So I remove the secondary IDE channel and reinstall...
January 6, 2004 11:34:21 AM

My suggestion, was to just flat out get rid of the problem, not to concentrate on all the fixes possible to solve the situation when the problem occurs, and my suggestion will get rid of the problem, so you don't have to deal with it when you may be in a critical situation such as using his DVDROM/CDRW to rip A DVD movie to his hardrive, but the IDE channel has defaulted to PIO mode. Personally I don't see that its a problem at all to remove the CDROM drive from the machine, but it may be a major problem for you, if you don't have the experience to do it, or something in the machine to take its place such as a DVDROM drive or a CDRW. The bottomline I was trying to present, is pretty simple actually, remove the CDROM from the system, remove the problem period, keep the CDROM, keep the problem, it doesn't matter to me which option you take, I don't have a CDROM drive in my machine, I haven't had one for two years.




<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=25..." target="_new">My Rig</A><P ID="edit"><FONT SIZE=-1><EM>Edited by 4ryan6 on 01/06/04 08:37 AM.</EM></FONT></P>
January 6, 2004 11:31:12 PM

yup yup... any way will work. But just don't want to spoil the IDE connectors by removing the drive too many times...
January 7, 2004 11:10:07 PM

Imagine that how many cables you need to unplug before you pull out the casing and then take off a few screws, then remove the cover(s) of the casing, then remove the CDROM screws, take off IDE cable, power supply and the audio cable (maybe the digital out) and some may need to set the BIOS detection... if can solve it from windows, I'd rather do it in windows...
January 8, 2004 1:41:15 AM

Not everyone have that... we need to think more general...
!