Sign in with
Sign up | Sign in
Your question

Need help with ATMA

Tags:
  • Games
  • Video Games
Last response: in Video Games
Share
March 25, 2005 8:25:26 PM

Archived from groups: alt.games.diablo2 (More info?)

I know this is not a ATMA help group, but I can't find anything online
help wise about this program.
Version of ATMA is 5.0.2
I have a very serious problem, well to me it is. For example if I move a
new sword to my Paladin and close ATMA and open Diablo the new item is
not there. Same thing with my Barbarian. The item is not there when I
open the game. Not just one d2x file, it does this with all of them.
I do not get an error when in ATMA all looks fine there.
We have a lot of stuff in ATMA and would hate to not be able to use it.
We've been playing for about three years and have saved some good items.
We play offline only if that makes a difference.
Would it help to install the newest version of ATMA? If so how would I
load the bank or what ever they call it?
Anyone have any suggestions on this, or a place to get answers?
WindowsXP, DiabloII expansion set with the latest patch.
Thanks

More about : atma

Anonymous
March 25, 2005 8:25:27 PM

Archived from groups: alt.games.diablo2 (More info?)

On Fri, 25 Mar 2005 17:25:26 -0500, Karen wrote:

> I know this is not a ATMA help group, but I can't find anything online
> help wise about this program.
> Version of ATMA is 5.0.2
> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there.

When you say "open Diablo" above, I assume that means the Diablo
program was not previously running and you then start it at that
point after the item has been moved. If that assumption is wrong,
then a big part of your difficulty is that the Diablo application
does not know to reload the file representation of your chars
after you have modified the file representation using Atma.
The program will reload them next time it runs.

The next question is how do you know you are directing
Atma to the right set of character files? Try to make
a new char with a new name you haven't used before and
see where the file with a similar name shows up. Then
check that this is the same directory you are telling
Atma to take char files from.

Another thing to point out is to make sure that the
version of Diablo that you are running is supported
by the version of ATMA that you are running.

Finally, to point out the obvious, it would be safer
to make backup copies of your stash file prior to all
experiments and just to have backups in case of computer
failure, etc.
March 25, 2005 9:08:42 PM

Archived from groups: alt.games.diablo2 (More info?)

On Fri, 25 Mar 2005 16:41:11 -0600, Last2Know <grokkalot@yahoo.com>
wrote:

>On Fri, 25 Mar 2005 17:25:26 -0500, Karen wrote:
>
>> I know this is not a ATMA help group, but I can't find anything online
>> help wise about this program.
>> Version of ATMA is 5.0.2
>> I have a very serious problem, well to me it is. For example if I move a
>> new sword to my Paladin and close ATMA and open Diablo the new item is
>> not there.
>
>When you say "open Diablo" above, I assume that means the Diablo
>program was not previously running and you then start it at that
>point after the item has been moved. If that assumption is wrong,
>then a big part of your difficulty is that the Diablo application
>does not know to reload the file representation of your chars
>after you have modified the file representation using Atma.
>The program will reload them next time it runs.
>
>The next question is how do you know you are directing
>Atma to the right set of character files? Try to make
>a new char with a new name you haven't used before and
>see where the file with a similar name shows up. Then
>check that this is the same directory you are telling
>Atma to take char files from.
>
>Another thing to point out is to make sure that the
>version of Diablo that you are running is supported
>by the version of ATMA that you are running.
>
>Finally, to point out the obvious, it would be safer
>to make backup copies of your stash file prior to all
>experiments and just to have backups in case of computer
>failure, etc.
>
Thanks for the response. I've already made a backup copy of everything
including the players.
Yes you are correct that the next time we open Diablo the items are not
there that we put in ATMA.
Yes the versions are correct. We've had Diablo for years and have been
using ATMA for a couple of years. And I've double checked to make sure
nothing had changed in the setup.
This problem just started.
Thanks again
>
>
Related resources
Anonymous
March 26, 2005 1:31:08 AM

Archived from groups: alt.games.diablo2 (More info?)

Karen wrote:
> I know this is not a ATMA help group, but I can't find anything online
> help wise about this program.
> Version of ATMA is 5.0.2
> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there. Same thing with my Barbarian. The item is not there when I
> open the game. Not just one d2x file, it does this with all of them.
> I do not get an error when in ATMA all looks fine there.
> We have a lot of stuff in ATMA and would hate to not be able to use it.
> We've been playing for about three years and have saved some good items.
> We play offline only if that makes a difference.
> Would it help to install the newest version of ATMA? If so how would I
> load the bank or what ever they call it?
> Anyone have any suggestions on this, or a place to get answers?
> WindowsXP, DiabloII expansion set with the latest patch.
> Thanks

I have no clue how old is ATMA 5.0.2. However I assume it
supports DII v1.10, and therefore shares the characteristics as
5.04d.

It looks like ATMA does NOT allow inter-version transfer of
items. This means 1.09 items can't load into 1.10 char/stash.

I know of a clumsy but workable solution. Make a bunch of v1.09
temporary mules (you can use ATMA to create these 1.09 mules.)
Transfer your 1.09 ATMA stash items to these temp mules, then
use these mules to join games. Once a 1.09 char joins a game in
DII v1.10, the char (and items he carries) gets upgraded to 1.10
(only the version # is upgraded; upgraded 1.09 set items still
don't get the partial set bonuses that real 1.10 set items have.)


Bing
Anonymous
March 26, 2005 2:00:56 AM

Archived from groups: alt.games.diablo2 (More info?)

On 25-Mar-2005, Karen <karen402@nomail.com> wrote:

> I know this is not a ATMA help group, but I can't find anything online
> help wise about this program.
> Version of ATMA is 5.0.2
> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there. Same thing with my Barbarian. The item is not there when I
> open the game. Not just one d2x file, it does this with all of them.
> I do not get an error when in ATMA all looks fine there.
> We have a lot of stuff in ATMA and would hate to not be able to use it.
> We've been playing for about three years and have saved some good items.
> We play offline only if that makes a difference.
> Would it help to install the newest version of ATMA? If so how would I
> load the bank or what ever they call it?
> Anyone have any suggestions on this, or a place to get answers?
> WindowsXP, DiabloII expansion set with the latest patch.
> Thanks

I presume that you are running D2LODv1.10? You may indeed have too old a
version of ATMA, I have v5.04d and things work fine.
The only other thing I can think of is... Are you opening player files in
ATMA with Diablo running but paused? I know you said you had Diablo
'closed', just making sure you mean truly closed, although you can open
player files if you are in the screen where you tell it whether you want
to play SP, MP, TCP/IP, etc. as long as the player file is not open.
(well, unless we are talking duping but that is a whole 'nother can or
worms)
The bank is just a utility of ATMA, have a player file open and then open
the bank, then transfer money in/out as you wish, when you close the
program it saves whatever you have put into the bank in some file or
something so that when you open ATMA again and open a player file and then
the bank, the money will be there from last time, even if it was 2 weeks
ago.
I would strongly suggest downloading the latest version of ATMA, sorry, no
idea if you will keep what you got so far, make a backup of the folder is
my suggestion.
Hope this helps.
--
Don't Panic!
March 26, 2005 2:00:57 AM

Archived from groups: alt.games.diablo2 (More info?)

On Fri, 25 Mar 2005 23:00:56 GMT, "ArtDent" <par@noyd.invalidname>
wrote:

>
>On 25-Mar-2005, Karen <karen402@nomail.com> wrote:
>
>> I know this is not a ATMA help group, but I can't find anything online
>> help wise about this program.
>> Version of ATMA is 5.0.2
>> I have a very serious problem, well to me it is. For example if I move a
>> new sword to my Paladin and close ATMA and open Diablo the new item is
>> not there. Same thing with my Barbarian. The item is not there when I
>> open the game. Not just one d2x file, it does this with all of them.
>> I do not get an error when in ATMA all looks fine there.
>> We have a lot of stuff in ATMA and would hate to not be able to use it.
>> We've been playing for about three years and have saved some good items.
>> We play offline only if that makes a difference.
>> Would it help to install the newest version of ATMA? If so how would I
>> load the bank or what ever they call it?
>> Anyone have any suggestions on this, or a place to get answers?
>> WindowsXP, DiabloII expansion set with the latest patch.
>> Thanks
>
>I presume that you are running D2LODv1.10? You may indeed have too old a
>version of ATMA, I have v5.04d and things work fine.
>The only other thing I can think of is... Are you opening player files in
>ATMA with Diablo running but paused? I know you said you had Diablo
>'closed', just making sure you mean truly closed, although you can open
>player files if you are in the screen where you tell it whether you want
>to play SP, MP, TCP/IP, etc. as long as the player file is not open.
>(well, unless we are talking duping but that is a whole 'nother can or
>worms)
>The bank is just a utility of ATMA, have a player file open and then open
>the bank, then transfer money in/out as you wish, when you close the
>program it saves whatever you have put into the bank in some file or
>something so that when you open ATMA again and open a player file and then
>the bank, the money will be there from last time, even if it was 2 weeks
>ago.
>I would strongly suggest downloading the latest version of ATMA, sorry, no
>idea if you will keep what you got so far, make a backup of the folder is
>my suggestion.
>Hope this helps.
Thanks, yes Diablo was all the way closed.
I may have fixed it, but the problem may come back. I just made a new
directory and copied all my files from ATMA in it, the d2i ect.
I remove the original files and re-loaded the ones from the new
directory.
Working for now. I will take a look at the new version.
Anonymous
March 26, 2005 2:27:49 AM

Archived from groups: alt.games.diablo2 (More info?)

"Karen" <karen402@nomail.com> wrote in message
news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com...
> I know this is not a ATMA help group, but I can't find anything online
> help wise about this program.
> Version of ATMA is 5.0.2
> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there. Same thing with my Barbarian. The item is not there when I
> open the game. Not just one d2x file, it does this with all of them.
> I do not get an error when in ATMA all looks fine there.
> We have a lot of stuff in ATMA and would hate to not be able to use it.
> We've been playing for about three years and have saved some good items.
> We play offline only if that makes a difference.
> Would it help to install the newest version of ATMA? If so how would I
> load the bank or what ever they call it?
> Anyone have any suggestions on this, or a place to get answers?
> WindowsXP, DiabloII expansion set with the latest patch.
> Thanks

There is a real simple solution to this problem
Once you have finshed transfering the stuff make sure you have the character
with the new items highlightd and hit the save botton in ATMA ( File then
Save ) then open D2 and that character should now be at the top of the list
as it is then the most resent character to be played then open and play
March 26, 2005 4:00:20 AM

Archived from groups: alt.games.diablo2 (More info?)

"Karen" <karen402@nomail.com> wrote in message
news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com...
>I know this is not a ATMA help group, but I can't find anything online
> help wise about this program.
> Version of ATMA is 5.0.2
> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there. Same thing with my Barbarian. The item is not there when I
> open the game. Not just one d2x file, it does this with all of them.
> I do not get an error when in ATMA all looks fine there.
> We have a lot of stuff in ATMA and would hate to not be able to use it.
> We've been playing for about three years and have saved some good items.
> We play offline only if that makes a difference.
> Would it help to install the newest version of ATMA? If so how would I
> load the bank or what ever they call it?
> Anyone have any suggestions on this, or a place to get answers?
> WindowsXP, DiabloII expansion set with the latest patch.
> Thanks

I would recommend getting the latest version of ATMA.
http://atma.diabloii.net/

You cannot import items from previous versions of D2 into 1.10. But I don't
think that's your problem because the character will not load if you try it.

You can check here:
http://www.rpgforums.net/forumdisplay.php?s=&daysprune=...
The author of ATMA, Hakai, posts there. The third thread stickied at the top
is specifically for Q&A about ATMAs. But be warned, the folks there are
extremely xenophobic, and are very harsh to anyone who they believe is using
hacks or 'cheating'.

Regards-
Mark

Bongo-Fury
Anonymous
March 26, 2005 9:26:20 AM

Archived from groups: alt.games.diablo2 (More info?)

Hi,

Karen <karen402@nomail.com> wrote in
news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com:

> I have a very serious problem, well to me it is. For example if I move a
> new sword to my Paladin and close ATMA and open Diablo the new item is
> not there. Same thing with my Barbarian. The item is not there when I
> open the game. Not just one d2x file, it does this with all of them.
> I do not get an error when in ATMA all looks fine there.

I'm running version 5.04D, so you might want to upgrade first.

It might be to simple, but make sure that on the Options tab, Auto Save and
Backup are checked. I played with this once and had a similar effect.

Regards,

Oliver
March 26, 2005 9:26:21 AM

Archived from groups: alt.games.diablo2 (More info?)

On Sat, 26 Mar 2005 06:26:20 +0100, Oliver Wenzel <ouuch@t-online.de>
wrote:

>Hi,
>
>Karen <karen402@nomail.com> wrote in
>news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com:
>
>> I have a very serious problem, well to me it is. For example if I move a
>> new sword to my Paladin and close ATMA and open Diablo the new item is
>> not there. Same thing with my Barbarian. The item is not there when I
>> open the game. Not just one d2x file, it does this with all of them.
>> I do not get an error when in ATMA all looks fine there.
>
>I'm running version 5.04D, so you might want to upgrade first.
>
>It might be to simple, but make sure that on the Options tab, Auto Save and
>Backup are checked. I played with this once and had a similar effect.
>
>Regards,
>
>Oliver
Thanks to everyone for their suggestions and input. The version I'm
running now does support DII v1.10 and I assme that's what all my stuff
is. I did download the latest version and MAY install it today. Kind of
hate to take chances when all is working well now.
Thanks again
Anonymous
March 27, 2005 2:45:04 AM

Archived from groups: alt.games.diablo2 (More info?)

"Karen" <karen402@nomail.com> wrote in message
news:b3ha41dg1s63qsf16fi2tpiujua29ojql7@4ax.com...
> On Sat, 26 Mar 2005 06:26:20 +0100, Oliver Wenzel <ouuch@t-online.de>
> wrote:
>
> >Hi,
> >
> >Karen <karen402@nomail.com> wrote in
> >news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com:
> >
> >> I have a very serious problem, well to me it is. For example if I move
a
> >> new sword to my Paladin and close ATMA and open Diablo the new item is
> >> not there. Same thing with my Barbarian. The item is not there when I
> >> open the game. Not just one d2x file, it does this with all of them.
> >> I do not get an error when in ATMA all looks fine there.
> >
> >I'm running version 5.04D, so you might want to upgrade first.
> >
> >It might be to simple, but make sure that on the Options tab, Auto Save
and
> >Backup are checked. I played with this once and had a similar effect.
> >
> >Regards,
> >
> >Oliver
> Thanks to everyone for their suggestions and input. The version I'm
> running now does support DII v1.10 and I assme that's what all my stuff
> is. I did download the latest version and MAY install it today. Kind of
> hate to take chances when all is working well now.
> Thanks again

My moto is:
If its not broke dont fix it
March 27, 2005 11:53:20 AM

Archived from groups: alt.games.diablo2 (More info?)

On Sat, 26 Mar 2005 22:45:04 GMT, "custard" <custards1@hotmail.com>
wrote:

>
>"Karen" <karen402@nomail.com> wrote in message
>news:b3ha41dg1s63qsf16fi2tpiujua29ojql7@4ax.com...
>> On Sat, 26 Mar 2005 06:26:20 +0100, Oliver Wenzel <ouuch@t-online.de>
>> wrote:
>>
>> >Hi,
>> >
>> >Karen <karen402@nomail.com> wrote in
>> >news:b139411c1j3bfqifc1ohb9fpo8al0jessu@4ax.com:
>> >
>> >> I have a very serious problem, well to me it is. For example if I move
>a
>> >> new sword to my Paladin and close ATMA and open Diablo the new item is
>> >> not there. Same thing with my Barbarian. The item is not there when I
>> >> open the game. Not just one d2x file, it does this with all of them.
>> >> I do not get an error when in ATMA all looks fine there.
>> >
>> >I'm running version 5.04D, so you might want to upgrade first.
>> >
>> >It might be to simple, but make sure that on the Options tab, Auto Save
>and
>> >Backup are checked. I played with this once and had a similar effect.
>> >
>> >Regards,
>> >
>> >Oliver
>> Thanks to everyone for their suggestions and input. The version I'm
>> running now does support DII v1.10 and I assme that's what all my stuff
>> is. I did download the latest version and MAY install it today. Kind of
>> hate to take chances when all is working well now.
>> Thanks again
>
>My moto is:
>If its not broke dont fix it
That's a good "moto" but mine is very broke
!