Direct3D Lockups in Win2k.

Hello everyone,

I have recently become the unexpected owner on a new XP2000+, and have remade my computer. I originally just changed the MoBo, RAM, and CPU, which seemed to work fine. I then switched to Win2k from Win98SE. I have tried 4 graphically intense programs since then, MadOnion 2001 (freezes randomly 3-5 mins in), Unreal Tournament in OpenGL mode (no problems after a few hours of play), Empire Earth (one play, froze after 30 minutes) and Morrowind which froze after about 45 seconds. If anyone has any idea of what may be causing this, please help! If not, I'm going to switch over to RH 7.3 and say goodbye to most of my gaming... =(

I'm running:

XP2000+ w/ 512MB DDR333
Radeon 8500 64MB
Gigabyte MoBo (Forget exact model)
Sound Blaster PCI64 (I know...)
Win2k Professional SP3

I have tried with both the latest Catalyst and regular ATI drivers.

Thanks for any help.

Q : Is Dvorak better than QWERTY?
A : Only if you use a shared computer.
4 answers Last reply
More about direct3d lockups win2k
  1. 1. Load the chipset drivers for your motherboard.

    2. Load the <A HREF="http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871_2336,00.html" target="_new">Microsoft Windows® 2000 Patch for AGP Applications</A>. You'll see it in the upper right part of the screen under Utilities, Drivers, & Updates.

    <b>Don't load</b> the AMD chipset drivers unless your motherboard has an AMD chipset.

    Summary of problem fixed by Microsoft Windows® 2000 Patch for AGP Applications

    <i><font color=purple>An issue has been identified that could result in the corruption of video data shared between AGP graphics adapters and AMD Athlon™ or AMD Duron™ family processors, including the AMD Athlon™ MP, mobile Athlon™ 4, and AMD Athlon™ XP processors, when running Microsoft Windows®2000 Professional, Windows®2000 Server, or Windows®2000 Advanced Server. This issue is independent of system chipset and has been observed when running Ziff-Davis 3D Winbench™ 2000 and Mad Onion 3DMark™ 2000 in benchmarking mode. Note: This patch is not needed for Windows XP.</font color=purple></i> -- www.amd.com

    <b>I have so many cookies I now have a FAT problem!</b>
  2. it sounds like a directx problem. what version of direct x are you using? to help with trouble shooting run the dx diag utility. if it fails my best guess is that you have corrupted video card drivers. if this isn't the problem make sure your mobo/bios is set correctly for the vid card your using, win 2k is very very pickey about the vid drivers. make sure they are not shadowed in the bios and your not running previous drivers from the previos O.S. also never set your agp settings beyond manufac. recomendations apeture size should be 1/2 of the ammount of system memory. hope this helps ....drz....
  3. Thanks for the help. I downloaded and installed the patch, but Morrowind still freezes after about 30 mins. I have been seeing less crashes, but they still happen.

    I have DirectX 8.1, the latest version. The dxdiag doesn't give any errors. I turned hardware acceleration on my sound card off because I recall having problems related to that before. In any case, I guess I'll just be playing alot more Diablo II and UT *grin*.

    Q : Is Dvorak better than QWERTY?
    A : Only if you use a shared computer.
  4. This is a very common problem. Check out the article on Via Arena's website called "staying out of the loop". I had to turn down my memory settings to fix the crashes permanently. Same thing happened to me when I switched from Win ME to XP. Actually, the same thing happened to thousands of people. Do a search on Infinite loop XP and you will see what I mean.


    Just because you're not paranoid, doesn't mean they're not watching you.
Ask a new question

Read More

Graphics Cards Graphics