Sign in with
Sign up | Sign in
Your question

Nividia based card kills my RAM

Last response: in Graphics & Displays
Share
November 22, 2002 10:18:58 PM

I've discovered an issue between various NVidia Geforce cards and RAM, but can't find a solution.

I've tried both a Geforce 2MX and a Leadtek Winfast A250 at different times (both using NVidia) and have found that it kills most of my RAM... I'm using 512 MB PC2700 DDR RAM, but after 20 odd minutes of use, my pc dies.

After running a variety of diagnostic tools, Norton system works discovered that it could only read 130Mb of the RAM.

I replaced the RAM, but it continued. I've now had a technican where I purchased it look and the only way we can get to use the full 512 MB of RAM is by using a graphics card that is not NVidia based.. We've also rebuilt the machine using different configurations - still using the Nvidia - without fixing this issue.

Has anyone else seen this issue and if so, is there a fix? NVidia aren't saying anything other than blame Microsoft (but we've tried those fixes already)

I'm running with Win98 SE using a Gigabyte 7VAX motherboard.

Thanks
November 23, 2002 3:37:45 AM

Try this (Toejam solved a ram/graphics card problem of mine this way)
If I were you, I'd adjust the vcache setting in the System.ini file, and then try out the newest driver set for the card.

Open the System.ini file in a text editor, such as Notepad.

Go to the [vcache] section.

Add these lines, or change the settings to this, directly under [vcache]:

MinFileCache=4096
MaxFileCache=131072

Save the changes and reboot.

Then go directly to the BIOS, and try to open the AGP aperture to 256, if the BIOS supports an aperture that large. That's pretty standard with 512MB of RAM. 1/2 the size of the physically-installed memory.

Then clean out the old drivers completely with Add/Remove Programs, and then install the new drivers.

The vcache is basically a set of memory addresses for the disk caching virtual device driver.

In Win9x, when you install 512MB of RAM or more, a bug in the OS correspondingly raises the size of the vcache, and this can become as large as 800MB when controlled by Windows. But the vcache settings must always be smaller than the size of the physically installed RAM, or it can cause blue screens and out-of-memory errors.

Also, the AGP port uses a set of memory addresses that are very close to the vcache. This is a cache for texturing, and so, for example, if you have a video card with 32MB of RAM, another 32MB is allocated for AGP texturing. If these addresses overlap, the again, you get blue screens.

The settings I posted for you caused the minimum size of the cache to be 4MB, which is good for performance. The maximum number set the upper limit for the cache at 128MB, which is not only sufficient for the virtual device driver and the cache, but also better for performance. The standard rule-of-thumb in this kind of situation is that the maximum number is really the important one, and that it should be set at around 25% of your RAM.

After making the changes, the memory addresses cannot overlap and cause a protection fault when the disk caching virtual device driver and the AGP port start fighting over the RAM addresses during the boot, which is exactly what was happening on your machine.

Does that explain it sufficiently?


The Men Behind the GUNS!

<A HREF="http://www.btvillarin.com/phpBB/viewtopic.php?t=327" target="_new"><b>MY SYSTEM</b></A>
November 23, 2002 5:27:07 PM

It seems like the 7vax and 7vaxp have some gfx card and memory issues.

I'm rma'ing my PC3200 right now.
!