Sign in with
Sign up | Sign in
Your question

File transfer stopped working in Windows Messenger 4.7 aft..

Last response: in Windows XP
Share
Anonymous
October 1, 2004 11:37:49 PM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi

I have a problem with file transfer and the new Windows Messenger (4.7.3000)
that comes with Service Pack 2.
Before installing the uber update, everything was working fine for my friend
and I (we're both behind routers, default settings, nothing fancy) : the
files would just transfer without any need for specific configuration.

Now, it doesn't work anymore : none of us can send or receive files, we
either get the "blocked connection, contact your network administrator"
message or the plain "transfer failed" one.

I've tried opening the 6891-6900 ports on the router, enabling UPnP also but
to no avail : i cannot send or receive files.

I don't understand what's wrong since it WAS working before and i didn't
change anything to my configuration except installing SP2.

Any ideas or solutions would be greatly appreciated.

My configuration:
Windows XP SP2
Windows Messenger 4.7.3000
ASUS P4P800 Deluxe integrated LAN (3Com Gigabit LOM 3C940)
Netgear FR114P Firewall + Router.
Anonymous
October 1, 2004 11:37:50 PM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Greetings,

Actually what's probably happened is the protocol has changed (I admit I haven't even looked
into this for the .3000 version).

Windows Messenger 4.7 doesn't actually have support for UPnP file transfer, so it was working
before, simply because of an Application Layer Gateway (ALG) in the router itself which was
translating the packets on your behalf so that this feature worked. The problem with ALG's
is that if the protocol changes, even slightly, usually the functionality will break.

The easiest solution in this sceario is to either upgrade to Windows Messenger 5 where UPnP
file transfer is supported:
http://microsoft.com/downloads/details.aspx?FamilyID=77...

or simply use MSN Messenger 6.x instead:
http://messenger.msn.com/Download
____________________________________________
Jonathan Kay
Microsoft MVP - Windows Messenger/MSN Messenger
Associate Expert
http://www.microsoft.com/windowsxp/expertzone/
Messenger Resources - http://messenger.jonathankay.com
All posts unless otherwise specified are (c) 2004 Jonathan Kay.
You *must* contact me for redistribution rights.

"Dr.Woof" <denvergarou@hotXXNOSPAMXXmail.com> wrote in message
news:hmi7d.1876603$ic1.193179@news.easynews.com...
> Hi
>
> I have a problem with file transfer and the new Windows Messenger (4.7.3000) that comes
> with Service Pack 2.
> Before installing the uber update, everything was working fine for my friend and I (we're
> both behind routers, default settings, nothing fancy) : the files would just transfer
> without any need for specific configuration.
>
> Now, it doesn't work anymore : none of us can send or receive files, we either get the
> "blocked connection, contact your network administrator" message or the plain "transfer
> failed" one.
>
> I've tried opening the 6891-6900 ports on the router, enabling UPnP also but to no avail :
> i cannot send or receive files.
>
> I don't understand what's wrong since it WAS working before and i didn't change anything to
> my configuration except installing SP2.
>
> Any ideas or solutions would be greatly appreciated.
>
> My configuration:
> Windows XP SP2
> Windows Messenger 4.7.3000
> ASUS P4P800 Deluxe integrated LAN (3Com Gigabit LOM 3C940)
> Netgear FR114P Firewall + Router.
>
>
Anonymous
October 13, 2004 8:05:49 PM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi Jonathon,

I have WinXP Pro SP2 installed and have the latest version
of Messenger also (5.0.0482) and I am having trouble with
file transfer. I am using a NAT router but this is uPNP
enabled. The problem is when I try to send a file it just
hangs at the connecting stage then says about a "firewall
blocking...contact network administrator". I seem to be
able to receive files from other people who are using
Windoes Messenger but not from people using MSN Messenger.
Sending files to anybody also fails. I have tried opening
ports 6891-6900 on the router and disabling the SP2
firewall and it still doesn't work. As a last resort I put
my PC in the DMZ of the router and turned off the SP2
firewall but still no joy? Any help would be greatly
appreciated...from what I have read, and I see that
Windows Messenger 5 has uPNP file transfer, this should
just work...

Thanks, Richard.

>-----Original Message-----
>Greetings,
>
>Actually what's probably happened is the protocol has
changed (I admit I haven't even looked
>into this for the .3000 version).
>
>Windows Messenger 4.7 doesn't actually have support for
UPnP file transfer, so it was working
>before, simply because of an Application Layer Gateway
(ALG) in the router itself which was
>translating the packets on your behalf so that this
feature worked. The problem with ALG's
>is that if the protocol changes, even slightly, usually
the functionality will break.
>
>The easiest solution in this sceario is to either upgrade
to Windows Messenger 5 where UPnP
>file transfer is supported:
>http://microsoft.com/downloads/details.aspx?
FamilyID=77c3799f-6388-4193-8002-be55584c1ac1
>
>or simply use MSN Messenger 6.x instead:
>http://messenger.msn.com/Download
>____________________________________________
>Jonathan Kay
>Microsoft MVP - Windows Messenger/MSN Messenger
>Associate Expert
>http://www.microsoft.com/windowsxp/expertzone/
>Messenger Resources - http://messenger.jonathankay.com
>All posts unless otherwise specified are (c) 2004
Jonathan Kay.
>You *must* contact me for redistribution rights.
>
>"Dr.Woof" <denvergarou@hotXXNOSPAMXXmail.com> wrote in
message
>news:hmi7d.1876603$ic1.193179@news.easynews.com...
>> Hi
>>
>> I have a problem with file transfer and the new Windows
Messenger (4.7.3000) that comes
>> with Service Pack 2.
>> Before installing the uber update, everything was
working fine for my friend and I (we're
>> both behind routers, default settings, nothing fancy) :
the files would just transfer
>> without any need for specific configuration.
>>
>> Now, it doesn't work anymore : none of us can send or
receive files, we either get the
>> "blocked connection, contact your network
administrator" message or the plain "transfer
>> failed" one.
>>
>> I've tried opening the 6891-6900 ports on the router,
enabling UPnP also but to no avail :
>> i cannot send or receive files.
>>
>> I don't understand what's wrong since it WAS working
before and i didn't change anything to
>> my configuration except installing SP2.
>>
>> Any ideas or solutions would be greatly appreciated.
>>
>> My configuration:
>> Windows XP SP2
>> Windows Messenger 4.7.3000
>> ASUS P4P800 Deluxe integrated LAN (3Com Gigabit LOM
3C940)
>> Netgear FR114P Firewall + Router.
>>
>>
>
>
>.
>
!