SIP not fully supported in XP SP2

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi everyone that understand SIP and Windows Messenger,
Just upgraded my WinXP home to SP2. I want to setup Windows Messenger (any
version) to be able to register on a SIP server that requires authentication
and then be able to have voice, video, presence, file transfer, messenging
and program sharing.

But:
Any version for WM except 5.0.084 fails to register on the SIP server. NOTE:
I have turned off the Windows firewall completely since I have a combined HW
firewall/SIP server/proxy (Intertex IX66). However, with the WM5 "only"
voice, video and program sharing seems to work as it should. Presence status
of my buddies is never updated after my own login and messaging or file
transfer gives a not very informative "The message could not be delivered to
all receipients" or something similar.

The good old 4.7.2009 that up to date seems to be the very best SIP-friendly
version out does not work under WinXP SP2 since it cannot even register on a
SIP-server that requires authentication. The sequence looks like this:
Windows Messenger -- SIP-server
Register (no password) -->
<-- Unauthorized 401 (Containing a authentication challenge code to be
used for a next "Register incl password")
Nothing more beeing transmitted from my WinXP. ( instead it should be a
"Register incl password" according to the SIP standard)

Now, can anyone tell me if/when any of the two following two problems will
be fixed?
1. Fix so that 5.0.084 will handle SIP presence, file transfer and instant
messenging.
2. Fix so that 4.7.2009 will handle authorized logins under WinXP SP2.

If it matters, UDP is the configured protocol to be used.

/Fred
5 answers Last reply
More about fully supported
  1. Archived from groups: microsoft.public.windowsxp.messenger (More info?)

    Hi Fred,

    > Windows Messenger -- SIP-server
    > Register (no password) -->
    > <-- Unauthorized 401 (Containing a authentication challenge code to be
    > used for a next "Register incl password")
    > Nothing more beeing transmitted from my WinXP. ( instead it should be a

    Maybe it is issue of the sip server ? Possible WM do not recognize 401
    response.

    Which server are you using ?

    Vitali Fomine
  2. Archived from groups: microsoft.public.windowsxp.messenger (More info?)

    Hi,
    As I wrote in my post, I am using a HW based SIP server from Intertex. The
    model is called IX66.
    1. I do not think it is an issue of the SIP server. According to my Ethereal
    log the response is according to all valid RFCs.
    2. You might be correct in your assumption that WM does not understand the
    401 response. However, 4.7.2009 DOES work with the very same setup/SIP
    server when the PC is running WinXP SP1, but not when running WinXP SP2.
    Clearly SP2 does something to prevent 4.7.2009 to function.

    /Fred


    "Vitali Fomine" <info@fomine.com> skrev i meddelandet
    news:2tiro9F1usr8tU1@uni-berlin.de...
    > Hi Fred,
    >
    >> Windows Messenger -- SIP-server
    >> Register (no password) -->
    >> <-- Unauthorized 401 (Containing a authentication challenge code to be
    >> used for a next "Register incl password")
    >> Nothing more beeing transmitted from my WinXP. ( instead it should be a
    >
    > Maybe it is issue of the sip server ? Possible WM do not recognize 401
    > response.
    >
    > Which server are you using ?
    >
    > Vitali Fomine
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.messenger (More info?)

    What about upgrading to Windows Messenger 5.0? (See
    http://www.microsoft.com/downloads/details.aspx?FamilyID=77c3799f-6388-4193-8002-be55584c1ac1&DisplayLang=en
    for more info)

    Let me know if you're still having issues after the upgrade.

    Sincerely,
    Michael Katz [MVP - MSN Client]
    --


    "Fred" <anonymous@msnews.microsoft.com> wrote in message
    news:O%23h5R$etEHA.908@TK2MSFTNGP10.phx.gbl...
    > Hi,
    > As I wrote in my post, I am using a HW based SIP server from Intertex. The
    > model is called IX66.
    > 1. I do not think it is an issue of the SIP server. According to my
    > Ethereal log the response is according to all valid RFCs.
    > 2. You might be correct in your assumption that WM does not understand the
    > 401 response. However, 4.7.2009 DOES work with the very same setup/SIP
    > server when the PC is running WinXP SP1, but not when running WinXP SP2.
    > Clearly SP2 does something to prevent 4.7.2009 to function.
    >
    > /Fred
    >
    >
    > "Vitali Fomine" <info@fomine.com> skrev i meddelandet
    > news:2tiro9F1usr8tU1@uni-berlin.de...
    >> Hi Fred,
    >>
    >>> Windows Messenger -- SIP-server
    >>> Register (no password) -->
    >>> <-- Unauthorized 401 (Containing a authentication challenge code to be
    >>> used for a next "Register incl password")
    >>> Nothing more beeing transmitted from my WinXP. ( instead it should be a
    >>
    >> Maybe it is issue of the sip server ? Possible WM do not recognize 401
    >> response.
    >>
    >> Which server are you using ?
    >>
    >> Vitali Fomine
    >>
    >>
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.messenger (More info?)

    Hi,
    On WinXP SP2, 5.0.084 is the only version that can handle an authorized
    login (that is, it will handle the 401 response and send a second REGISTER
    containing userid and password).

    However, the drawback with 5.0.084 is that file transfer and IM does not
    work (For your info: I am using SIP only). (Get a message "The message could
    not be delivered to all recipients") However, voice, video and application
    sharing does work.

    Also, the presence function in 5.0.084 have problems with SIP, which it
    seems to ignore. It will send SUBSCRIBE "buddy" to the SIP server at login
    time and that is OK. But it seems to NOT inform about its own presence state
    changes. That is: If you have a number buddies with PCs running 5.0.084 none
    of them will be informed what happens with the others since WM does not
    inform the SIP-server. (A presence state change does trigger WM to update
    the .NET service, but fail do so with SIP.) The result is that with SIP, you
    only get a snapshot of your buddies at your login time.

    /Fred

    "Michael Katz [MVP]" <michaelk[AT]mvps.org> skrev i meddelandet
    news:%23uiAbggtEHA.3072@TK2MSFTNGP10.phx.gbl...
    > What about upgrading to Windows Messenger 5.0? (See
    > http://www.microsoft.com/downloads/details.aspx?FamilyID=77c3799f-6388-4193-8002-be55584c1ac1&DisplayLang=en
    > for more info)
    >
    > Let me know if you're still having issues after the upgrade.
    >
    > Sincerely,
    > Michael Katz [MVP - MSN Client]
    > --
    >
    >
    > "Fred" <anonymous@msnews.microsoft.com> wrote in message
    > news:O%23h5R$etEHA.908@TK2MSFTNGP10.phx.gbl...
    >> Hi,
    >> As I wrote in my post, I am using a HW based SIP server from Intertex.
    >> The model is called IX66.
    >> 1. I do not think it is an issue of the SIP server. According to my
    >> Ethereal log the response is according to all valid RFCs.
    >> 2. You might be correct in your assumption that WM does not understand
    >> the 401 response. However, 4.7.2009 DOES work with the very same
    >> setup/SIP server when the PC is running WinXP SP1, but not when running
    >> WinXP SP2. Clearly SP2 does something to prevent 4.7.2009 to function.
    >>
    >> /Fred
    >>
    >>
    >> "Vitali Fomine" <info@fomine.com> skrev i meddelandet
    >> news:2tiro9F1usr8tU1@uni-berlin.de...
    >>> Hi Fred,
    >>>
    >>>> Windows Messenger -- SIP-server
    >>>> Register (no password) -->
    >>>> <-- Unauthorized 401 (Containing a authentication challenge code to
    >>>> be
    >>>> used for a next "Register incl password")
    >>>> Nothing more beeing transmitted from my WinXP. ( instead it should be a
    >>>
    >>> Maybe it is issue of the sip server ? Possible WM do not recognize 401
    >>> response.
    >>>
    >>> Which server are you using ?
    >>>
    >>> Vitali Fomine
    >>>
    >>>
    >>
    >>
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.messenger (More info?)

    Hi Fred!

    I'm having the same problems! Have you found a solution to your problems?

    regards,
    klaus

    btw: im using windows messenger 5.1

    Fred wrote:

    > Hi,
    > On WinXP SP2, 5.0.084 is the only version that can handle an authorized
    > login (that is, it will handle the 401 response and send a second REGISTER
    > containing userid and password).
    >
    > However, the drawback with 5.0.084 is that file transfer and IM does not
    > work (For your info: I am using SIP only). (Get a message "The message could
    > not be delivered to all recipients") However, voice, video and application
    > sharing does work.
    >
    > Also, the presence function in 5.0.084 have problems with SIP, which it
    > seems to ignore. It will send SUBSCRIBE "buddy" to the SIP server at login
    > time and that is OK. But it seems to NOT inform about its own presence state
    > changes. That is: If you have a number buddies with PCs running 5.0.084 none
    > of them will be informed what happens with the others since WM does not
    > inform the SIP-server. (A presence state change does trigger WM to update
    > the .NET service, but fail do so with SIP.) The result is that with SIP, you
    > only get a snapshot of your buddies at your login time.
    >
    > /Fred
    >
    > "Michael Katz [MVP]" <michaelk[AT]mvps.org> skrev i meddelandet
    > news:%23uiAbggtEHA.3072@TK2MSFTNGP10.phx.gbl...
    >
    >>What about upgrading to Windows Messenger 5.0? (See
    >>http://www.microsoft.com/downloads/details.aspx?FamilyID=77c3799f-6388-4193-8002-be55584c1ac1&DisplayLang=en
    >>for more info)
    >>
    >>Let me know if you're still having issues after the upgrade.
    >>
    >>Sincerely,
    >>Michael Katz [MVP - MSN Client]
    >>--
    >>
    >>
    >>"Fred" <anonymous@msnews.microsoft.com> wrote in message
    >>news:O%23h5R$etEHA.908@TK2MSFTNGP10.phx.gbl...
    >>
    >>>Hi,
    >>>As I wrote in my post, I am using a HW based SIP server from Intertex.
    >>>The model is called IX66.
    >>>1. I do not think it is an issue of the SIP server. According to my
    >>>Ethereal log the response is according to all valid RFCs.
    >>>2. You might be correct in your assumption that WM does not understand
    >>>the 401 response. However, 4.7.2009 DOES work with the very same
    >>>setup/SIP server when the PC is running WinXP SP1, but not when running
    >>>WinXP SP2. Clearly SP2 does something to prevent 4.7.2009 to function.
    >>>
    >>>/Fred
    >>>
    >>>
    >>>"Vitali Fomine" <info@fomine.com> skrev i meddelandet
    >>>news:2tiro9F1usr8tU1@uni-berlin.de...
    >>>
    >>>>Hi Fred,
    >>>>
    >>>>
    >>>>>Windows Messenger -- SIP-server
    >>>>>Register (no password) -->
    >>>>><-- Unauthorized 401 (Containing a authentication challenge code to
    >>>>>be
    >>>>>used for a next "Register incl password")
    >>>>>Nothing more beeing transmitted from my WinXP. ( instead it should be a
    >>>>
    >>>>Maybe it is issue of the sip server ? Possible WM do not recognize 401
    >>>>response.
    >>>>
    >>>>Which server are you using ?
    >>>>
    >>>>Vitali Fomine
    >>>>
    >>>>
    >>>
    >>>
    >>
    >
    >
Ask a new question

Read More

Servers Messenger Windows XP