Sign in with
Sign up | Sign in
Your question

Running full screen with games using Radeon HD 5470

Last response: in Windows 7
Share
Anonymous
a b $ Windows 7
August 5, 2010 4:36:34 AM

it wont run in full screen always in middle.. i tried messing with game options but it doesn't work for all games, i really need this fixed... im using Radeon HD 5470
windows 7 intel core i5 4gb ddr3 rams
August 5, 2010 7:12:54 AM

Sounds like a display driver issue.. Try this.. Right click the game's executable file and go to properties.. Check on the box quoting 'always run maximized' or something like that.. Apply and click ok.. Try running your game then.. Alternatively, you could try pressing alt+enter while your game is running..
Anonymous
a b $ Windows 7
August 5, 2010 12:11:11 PM

i dont have this option only run in like 640x520 or something like that no max :(  i really need this fixed im desparate thanks though.
Related resources
August 5, 2010 12:34:23 PM

Does alt+enter works.?
Anonymous
a b $ Windows 7
August 5, 2010 12:50:52 PM

nop doesnt work :( 
a c 288 $ Windows 7
August 5, 2010 3:40:09 PM

Are your video drivers the rights ones for the video card? If not, update the drivers first, also see if there is a driver for the monitor you are using.

Does this box get bigger/smaller as you change resolution? Does the box look like a Windows Explorer window with the close/minimize/maximize buttons in the corner or is it just a video box in the middle with no window borders or buttons?

Try running the games at the native resolution for your display. Some displays have an issue when scaling and don't scale to the full screen, rather they run the resolution in a box.
a b $ Windows 7
August 5, 2010 3:51:15 PM

Just to clarify:

Is the problem that only games show up in the middle of the screen, or is your display always in the middle of your screen (black bars surround the desktop background)? And what resolution are you running vs. the native resolution of your monitor?

If you have black bars surrounding your display, you need to adjust the scaling in the Catalyst Control Center. Here's how you adjust scaling in CCC.
a b $ Windows 7
August 5, 2010 4:01:36 PM

Quote:
it wont run in full screen always in middle.. i tried messing with game options but it doesnt work for all games, i really need this fixed... im using Radeon HD 5470
windows 7 intel core i5 4gb ddr3 rams


What game? I know some games written specifically for windows may only run at a certain resolution and you won't be able to play them in full screen mode. Mind you, these are much older games, but I've seen that happen once in awhile.

If you could tell us what game you are talking about, that would be of great help as well. Also, like someone asked, is this how even your windows desktop is or just the game in question?
Anonymous
a b $ Windows 7
August 6, 2010 7:26:56 AM

bump
Anonymous
a b $ Windows 7
August 6, 2010 3:04:54 PM

bump :( 
August 6, 2010 3:40:23 PM

Are the concerned games running on their latest available patches.? You may also try with running your video card with old driver(s).. Sometimes new drivers create such problems for older games..
April 23, 2012 6:30:15 PM

I had the same problem.. I was trying to play some old games with low resolutions like GTA san andreas, Chaos Legion... when my laptop's LCD was on its native screen resolution the options on scaling in the catalyst control centel were there, but did not highlighted... so this is what i did, first I set my screen resolution 1024 x 768 then went to catalyst control center. there were three options that appeared on scaling instead of two, and I could already toggle them. just choose full screen then apply, after doing that just set your screen to its native resolution. the games then will be on full screen. it worked for me. I am using an acer 4553G laptop with AMD phenom tri-core 2.10Ghz, 8gb ram ddr, ATi HD5470. it worked for me... we both have the same graphic card, it might help you out.. :) 
April 23, 2012 6:40:18 PM

it's not the drivers.. it's just the settings, alt+enter isn't much of an option also..
August 17, 2012 10:13:58 AM

it worked for me too...thnx.
I recently bought sony vaio E15 wid 2GB Amd radeon 7650m
>amber,ddun.
April 15, 2013 2:34:44 PM

Anonymous said:
it wont run in full screen always in middle.. i tried messing with game options but it doesn't work for all games, i really need this fixed... im using Radeon HD 5470
windows 7 intel core i5 4gb ddr3 rams


This is for ATI Cards
This works with catalyst 13.1 and similar versions of Catalyst control Center:

1) under "Desktop Management" select "Desktop Properties".

2) Select any Resolution Lower than your native resolution. and apply

3) Now under "My Built-in Displays" select "Properties (built-in Displays)".

4) Notice that "Fullscreen" is not greyed-out and not selected, Select "Fullscreen"

5) Now go back to "Desktop Properties" and select your normal screen resolution.

- Now if you launched you games they go fullscreen, if this works for you pls leave a "thank you" it really makes my day. :) 

!