Sign in with
Sign up | Sign in
Your question

KT7A & KT7A-Raid Don't See Hard Drive

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
January 22, 2002 2:47:43 PM

Okay, I've got one for all of you. I'm building a new 'puter for little SIS. I've installed a 1.4 T-bird 266FSB, KT7A V.1.3 MOBO, 768MB RAM, WD400BB, Sony CD-ROM, Plextor CD-RW, ATI Xpert 2000 PRO, all powered by a 350W Enermax power supply.
When I put this together the first time the system would't recognize the hard drive but did recognize CD-ROM and CD-RW. After much fussin', swappin' cables and IDE sockets, I RMA'd the drive and received another. Put it in and guess what? No drive. Put same drive in current system and it was detected by the BIOS with no prob. So, RMA'd MOBO w/T-bird to vendor. T-bird passed, MOBO didn't. Processor and new KT7A MOBO returned. Installed all components and fired it up. Once again the BIOS failed to recognize the hard drive. Got out my KT7A-Raid MOBO, slated for my new unit, installed chip, RAM and Cooler on board, installed board and video card, hooked up drives and fired it up. IT didn't see the drive EITHER!
Back to square one. Tried Ram from current computer, still no go. Put hard drive in current unit, BIOS detected it. Successfully performed fdisk on drive. Time for one more try. Reinstalled hard drive in new system and got same results, BIOS failed to detect hard drive.
Anybody have this happen to them or got any thoughts on how to correct this.
January 22, 2002 7:08:21 PM

Good and bad news!

First the bad.

from <A HREF="http://www.viahardware.com/faq/kt7/kt7faq.htm" target="_new">Paul's Unofficial Abit KT7 FAQ</A>

<i>Why is my Western Digital drive not detected by my motherboard?

It seems that certain Western Digital disk drives have a firmware incompatiblity with the KT133 and KT133A chipsets that causes them to not be detected by motherboards using these chipsets - such as the KT7/KT7A/KT7E motherboards (with or without RAID). Considerable discussion on this problem may be found on <A HREF="http://websupport.wdc.com/forum/topic.asp?TOPIC_ID=197" target="_new">this thread</A> at Western Digital's support site. A variety of disk drives seem to be affected and include the WD200, WD400BB, WD1000 plus other 20, 40, 60, 80 and 120GB models. Western Digital and ABIT are aware of the problem and Western Digital are apparently working on a firmware upgrade. Keep an eye on <A HREF="http://www.wdc.com/support/" target="_new">their site</A> and please email me when a fix is found so that I may update this question.</i>

Now the good news (if you can trust it).

I glanced through the thread mentioned. It seems the fix is to cut a small segment from the pin 1 wire on a 40-wire cable or the 1st two wires of an 80-wire cable. Remember both cables have a 40-pin connector but with the 80-wire cable you need to cut two wires for the 1st pin instead of one.

<b>Please be aware that this is written in a message thread at the WDC support site. I have no way of knowing if this is good information. Please read the thread and make your own decision.</b>


<b>We are all beta testers!</b>
Anonymous
a b V Motherboard
January 23, 2002 2:28:49 AM

Thanks phsstpok!

The thread to WD's forum was enlightening and productive. The "fix" of cutting wires 1 & 2 worked like a charm. Now I can get on with building this computer and getting it to my sister who has been very patiently waiting for her "way cool new computer" as she puts it.
January 23, 2002 2:35:29 AM

Hey, that's great! Glad it worked.

Now I'm curious. I'll have read up on IDE pinouts. I'm wondering what Pin 1 does.

<b>We are all beta testers!</b>
!