Sign in with
Sign up | Sign in
Your question

Soyo Dragon+ Onboard Lan Doesn't Work

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
January 28, 2002 12:27:21 AM

This seems to be a common problem with this board, judging from other forums. I installed all drivers I could find, and device manager thinks it works, but my broadband DSL just doesn't connect to anything. After disabling onboard LAN in BIOS and installing cheesy 3COM card, works like a champ. Anyone have any luck getting their onboard LAN to work????
Anonymous
a b V Motherboard
January 28, 2002 1:37:30 AM

I'm using the Soyo Dragon Plus with a Toshiba cable modem and didn't have any luck either. So far Netgear and Soho cards have worked fine in the system.

Also had problems with Sound Blaster Live. Had to just use the onboard audio (although it's not too shabby in MOH and RTCW).
January 28, 2002 2:21:57 AM

lol my soyo dragon ultra cant uae the crappy cmi audio chip so I put my sb live in and no problems .. for the lan.. are you going into Start|run|winipcfg, release all|renew all after you install it ?? I did that and the lan chip performs as good as my pci nic card.. I do have other issues with this board however that revolve around poor general performance and crashes tho'

lagger

<b><font color=blue>Computers run on smoke, I let the smoke out of mine and it quit working </b> </font color=blue>
Related resources
Anonymous
a b V Motherboard
January 28, 2002 8:41:08 PM

I've had this borad for a couple of months now and have had no trouble with it at all. Onboard LAN and audio have been great. I use it for gameing, surfing, and programming. Most stable machine I have ever owned.

-Make sure it's enabled in the bios
-ipconfig/release all, ipconfig/renew all
-Make sure there are no conflicts in device manager
-???
Anonymous
a b V Motherboard
February 21, 2002 5:18:04 PM

Wow and I thought it was just me. I just got me a new soyo board and I couldn't get the onboard lan to work either. I shipped it back to the company I bought it through and they couldn't make it work either. So they shipped me a new board back and surprise surprise it didn't work either. I never did try the ipconfig though. In windows 2000 only way I can make it come up is in the command prompt. How do you release it and renew it there. Thanks
February 21, 2002 5:23:32 PM

mine is working great. I use the drivers that WinXP provided during the installation.

-Always put the blame on you first, then on the hardware !!!
Anonymous
a b V Motherboard
February 21, 2002 8:28:34 PM

well I tried to do a release and renew. The release fails cause it is using DHCP and there is no tcp/ip assigned (duh I can't hit the dhcp server cause it don't work) so when I renew it just does nothing. Guess it was a big mistake getting this board.
Anonymous
a b V Motherboard
February 21, 2002 8:52:13 PM

Just to add a note. I disabled the onboard lan and put in a nic card that was working on my other computer. It don't work either. This board just doesn't like networking I guess. It will send all day long but it can't recieve anything
!