Sign in with
Sign up | Sign in
Your question

ASUS Rampage 3 USB device not recognised only on back MOBO ports

Last response: in Windows 7
Share
August 6, 2010 8:56:14 AM

Strange but True
Just installed new Asus Rampage 3 Gene motherboard with 6GB Kingston triple channel RAM with Intel 980x CPU and an ATI 5970 GPU, all powered by my 1000 Zalman power supply. Installed Windows 7 Professional 64 bit on my Intel 160GB SSD. Everything is flying just fine and then started to plug in my USB devices. My wireless mouse works great in all USB slots in the back. My Kingston 4GB flash disk works fine in all USB slots in the back. My external Seagate HDD works fine in all USB ports in the back of the MOBO. Now comes my CD Library carousels from DACAL. I plug it in and USB host controller can't recognise it. I have 4 carrousel’s so I try each one separately and get the same message. In desperation after an hours worth of fiddling I plug into the front case UBS and works just fine. I then try each USB port separately in the back of the MOBO and find only one port that recognises the DACAL device. Always the same port in the back. So I tried running 32 bit but same problem and same port works. So I plugged in a ISA USB 4 port card and that works just fine.

Now I ask the strange question, why?

The USB ports in the back of the MOBO seem to work fine with all my other USB devices, the only conclusion I can come up with is that not all USB ports are built the same. :o 

Thanks in advance for anyone that cares to shed some light on this mystery.
August 6, 2010 9:47:12 AM

Have you unplugged all devices in the rear usb ports when you're trying this? It could be that it's draining a little too much power for each USB bus to handle more than one device. Also have you tried to reinstall the drivers from the Asus site? maybe there is an update on the site for the USB host controller.
a b $ Windows 7
August 6, 2010 10:25:16 AM

As much as I dislike recommending it, might be worth trying a BIOS update?
Related resources
August 6, 2010 12:19:02 PM

I would contact Asus support first, but it does sound like you need a driver update for the cd carousel.
August 9, 2010 6:38:33 AM

Thanks to everyone that replied. For now, I am happy everthing works just fine with the ISA card so like they say "leave sleeping dogs"
!