Soyo Dragon and XP1800

I can't seem to get my new AMD XP1800 to work with my Soyo Dragon mobo (regular Dragon, not the +). I am upgrading from a Tbird 850 which I had no problems with. I installed the 1800 and powered up, it came as an 1150 so I changed the fsb in the bios from 100 to 133, saved and rebooted. Now it was recognized as XP 1800. I see the Win98 logo then I get the DOS Regscan screen and it freezes. I try again and get some error that says there's something wrong with Command.com. It alternates, more or less, between the Regscan screen and Command.com error. I can't get it to boot completely into the OS. If I set the FSB back to 100, it comes up as 1150 and seems to work fine. The processor is defintely an 1800, I've tried everything I know. Here's my system specs:

Soyo Dragon Mobo (bios KVXA_2BA1)
AMD XP 1800
512MB DDR PC2100
Radeon 8500
SB Live
Onboard sound and LAN are disabled.

I saw on the Soyo site that the previous Bios K7VX_2AA3 adds support for AMD XP, I don't know if it's a good idea to install that one again then the newer one. Thanks in advance.
4 answers Last reply
More about soyo dragon xp1800
  1. Check if your PCI speed is set to 1/4 of your FSB (133/4=33.3). Also check if you have 133 MHz memory and that it is set to CAS 3 (CAS 2.5 with DDR RAM) to be sure you haven't to fast memory timings.

    My case has so many fans that it hovers above the ground :eek: .
  2. The only thing I see is maybe that you are set at turbo mode instead of normal. I have this board and a XP1700+. With my memory, I can run it in turbo mode, but not with my cousin memory, different brand than mine.


    oups! I dont have this board, but the Dragon +. Maybe that you have the same BIOS option..

    -Always put the blame on you first, then on the hardware !!!
    <P ID="edit"><FONT SIZE=-1><EM>Edited by Pat on 02/04/02 02:28 PM.</EM></FONT></P>
  3. I am having the exact same problem! I have essentially the same config as you but I am using the onboard LAN and sound and I have a Voodoo 4, 4500 PCI video card.

    I am going to try replacing my memory stick (512MB, PC2100) tomorrow, because when I tried Norton Utilities diagnostics it has failed consistently. After the hassle of installing the heatsink on CPU I dread the thought of replacing the mobo!

    Given enough attempts, anyone can screw anything up beyond repair.
  4. I tired the suggestions, but no joy. I went ahead and flashed the Bios to the previous Bios K7VX_2AA3. Now at the FSB of 100 it recognizes the XP 1800 as AMD XP 1150 instead of just AMD 1150. Then I tired setting the FSB back to 133. It comes up as AMD xp1800+ and I don't get the Command.com error, but it does do the Registry checker sometimes or just freezes at the Win98 logo. I thought I was sure about the memory (2 sticks, each 256mb DDR PC2100) being 133, but now I wonder. One is from Crucial the other from a local store (Microcenter). I'll have to recheck that. Thanks for the advice.
Ask a new question

Read More

Motherboards Soyo Command Prompt Windows XP