Closed

Can't delete file

I have a file on my XP Pro SP1 system that I can't delete. Everytime I try I get an error message that says

Cannot delete (file): It is being used by another person or program.
Close any programs that might be using the file and try agian.

Problem is there are no users/apps using the file. I've gone in safe mode as administrator and I still get this crap. The file in question is a huge uncompressed AVI, just over 3 gigs in size. I'm long finished with it, and I was "cleaning up house" when all this crap went down.

If it may mean anything, the file is stored on a 2-drive NTFS RAID 0 array controlled by a 3Ware 7410 controller. I've never had a problem with this setup, and I doubt it had anything to do with this, but I'll mention it anyway.

I also recently installed SuSE Linux on a separate drive (system drives are on pull-out bays, and SuSE recognized the 3Ware controller, much to my amazement. It lists it as C drive), and I actually tried to dump it through Linux, to no avail.

So, any clues as to how I can dump this file will be greatly appreciated, thanks.
2 answers Last reply
More about delete file
  1. I believe that this is the windows XP bug. I do sometimes unable to delete avi file. I found this fix from the internet. Try this:

    Run regedit

    Find HKEY_LOCAL_MACHINE/SOFTWARE/Classes/CLSID/{87D62D94-71B3-4b9a-9489-5FE6850DC73E}/InProcServer32

    Delete this key.

    You'll be able to delete the avi file then. You might want to save that key by exporting it out first.

    P4 1.7Ghz @ 2GHz, 512MB PC800 RDRAM, 64MB Abit Ti4200, 60GB Maxtor, 120GB Western Digital, 48x24x42 TDK CDRW, 16X ASUS DVDROM, SB! live 5.1DE, Lifeview 3000 TV card
  2. Found the link where I got that info:

    <A HREF="http://www.dvdrhelp.com/forum/userguides/100406.php" target="_new">http://www.dvdrhelp.com/forum/userguides/100406.php</A>

    P4 1.7Ghz @ 2GHz, 512MB PC800 RDRAM, 64MB Abit Ti4200, 60GB Maxtor, 120GB Western Digital, 48x24x42 TDK CDRW, 16X ASUS DVDROM, SB! live 5.1DE, Lifeview 3000 TV card
Ask a new question

Read More

Error Message Windows XP