Sign in with
Sign up | Sign in
Your question

Internet Gateway & UPnP

Last response: in Windows XP
Share
Anonymous
March 12, 2005 7:53:48 PM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi.

Does anyone have suggestions why the Internet Gateway icon does not show up
in my Network Connections? I noticed this because I'm trying to get MSN
Messenger 6.2 (& 7.0) to successfully connect video and audio - and the MSN
Messenger Tools|Options|Connection shows that I have a "non-UPnP port
restricted NAT" - I suspect the two things may be linked.

I am running XP Pro+SP2+hotfixes, and have ensured that SSDP Discovery and
UPnP Hosting services are installed and enabled. The PC is connected
wirelessly via a Linksys WRT54G router (with UPnP enabled) to a Broadband
Cable Modem to the internet.

Suggestions for fixes/further diagnostics would be appreciated.

Kind regards,
Alan

More about : internet gateway upnp

Anonymous
March 13, 2005 7:18:20 PM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

MSN Messenger 6.2.0205 audio/video requirements:

1. When using a high speed Internet connection, the modem/router MUST be
UPnP compatible and have this option active. For MSN Messenger 6.2.0205, both
sides must have Windows XP. Set Zone Alarm to either medium or high, but set
it to ALLOW the MSN Messenger 6.2.0205 all access to the Internet.

2. On the Network Connections, right click Local Area Connection, go to
Properties, and the General tab should show a check mark only on Client for
Microsoft Network, and Internet Protocol (TCP/IP). No check on File and
Printer Sharing for Microsoft Networks, nor on QoS Packet Scheduler.

3. The Windows Firewall should be ON (recommended) and no check in Don't
allow exceptions . The Exceptions tab will later show the MSN Messenger
6.2.0205 and UPnP Framework as being active.

4. In the Control Panel > Add Remove Programs > Add Remove Windows
Components, scroll to Networking Services and remove all checks, except for
Internet Gateway Device Discovery (A), and for UPnP User Interface (B). Click
Ok, Next, and after clicking Next the Windows Wizard Component will run.
Click Finish; now the UPnP will automatically open all required ports.

5. Sign in on Messenger and run Audio/Video Tuning Wizard. In the Tools >
Options > Connection tab, you should read You are connected to the Internet
through a UPnP symmetric NAT. (Administrator); if you are using a dial-up
line it will read You are connected to the Internet using a direct
connection. Now check the Windows Firewall Exceptions list, the MSN Messenger
6.2.0205 and UPnP Framework will now have a check marks and the required
ports automatically opend.

6. Both Windows XP users sides should have similar setups, with working
webcams and microphones. Remember that one side can have dial-up and the
other a UPnP compatible modem/router.

(A) Allow you to find and control internet connection sharing hardware and
software that uses UPnP.

(B) Display icons in My Network Places for the UPnP devices detected on the
network; also opens the required Windows Firewall port.

Finally on MSN Messenger > Option > General tab, check mark under Sig in,
item 1 and 3 ( remove the checks after the restart, if you don't want
Messenger to startup ). Restart. Now the Internet Gateway icon is displayed.

"Alan Oliver" wrote:

> Hi.
>
> Does anyone have suggestions why the Internet Gateway icon does not show up
> in my Network Connections? I noticed this because I'm trying to get MSN
> Messenger 6.2 (& 7.0) to successfully connect video and audio - and the MSN
> Messenger Tools|Options|Connection shows that I have a "non-UPnP port
> restricted NAT" - I suspect the two things may be linked.
>
> I am running XP Pro+SP2+hotfixes, and have ensured that SSDP Discovery and
> UPnP Hosting services are installed and enabled. The PC is connected
> wirelessly via a Linksys WRT54G router (with UPnP enabled) to a Broadband
> Cable Modem to the internet.
>
> Suggestions for fixes/further diagnostics would be appreciated.
>
> Kind regards,
> Alan
>
>
>
Anonymous
March 14, 2005 10:34:59 AM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi Efrain. Thanks for the comprehensive reply.

Let me provide further details because your "general" answer is not wholly
relevant. Plus, I have conducetd further tests and can report on those
results too.

Firstly, my Linksys WRT54G v1.0 Router is running the latest firmware which
"claims" be UPnP compatible. Interestingly, from within the router's admin
system, if I re-assert "Enable UPnP" by clicking on "Save Settings", then
the "Internet Gateway" icon appears for a few minutes in the Network
Connections window of all of the XP PC's on my LAN. However, the icon
disappears within a few minutes and, in any case, it is "Disabled" and
refuses to be Enabled.

QUESTIONS: Anyone got ideas why the Internet Gateway icon comes and goes?
And why it is Disabled and refuses to become Enabled?

Before sending my initial request for help to this forum, I read many posts
including several of your excellent posts, and have tried just about
everything! Back to your list...

I do not have Zone Alarm or ANY IP restricting software installed. The only
IP restricting actions are those performed by the Hardware Firewall within
my Linksys Router. I don't even have XP Firewall switched on. I do have
McAfee VirusScan ASaP installed, but it doesn't claim to performing any IP
filtering/restricting.

In your item #2 you recommend disabling "File and Printer Sharing for
Microsoft Networks" and "QoS Packet Scheduler.

QUESTIONS: ". I would like (and do have) both of these activated - what, in
your experience, is the effect of each of these being enabled?

In item #3, you recommend having XP Firewall switched ON.

QUESTIONS: Are you recommending that XP Firewall is switched on for reasons
of "safety", or, in your experience, does firewall need to be switched on in
order for the Internet Gateway icon to appear, and for MSN Messenger video
conferencing to work correctly?

I've tried everything else within your list of suggestions. Further
assistance would be greatly appreciated.

Kind regards,
Alan

"Efrain" <Efrain@discussions.microsoft.com> wrote in message
news:CD77F009-227E-4D71-B71D-44AB0989184F@microsoft.com...
> MSN Messenger 6.2.0205 audio/video requirements:
>
> 1. When using a high speed Internet connection, the modem/router MUST be
> UPnP compatible and have this option active. For MSN Messenger 6.2.0205,
> both
> sides must have Windows XP. Set Zone Alarm to either medium or high, but
> set
> it to ALLOW the MSN Messenger 6.2.0205 all access to the Internet.
>
> 2. On the Network Connections, right click Local Area Connection, go to
> Properties, and the General tab should show a check mark only on Client
> for
> Microsoft Network, and Internet Protocol (TCP/IP). No check on File and
> Printer Sharing for Microsoft Networks, nor on QoS Packet Scheduler.
>
> 3. The Windows Firewall should be ON (recommended) and no check in Don't
> allow exceptions . The Exceptions tab will later show the MSN Messenger
> 6.2.0205 and UPnP Framework as being active.
>
> 4. In the Control Panel > Add Remove Programs > Add Remove Windows
> Components, scroll to Networking Services and remove all checks, except
> for
> Internet Gateway Device Discovery (A), and for UPnP User Interface (B).
> Click
> Ok, Next, and after clicking Next the Windows Wizard Component will run.
> Click Finish; now the UPnP will automatically open all required ports.
>
> 5. Sign in on Messenger and run Audio/Video Tuning Wizard. In the Tools >
> Options > Connection tab, you should read You are connected to the
> Internet
> through a UPnP symmetric NAT. (Administrator); if you are using a dial-up
> line it will read You are connected to the Internet using a direct
> connection. Now check the Windows Firewall Exceptions list, the MSN
> Messenger
> 6.2.0205 and UPnP Framework will now have a check marks and the required
> ports automatically opend.
>
> 6. Both Windows XP users sides should have similar setups, with working
> webcams and microphones. Remember that one side can have dial-up and the
> other a UPnP compatible modem/router.
>
> (A) Allow you to find and control internet connection sharing hardware and
> software that uses UPnP.
>
> (B) Display icons in My Network Places for the UPnP devices detected on
> the
> network; also opens the required Windows Firewall port.
>
> Finally on MSN Messenger > Option > General tab, check mark under Sig in,
> item 1 and 3 ( remove the checks after the restart, if you don't want
> Messenger to startup ). Restart. Now the Internet Gateway icon is
> displayed.
>
> "Alan Oliver" wrote:
>
>> Hi.
>>
>> Does anyone have suggestions why the Internet Gateway icon does not show
>> up
>> in my Network Connections? I noticed this because I'm trying to get MSN
>> Messenger 6.2 (& 7.0) to successfully connect video and audio - and the
>> MSN
>> Messenger Tools|Options|Connection shows that I have a "non-UPnP port
>> restricted NAT" - I suspect the two things may be linked.
>>
>> I am running XP Pro+SP2+hotfixes, and have ensured that SSDP Discovery
>> and
>> UPnP Hosting services are installed and enabled. The PC is connected
>> wirelessly via a Linksys WRT54G router (with UPnP enabled) to a Broadband
>> Cable Modem to the internet.
>>
>> Suggestions for fixes/further diagnostics would be appreciated.
>>
>> Kind regards,
>> Alan
>>
>>
>>
Related resources
Anonymous
March 14, 2005 10:35:00 AM

Archived from groups: microsoft.public.windowsxp.messenger (More info?)

Hi Alan, I am trying to answer your questions the best that I can:
1.I did the detailed instructions months ago to help some friends down here
in Puerto Rico. In your case just some of the steps apply.
2.I don't use ZA. My modem/router firewall plus the Windows one is more than
enough for me. You can have the Windows Firewall ON at all times, but you
need to allow for the exceptions. in our case MSN Messenger and UPnP (uncheck
any other you don't need).
3.There is NO need to have the Windows Firewall disabled at any time. Just
enable the exceptions (MSN Mess. and UPnP) but if you dislike the it turn it
off.
4.I myself couldn't enable my MSN Messenger video/audiowith the File and
Printer Sharing and the QoS Scheduler working.
5. Step 4 of the detailed instructions is the key th allow the Internet
Gateway icon.
6.Steps 2,3,4,5 and the "Finally" of the detailed instructions are the ones
that apply to your specific case.
Note:
If after the Internet Gateway icon is shown you disable the exceptions and
check Don't Allow Exceptions and Restart, the icon will disappear. You can
recover it quickly by reenabling the exceptions and activating MSN messenger
at startup (later can be deactivated). Play with this step and you will have
control of the icon.
All the above works flawlessly with the UPnP ADSL modem/routers , here in
Puerto Rico. If yous don't work the same, it could be your cable modem
firmware.





"Alan Oliver" wrote:

> Hi Efrain. Thanks for the comprehensive reply.
>
> Let me provide further details because your "general" answer is not wholly
> relevant. Plus, I have conducetd further tests and can report on those
> results too.
>
> Firstly, my Linksys WRT54G v1.0 Router is running the latest firmware which
> "claims" be UPnP compatible. Interestingly, from within the router's admin
> system, if I re-assert "Enable UPnP" by clicking on "Save Settings", then
> the "Internet Gateway" icon appears for a few minutes in the Network
> Connections window of all of the XP PC's on my LAN. However, the icon
> disappears within a few minutes and, in any case, it is "Disabled" and
> refuses to be Enabled.
>
> QUESTIONS: Anyone got ideas why the Internet Gateway icon comes and goes?
> And why it is Disabled and refuses to become Enabled?
>
> Before sending my initial request for help to this forum, I read many posts
> including several of your excellent posts, and have tried just about
> everything! Back to your list...
>
> I do not have Zone Alarm or ANY IP restricting software installed. The only
> IP restricting actions are those performed by the Hardware Firewall within
> my Linksys Router. I don't even have XP Firewall switched on. I do have
> McAfee VirusScan ASaP installed, but it doesn't claim to performing any IP
> filtering/restricting.
>
> In your item #2 you recommend disabling "File and Printer Sharing for
> Microsoft Networks" and "QoS Packet Scheduler.
>
> QUESTIONS: ". I would like (and do have) both of these activated - what, in
> your experience, is the effect of each of these being enabled?
>
> In item #3, you recommend having XP Firewall switched ON.
>
> QUESTIONS: Are you recommending that XP Firewall is switched on for reasons
> of "safety", or, in your experience, does firewall need to be switched on in
> order for the Internet Gateway icon to appear, and for MSN Messenger video
> conferencing to work correctly?
>
> I've tried everything else within your list of suggestions. Further
> assistance would be greatly appreciated.
>
> Kind regards,
> Alan
>
> "Efrain" <Efrain@discussions.microsoft.com> wrote in message
> news:CD77F009-227E-4D71-B71D-44AB0989184F@microsoft.com...
> > MSN Messenger 6.2.0205 audio/video requirements:
> >
> > 1. When using a high speed Internet connection, the modem/router MUST be
> > UPnP compatible and have this option active. For MSN Messenger 6.2.0205,
> > both
> > sides must have Windows XP. Set Zone Alarm to either medium or high, but
> > set
> > it to ALLOW the MSN Messenger 6.2.0205 all access to the Internet.
> >
> > 2. On the Network Connections, right click Local Area Connection, go to
> > Properties, and the General tab should show a check mark only on Client
> > for
> > Microsoft Network, and Internet Protocol (TCP/IP). No check on File and
> > Printer Sharing for Microsoft Networks, nor on QoS Packet Scheduler.
> >
> > 3. The Windows Firewall should be ON (recommended) and no check in Don't
> > allow exceptions . The Exceptions tab will later show the MSN Messenger
> > 6.2.0205 and UPnP Framework as being active.
> >
> > 4. In the Control Panel > Add Remove Programs > Add Remove Windows
> > Components, scroll to Networking Services and remove all checks, except
> > for
> > Internet Gateway Device Discovery (A), and for UPnP User Interface (B).
> > Click
> > Ok, Next, and after clicking Next the Windows Wizard Component will run.
> > Click Finish; now the UPnP will automatically open all required ports.
> >
> > 5. Sign in on Messenger and run Audio/Video Tuning Wizard. In the Tools >
> > Options > Connection tab, you should read You are connected to the
> > Internet
> > through a UPnP symmetric NAT. (Administrator); if you are using a dial-up
> > line it will read You are connected to the Internet using a direct
> > connection. Now check the Windows Firewall Exceptions list, the MSN
> > Messenger
> > 6.2.0205 and UPnP Framework will now have a check marks and the required
> > ports automatically opend.
> >
> > 6. Both Windows XP users sides should have similar setups, with working
> > webcams and microphones. Remember that one side can have dial-up and the
> > other a UPnP compatible modem/router.
> >
> > (A) Allow you to find and control internet connection sharing hardware and
> > software that uses UPnP.
> >
> > (B) Display icons in My Network Places for the UPnP devices detected on
> > the
> > network; also opens the required Windows Firewall port.
> >
> > Finally on MSN Messenger > Option > General tab, check mark under Sig in,
> > item 1 and 3 ( remove the checks after the restart, if you don't want
> > Messenger to startup ). Restart. Now the Internet Gateway icon is
> > displayed.
> >
> > "Alan Oliver" wrote:
> >
> >> Hi.
> >>
> >> Does anyone have suggestions why the Internet Gateway icon does not show
> >> up
> >> in my Network Connections? I noticed this because I'm trying to get MSN
> >> Messenger 6.2 (& 7.0) to successfully connect video and audio - and the
> >> MSN
> >> Messenger Tools|Options|Connection shows that I have a "non-UPnP port
> >> restricted NAT" - I suspect the two things may be linked.
> >>
> >> I am running XP Pro+SP2+hotfixes, and have ensured that SSDP Discovery
> >> and
> >> UPnP Hosting services are installed and enabled. The PC is connected
> >> wirelessly via a Linksys WRT54G router (with UPnP enabled) to a Broadband
> >> Cable Modem to the internet.
> >>
> >> Suggestions for fixes/further diagnostics would be appreciated.
> >>
> >> Kind regards,
> >> Alan
> >>
> >>
> >>
>
>
>
March 1, 2010 10:24:22 AM

I am having the same proplem with this "You are connected to the internet throught a non-UPnP port restricted NAt. (Administrator). I don't undertsand just waht tis means and have never had this show up in my Connections in Messenger before and suddenly it appears. I use a modem and don't have a router connected to my computer. Is this issue interfering with me try to gey into my other hotmail email address and messenger through this other email address. I also run Windows XP Professional. Any suggestions regarding this and is it inportant to have this UPnP thing running. Anyone want to contact me regarding this can get me at zeloczz4@hotmail.com

Many thanks
Patrick lavelle
!