Sign in with
Sign up | Sign in
Your question

Win98 says my 40 GB is 2 GB, help me?

Last response: in Windows 95/98/ME
Share
March 11, 2001 1:46:33 PM

Yesterday I put together my new PC and installed win98( 1st edition). Everyrhing works like a charm except it says my 40 GB Seagate U5 is 1,99 GB.

1. Could it be that I installed DOS 6.2 while waiting to get the win98 CD? I formatted C:, installed DOS, and FDISK said it was 2 GB. Then I formatted again and installed
win 98 and C: is still 2 GB. I have not partitioned the HDD.

2. In BIOS I can enable LBA and a setting called "Large" that is supposed to be used when DOS cannot use the whole HDD but none of them works for me.

3. I guess the 2 GB formatted in DOS 6.2 is FAT 16. Is FAT16 limited to about 2 GB?

4. If so, can it be that win 98 only recognices the FAT16 formatted part of the disk?

5. Can my problem be solved by converting it to FAT32? And will windows convert more than the 2 GB it knows and loves?

6. In the device manager my HDD is listed as "Generic IDE type 47". The only setting I can change is to enable DMA. Is this a good thing to do?

Any tips appreciated!

Abit KT7A, Duron 750, 128 MB PC133 cas2, Seagate U5 40 GB,
Leadtek GeForce2 MX, SB 128 Vibra

More about : win98

Anonymous
March 11, 2001 8:23:43 PM

Some hardrives have a jumper setting that fools the motherboard into thinking that it is only a 2gb harddisk, mine does and its a seagate drive. This feature is for old motherboards that cant use large harddrives. You could also use the fdisk utilty to repartition and format your hardisk to FAT32.

Whats all this about square pegs and round holes?
March 11, 2001 9:06:07 PM

You are correct, DOS 6 suffers from the 2.1gb limitation.

Boot from a Windows startup disk (Win '95 OSR2, '98, etc..)

Delete your 2.1gb partition in FDISK and create a new primary partition, the full capacity of your HD should be recognized.

Format then install Windows.

I think Partition Magic or similar software may allow you to resize your 2.1gb device without the hassle of re-installation but I have no experience with these utilities :-(
March 11, 2001 9:10:26 PM

Oh and the 'generic type IDE 47' in device manager is normal.

DMA should be enabled. If you installed the UDMA drivers from the CD that came with the motherboard, DMA should be enabled anyway.
Related resources
!