Sign in with
Sign up | Sign in
Your question

Boot Device Massive Delay

Last response: in Motherboards
Share
March 14, 2002 12:15:55 PM

After the system POST, it takes it a full 5 minutes to find a boot device. It doesn't matter what it tries to boot from either: CD, HDD, or Floppy. I have changed the boot sequences, disabled devices, etc., etc. I even reset the BIOS and updated the BIOS...problem continues.

Now, this is on an old Gateway 400 someone brought to me because they were having "HDD" problems (please save the WTFs, it isn't my system, just trying to help the guy). So, I put in a new HDD, and was able to get the OS and all the drivers installed...yet the 5 minute boot delay never went away. Finally, literally out of nowhere, the system would no longer boot in anything but DOS or Safe Mode from the HDD.

This oddity, coupled with the delay on boot, has led me to declare the Mobo officially dead. I can think of no other reason for this sort of behavior, as I have never in my life experienced a system take so long to simply find a boot device. It is as if the IDE and Floppy controllers (or CMOS) are simply hanging on by a thin thread.

Again, after the full 5 minute delay, the system finds the device and boots normally (unless it is the HDD, it only goes into DOS or Safe Mode now, heh). Anyone ever experience this boot delay phenomenon? What was the culprit?
March 14, 2002 12:57:09 PM

Not a clue what would cause that.... the only thing I can think of off the top of my head would be to try changing the CMOS battery. Maybe it's dying?
Anonymous
a b V Motherboard
March 14, 2002 2:45:11 PM

the JUMPERS on your ide devices may be set wrong. i've had that problem before and it was the jumpers.
Related resources
March 14, 2002 3:01:55 PM

i usually set it to cable select, just in case i want to throw it in another machine, then i wouldnt have to worry about changing the jumpers..unless that computer is so old that it wont support cable select...but that is becoming a rarity.

-DAvid

-Live, Learn, then build your own computer!-
March 14, 2002 3:14:53 PM

None of that is the problem.

Also, consider this:

I disabled ALL boot devices EXCEPT the floppy drive. It STILL took 5 minutes just to boot off the floppy, with nothing else even enabled.

I am pretty certain the mobo is messed up, ceretainly the drive controllers. Whatever caused it destroyed the original HDD. So short of a physical failure somewhere, the only thing I can even think it would be is the CMOS. I will try to replace the battery and see what happens, but I doubt it will help simply due to the nature of the problem. The drive controllers are simply not working properly. I even tried different cables (just to be complete, heh), and no dice. I still say the mobo is simply finished.
Anonymous
a b V Motherboard
March 14, 2002 3:17:29 PM

that may be your problem right there. i NEVER use cable select. i have had nothing but problems with it. i have a friend who just built a brand new system and had the same boot delay problem and it was because he was using cable select instead of the CORRECT jumper settings. i highly recommed trying the proper jumper settings.
March 15, 2002 1:18:00 AM

I also suggest using master or slave jumpers, but he stated that he tried with ONLY the floppy enabled, although unless he actually unplugged it then it may still create problems. I dont think he made that clear. It does sound alot like the board is hosed though, at least the BIOS or controller. How old is this sucker? Maybe its not worth playing with if its older.....

Jesus saves, but Mario scores!!!
Anonymous
a b V Motherboard
March 15, 2002 4:36:43 AM

no no no thats not what you want to do. don't just disable them in the bios you want to physically UNPLUG those ide ribbons and then try booting off the floppy. also try unplugging EVERYTHING except the primary ide ribbon with ONLY the hd on it set as MASTER. THEN if you still get this delay problem i'll believe maybe its a bad board. get rid of all pci cards and the flopy drive when doing this.

i'm tellin you i've seen this exact bios delay problem a million times and its always been cause the jumpers were set wrong. where exactly in the bios is it hanging? if its during ide device detection then i'd say it was definitely the jumpers. (or a bad hard drive)

and as far as your other problem goes with the operating system acting up weird i have experienced similar problems like that and the problem was bad memory stick. but if the system was working before with that memory in it then thats probably not the problem. try using only one stick of memory you know works. it does not sound like your motherboard is dead you are just having a hell of a time debugging the problem.
March 15, 2002 8:12:31 AM

Quote:
i NEVER use cable select. i have had nothing but problems with it

I tend to agree with you on that one, although I've encountered drives which actually wouldn't work jumpered M/S, only CS. Go figure.

<i>It's always the one thing you never suspected.</i>
March 15, 2002 1:34:33 PM

Heh, well the jumpers are not set incorrectly. Consider that the machine began with these problems after a power failure to the person's house. Everything was working fine until then. So you see, no jumpers have changed. Now, I DID set the jumpers on the NEW HDD to Master (and I assure you it is correct). Still, I disabled all devices in the BIOS but the floppy, physcially removed the cables on the IDE controllers (HDD=1, CD=2), and the only other thing on the board is the video (which is integrated).

The problem persists. Consider that the "hang" occurs after the memory test (which completes and indicates is ok). It then simply gives me the message "Wait..." while it hangs for 5 full minutes. Once the device is found, it boots with no problems. So COULD it be memory? Possible but not likely to cause this particular phenomenon.

I have reset the BIOS, and updated it. Problem persists. I have already explained what else I have done.

One last thing toi consider: the NEW HDD, after changing NOTHING, boots with ZERO problems on 2 other machines I tried.

I insist it is the mobo.
March 15, 2002 3:10:28 PM

im leaning toward a bad cable. let us know what happens when you take out all the ide cables and leave just the floppy cable.

i went to the tomshardware forums and all i got was this lousy signature.
March 15, 2002 3:20:49 PM

have you changed the IDE cable?

many a times a faulty cable reads bad data that has to be reread and reread (all that CRC and error checking stuff) untill its valid. it happened with me once, the machine crashed randomely, any moment from switching it on to booting into windows and starting some application. sometimes it took a long time to boot (not 5 minutes though) sometiems it hung!

i switched the cable and there! it was good as new!!

girish

<font color=red>Nothing is fool-proof. Fools are Ingenious!</font color=red>
Anonymous
a b V Motherboard
March 15, 2002 4:25:29 PM

Quote:
the machine began with these problems after a power failure to the person's house. Everything was working fine until then.


you should have said that in the first place. that can definitely damage your hardware. i have seen it happen before several times. only problem is you dont know which part or parts of your hardware were damaged.

i still, howerver, have not seen sufficient evidence to conclude your board is bad. infact, i bet i could get it working! jk. you really need to thoroughly follow all of the debugging steps that the nice poeple in this forum posted for you.

i still want to see if there is a delay when you try booting off a floppy with ONLY the following components hooked up: floppy, video card, memory, power supply, cpu. i want those other ide ribbons UNPLUGGED from the motherboard when you try this.

everyone always likes to jump to the conclusion that their board must be dead cause it's the easy way out. but since your board can power on and has booted slowly, i dont believe this is the case.
March 15, 2002 6:30:53 PM

Ok, it isn't the mobo. It was the BIOS. I will explain. (And sorry I didn't mention the power surge thing earlier)

First, I tried EVERYTHING everyone here suggested, and the problem continued. I then tried several other things I won't bore you with. Keep in mind, this problem persisted even when I had PHYSICALLY detached all the drives, and disabled them in the BIOS. However, I have found the problem, and the system is now running flawlessly.

I finally got to a point where I was trying various BIOS settings that would have anything to do with the problem. Here is what finally fixed it:

On the Secondary Master Device (CD drive), the setting was on ATAPI CD-ROM. I changed this to AUTO DETECT. Again, bear in mind that the drive was physically detached, and disabled in the boot sequence. I reboot. Problem is gone. WTF? I go back in (again, device NOT attached, and disabled in boot sequence) and put it back to ATAPI CD-ROM. Reboot. Problem is back. Obviously, I go back in and change it to AUTO DETECT. I then attach everything, enable, and enable in the boot sequence. System begins running flawlessly.

The BEST part?? AUTO DETECT, of COURSE, detects the device as ATAPI CD-ROM. However, if you SET it to ATAPI CD-ROM, the system simply WILL NOT WORK. Bizzare.

Anyway, the system is now running smoothly (well, as smoothly as a Gateway can run, heh).

Thanks to everyone who chimed in. No matter how long I do this stuff, I still find something new each and everyday. If nothing else, your suggestions kept me looking for the culprit, because I was absolutely ready to declare the mobo dead. Due to the bizzare nature of the problem (and subsequent fix), and the events that led to the system having problems in the first place, it was hard not to lay the blame there. However, I agreed with the poster who said it is easy to jump to that conclusion when problems of this nature arise. I have personally never had a mobo fail on me (plenty of other parts, though heh), and I have built many, many machines. However, there is a REASON I avoid BB/Gateway/Dell. This is no small part of the reason, to say the least.

Have a good weekend, and thanks again!
Anonymous
a b V Motherboard
March 15, 2002 10:56:25 PM

A-HAH! see i knew it wasnt dead. lol. you just gotta keep playing around with the settings till u get it right. i've always used AUTO for each ide device in the bios. i've never heard of any problems manually setting each ide device though.
!