Linksys WRT54G WEP Problems

Archived from groups: alt.internet.wireless (More info?)

Well, as the title suggests, i'm having problem with WEP with my new
Linksys WRT54G wireless router.

With WEP disabled my laptop (an Acer 2012WLMI, with an Intel Wireless
adapter) connects fine and everything is lovely. However, if i enable
WEP the laptop refuese to conect. Obviously, i have entered the WEP key
when trying to connect but it simply wont have it. It just continues to
say that a network is available blah blah. This is all with 128bit WEP.
I just managed to get the laptop to connect using 64bit, however, it
wont share the internet connection! This is most frustrating as you
might imagine.

Anyone got any ideas? Both PC and Laptop are running Windows XP.

Thanks


--
goose
brought to you by http://www.wifi-forum.com/
11 answers Last reply
More about linksys wrt54g problems
  1. Archived from groups: alt.internet.wireless (More info?)

    i had similar problems with my wrt54g and centrino platform until i upgraded
    the firmware in the linksys. make sure you're up to date.

    jtm
  2. Archived from groups: alt.internet.wireless (More info?)

    I have the same router you have and I did setup a 64-bit WEP key. On my
    laptop and my two desktops (all running XP) I have D-Link DWL-122 dongles.
    All this seems to be working OK and has worked fine for over a month now. I
    did have kind of a problem with the laptop in that it took a long time to
    connect to the network with it. I solved this by adding the little extension
    wire that comes with the dongle and getting the actual device away from the
    back of the laptop. For some reason that completely fixed the problem with
    the laptop. It appears that when the link quality is not good, the thing
    just doesn't work as well.

    I picked a 64-bit key rather than the 128-bit key because I feel that all
    this is just like putting a lock on your door. It only keeps honest people
    out and will keep out the occasional person just looking for a free WIFI
    connection. Nothing will keep out a determined person who has the knowledge
    and the software to do real mischief.

    As you can probably tell, I am no expert. I was just successful at setting
    up my own little network. To know what is the problem, everybody would have
    to know more about how you set everything up. Sorry, I can't be of any real
    help here.

    "goose" <goose.19ebqy@no-mx.forums.yourdomain.com.au> wrote in message
    news:goose.19ebqy@no-mx.forums.yourdomain.com.au...
    >
    > Well, as the title suggests, i'm having problem with WEP with my new
    > Linksys WRT54G wireless router.
    >
    > With WEP disabled my laptop (an Acer 2012WLMI, with an Intel Wireless
    > adapter) connects fine and everything is lovely. However, if i enable
    > WEP the laptop refuese to conect. Obviously, i have entered the WEP key
    > when trying to connect but it simply wont have it. It just continues to
    > say that a network is available blah blah. This is all with 128bit WEP.
    > I just managed to get the laptop to connect using 64bit, however, it
    > wont share the internet connection! This is most frustrating as you
    > might imagine.
    >
    > Anyone got any ideas? Both PC and Laptop are running Windows XP.
    >
    > Thanks
    >
    >
    > --
    > goose
    > brought to you by http://www.wifi-forum.com/
    >
  3. Archived from groups: alt.internet.wireless (More info?)

    "James R. Brown" <heavy-duty@earthlink.net> wrote in
    news:7zfJc.6089$Jk2.1297@roc.nntpserver.com:

    <snip>
    > I picked a 64-bit key rather than the 128-bit key because I feel that
    > all this is just like putting a lock on your door. It only keeps
    > honest people out and will keep out the occasional person just looking
    > for a free WIFI connection. Nothing will keep out a determined person
    > who has the knowledge and the software to do real mischief.
    <snip>

    I'm not an expert either, but disagree with this view. The well known
    weakness of WEP requires gathering a lot of transmission packets - for an
    individual home user, just changing the WEP key weekly will take care of
    the problem.

    As to key size, WEP uses a 24 bit IV, so the 64 bit key is really only a 40
    bit key, while the 128 bit key is really a 104 bit key. A 40 bit key can
    be brute forced on a home computer within an hour or so - a 104 bit key
    cannot currently be brute forced by any computer.

    --
    Tom McCune
    My PGP Page & FAQ: http://www.McCune.cc/PGP.htm
  4. Archived from groups: alt.internet.wireless (More info?)

    fwiw, i'm running wpa-psk/tkip on my wrt54g and two centrino notebooks. not
    without problems but livable. the problems appear to be the microsoft client
    getting confused. i'm hoping that the long awaited update fixes it.

    for me doing a suspend and resume after the first cold boot and subsequent
    loss of connection brings the connection up and maintains it solidly. still
    annoying though. drives wife and daughter crazy and they pass it along. ;-)

    i'm a bit frustrated however with the lack of wireless printer support under
    wpa. i'm hoping it will be forthcoming after msft gets the client stable
    with the update in august.

    i haven't seen anyone question wpa security however.

    jtm
  5. Archived from groups: alt.internet.wireless (More info?)

    Hi goose! I was just surfing the net and I saw your message. I know a
    little
    something about linksys devices so I thought you might want to try
    this:

    right click on your wireless network connection icon under network
    connections in control panel, go to properties and then go to
    properties of "internet protocol tcp/ip", click the authentication
    tab, then uncheck "Enable Network Access control using IEEE 802.1x"
    option, click on okey. Reconect to your network (SSID) and then
    restart your computer.

    usually, when your system keeps on telling you that one or more
    networks are available yet you can't connect, this means that your
    current hardware dosent
    support the 802.1x authentication.

    by the way, your problem about the 64 bit wep key, what do you mean
    when you say you can't share the internet.
  6. Archived from groups: alt.internet.wireless (More info?)

    Jim,

    What do you mean about lack of wireless printer support? Are you using
    TCP/IP or IPX/SPX? If IPX/SPX, switch to TCP/IP (and NetBIOS over TCP/IP)
    since there are issues with IPX/SPX (works fine for wired clients but not
    wireless clients and the WRT64G). Then, assign the printer server an IP
    address below the router's DHCP range (i.e. 192.168.1.99 if the range starts
    at 192.168.1.100). On the wireless computers, manually add a local printer
    on a new TCP/IP port (192.168.1.99).

    In terms of initially losing WPA-PSK connectivity; if you logoff, does the
    computer become disconnected from the router (and a few minutes after the
    first logon)? If so, there is a registry fix that will prevent that.
    Hopefully, this will be corrected in SP2 (at least to the extent that you
    can make the needed change without editing a registry key).

    -Yves

    "Jim Miller" <jim@NOSPAMjtmiller.com> wrote in message
    news:Ef2dnVuIh_S5UmjdRVn-uA@comcast.com...
    > fwiw, i'm running wpa-psk/tkip on my wrt54g and two centrino notebooks.
    not
    > without problems but livable. the problems appear to be the microsoft
    client
    > getting confused. i'm hoping that the long awaited update fixes it.
    >
    > for me doing a suspend and resume after the first cold boot and subsequent
    > loss of connection brings the connection up and maintains it solidly.
    still
    > annoying though. drives wife and daughter crazy and they pass it along.
    ;-)
    >
    > i'm a bit frustrated however with the lack of wireless printer support
    under
    > wpa. i'm hoping it will be forthcoming after msft gets the client stable
    > with the update in august.
    >
    > i haven't seen anyone question wpa security however.
    >
    > jtm
    >
    >
  7. Archived from groups: alt.internet.wireless (More info?)

    On Fri, 16 Jul 2004 07:32:32 -0700, Yves Konigshofer spoketh

    >Jim,
    >
    >What do you mean about lack of wireless printer support?

    I bet he means that wireless print servers doesn't (yet) support WPA...

    Lars M. Hansen
    http://www.hansenonline.net
    (replace 'badnews' with 'news' in e-mail address)
  8. Archived from groups: alt.internet.wireless (More info?)

    yves

    i've been searching unsuccessfully for a standalone wireless print server
    rather than using a pc. i'm assuming that once some issues with wpa msft
    client get sorted out the print server manufacturers will decide it's worth
    doing. right now you have to drop back to wep if you want a non-pc print
    server.

    i'd like to hear more about the registry edit. i'm comfortable with those.

    tnx
    jtm

    "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message
    news:cd8ouo$qfs$1@news.Stanford.EDU...
    Jim,

    [...]

    In terms of initially losing WPA-PSK connectivity; if you logoff, does the
    computer become disconnected from the router (and a few minutes after the
    first logon)? If so, there is a registry fix that will prevent that.
    Hopefully, this will be corrected in SP2 (at least to the extent that you
    can make the needed change without editing a registry key).

    -Yves
  9. Archived from groups: alt.internet.wireless (More info?)

    In XP, edit the registry and add a DWORD registry key called "AuthMode" (no
    quotes) to
    "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EAPOL\Parameters\General\Global" set
    it to 2 (i.e. 00000002) and restart the computer afterwards.

    As for print servers, I guess you could try to use a wired print server and
    connect it to a wireless game adapter that supports WPA (although, I do not
    know if any do).

    -Yves

    "Jim Miller" <jim@NOSPAMjtmiller.com> wrote in message
    news:QIKdnVk697veimXdRVn-ig@comcast.com...
    > yves
    >
    > i've been searching unsuccessfully for a standalone wireless print server
    > rather than using a pc. i'm assuming that once some issues with wpa msft
    > client get sorted out the print server manufacturers will decide it's
    worth
    > doing. right now you have to drop back to wep if you want a non-pc print
    > server.
    >
    > i'd like to hear more about the registry edit. i'm comfortable with those.
    >
    > tnx
    > jtm
    >
    > "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message
    > news:cd8ouo$qfs$1@news.Stanford.EDU...
    > Jim,
    >
    > [...]
    >
    > In terms of initially losing WPA-PSK connectivity; if you logoff, does
    the
    > computer become disconnected from the router (and a few minutes after the
    > first logon)? If so, there is a registry fix that will prevent that.
    > Hopefully, this will be corrected in SP2 (at least to the extent that you
    > can make the needed change without editing a registry key).
    >
    > -Yves
    >
    >
    >
  10. Archived from groups: alt.internet.wireless (More info?)

    yves

    where did you find that hack?

    tnx
    jtm


    "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message
    news:cd9sll$l69$1@news.Stanford.EDU...
    In XP, edit the registry and add a DWORD registry key called "AuthMode" (no
    quotes) to
    "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EAPOL\Parameters\General\Global" set
    it to 2 (i.e. 00000002) and restart the computer afterwards.
  11. Archived from groups: alt.internet.wireless (More info?)

    It was posted here and elsewhere some months ago. It configures the way the
    computer attempts to authenticate. The default is to initially authenticate
    using computer credentials and then user credentials upon logon (and then
    back to computer credentials upon logoff). Why this matters with WPA-PSK
    (with WPA, I could understand), I do not know. In any case, the
    authentication with user credentials seems to cause the wireless card to
    dissociate from the access point. Setting AuthMode to 2 forces XP to only
    use the initial computer credentials (seemingly meaningless in WPA-PSK) and
    never authenticate using user credentials. This can apparently be
    configured with a wireless snap-in in MMC under Server 2003 but not under
    XP.

    I think there have been fewer postings regarding this registry modification
    in recent months because more and more wireless cards are including WPA
    supplicants and client software to replace WZC (and to get WPA working under
    W2k). As far as I know, the current Linksys cards no longer recommend
    against installing their utility on XP.

    -Yves

    "Jim Miller" <jim@NOSPAMjtmiller.com> wrote in message
    news:A4udnaooEaPlhWTdRVn-hA@comcast.com...
    > yves
    >
    > where did you find that hack?
    >
    > tnx
    > jtm
    >
    >
    > "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message
    > news:cd9sll$l69$1@news.Stanford.EDU...
    > In XP, edit the registry and add a DWORD registry key called "AuthMode"
    (no
    > quotes) to
    > "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EAPOL\Parameters\General\Global"
    set
    > it to 2 (i.e. 00000002) and restart the computer afterwards.
    >
    >
    >
Ask a new question

Read More

Laptops WEP Linksys Wireless Networking