Sign in with
Sign up | Sign in
Your question

HL2 pauses...arg

Last response: in Video Games
Share
February 11, 2006 11:45:57 PM

Ok, here is what pisses me off, you can see i have a pretty decent gaming rig, older perhaps, but not slow. And i have alot of RAM. But half-life 2 still has those annoying pauses every little while, it really anoys me. So i figured i'd look and see how much physical ram is being used, and to my surpise only 500~700 mb of physical ram was being used(measued while game was mininized). I have 2 GB or ram, is there any way i can tweak the game engine to use more physical ram and less page file? I don't want to have to buy a $250 raptor 150gb 10000rpm drive just to enjoy a 50$ game when the cause it dumb a** coding.

More about : hl2 pauses arg

February 12, 2006 3:10:33 AM

hah mine did the exact same thing, in every game. for some reason it stopped when i got my athlon64 3800 hmmm,odd. but i never found a cure i dont even know if its page fileing but i dont remember who but if you have over 2Gigs you can disable page fileing i forgot and and who told me. Good Luck.
February 12, 2006 9:21:15 AM

How frequently does it pause?
Related resources
February 12, 2006 4:10:50 PM

i'd say every 20 or 30 seconds, like on the airboat ride, every time i'd round a corner or go through some boxes or something the hd activity led lights up and it pauses for just a half a second, not much but plenty to notice.
February 12, 2006 7:09:33 PM

damn i shoulda knocked on wood, now im gettin the pauses again. its like ever 1 or 2 secs, but its constant it always happens at the exact same time. it happens in quake 4 for me also.
February 12, 2006 7:15:36 PM

It is a famous bug that's still not found because it's not related to your cpu, gfx board, mobo, or memory. It could be some specific combination of the afore mentioned though. The jury is still out on it. I had it on my previous gaming rig. My current rig doesn't have it. For some reason Source creates a lot of HD access on some configurations while not doing it on others. Seems that it is more frequent on older configurations because the general noise about the bug has died down some. It's not just limited to HL2 either, as I had it also with Vampires the Masquerade: Bloodlines, but it was most noticable on HL2.

Maybe it gets a faulty reading on the available amount of physical memory from some mobo's? Maybe only if it's some specific brand or type of memory?
February 12, 2006 7:17:06 PM

Quote:
damn i shoulda knocked on wood, now im gettin the pauses again. its like ever 1 or 2 secs, but its constant it always happens at the exact same time. it happens in quake 4 for me also.


Different game engine, so probably not related to captain_insano's problem.
February 12, 2006 8:45:04 PM

I've noticed similar slowdowns that were alleviated when I turned off my antivirus. Try disabling the real-time file scanning if you're running an antivirus program.
February 13, 2006 12:48:40 AM

i dont have an ativirus and have absolutly nothing i dont need running, different engine or not its still there.
February 13, 2006 7:51:29 AM

@ d3vNULL: that's too simple. It's a known bug. Presume some computer literacy here. We also assume that captain is not downloading other stuf while playing HL2.


Quote:
i dont have an ativirus and have absolutly nothing i dont need running, different engine or not its still there.

Let's stick to the topic though which is this problem with Source (HL2). It is very unlikely that your problem is related to this, so start up a new topic if you think it's worth it.
February 13, 2006 11:19:41 PM

i was just answering his question dude...and i still have his same problems in hl2. no need to start a new thread, thatd be pointless.
February 14, 2006 5:42:49 AM

Quote:
i was just answering his question dude...and i still have his same problems in hl2. no need to start a new thread, thatd be pointless.


Thing is, it's been widely reported by people having Source games installed. Everything else works fine for them. You say you have a similar pauzing prob (2 to 4 sec intervals, right?) and you also have it with Q4. There is no way telling whether you have the same problem as captain describes, and odds are you do not because you have this problem with different game engines.

Given the very short intervals you mention, whereas the famous Source bug is more typical 30 second intervals upto a minute (it varies somewhat), I suspect you have some malware on your system that is constantly accesssing or trying to access the net. I still think you should start a new topic but I'm not going to force you. Try playing without an internet connection and see if it's either gone, or maybe you get much longer pauses (network timeouts).
February 15, 2006 10:03:52 PM

haha are you kidding malware i havent had a bug for 3 years, i play q4 with net off as it is not a legit version and have tried with hl2 but yeah as you said mine are every 1 sec his are 30-60. my guess would be its loading some textures on the harddrive for no reason( i have a gig) and thats whats doing it i hate microsoft so much, id go linux in a second if they had better game support.
February 15, 2006 10:37:53 PM

sounds wierd but try lowering the fsb on your cpu, on my old gaming rig i had the same problem with a few games as it happens when i put my hardware back at stock levels the pausing would stop and there wouldnt be any extra HDD access... so try putting everything back to stock and see if it happens...
February 19, 2006 2:19:09 PM

right now i'm running stock speeds on everything except my video card. I also tried PCI Latency tool, to no avail. Right now i had to send in my Ram to get it replaced by OCZ, wouldn't OC at all with 4 dimms filled but worked beautifuly with 2. So they are replacing my 4x512 with 2x1024 PC4000 Gold GXT. Currently i am pirating 2x512 from my second system that i run stock that has a 3200 winnie, 9800 Pro, 4x512 Corsair XMS Low latency stuff with the activity indicators. So trouble shooting is moot at this point as i get LOTS of load lag in FEAR, BF2, to some degree more in HL2. I also am having problems running almost ALL of my older games. I tryed setting the processor affinity to core 0, and then to core 1. That did help, but some of my favorite games have address errors ONLY when playing LAN games. Its wierd, of course I do have 8.22 R5 Remix Nforce drivers, perhaps that's the culprit, i may try the 5.11's and see if that helps. But from what i used before the 8.22's seemed alot faster, maybe it was just me, i suppose i could bench mark it on 3dMark 06 and see if there is any real gain.
February 20, 2006 4:22:36 PM

I always get nailed by scripted events, most especially whenever Dr. Breen's pasty face pops up on a screen to exhort the populace with long-winded tirades.

When I first got Half Life, I didn't have pauses at all. They were introduced in the first update, and made hideously worse in subsequent updates.

I just learned to live with it.
February 23, 2006 1:47:52 PM

Maybe they will fix it, alot of people criticize steam, i know i have, but i also realize of usefull it is. I NEVER have to go and download upates for CSS, DODSource, HL2 or anything, it automatically does it. It seems that if they serously scew something up, like they released that update to the bumpmapping that made the rian water a chalky white, so you could see it more, they removed it the next week because people thought it looked stupid. Maybe i'll drop them a line and let them know, they seem to respond to fans quite well, so maybe its possible for them to create an option where it detects your system memory andt then uses more physical ram instead of page file. Either that or get a WD Raptor to reduce it.
!