Sign in with
Sign up | Sign in
Your question

Oblibion Lag/Video Problem

Last response: in Video Games
Share
April 8, 2006 4:45:40 PM

hi,

I bought the Oblivion collector's DVD 2 days ago but i can't seem to make it playable at all. i searched for anwsers on bethesda and many forums, without any luck.

When i first launched the game, the autodetect feature granted me a 'ultra high quality' setting, wich i felt was great, since i just bought a new video card. Pretty much everything is on high, except for the shadows wich are disabled. Indoors i would get anywhere from 10 to 25 frames, but outside, it dropped to 7-10 FPS with the default settings. I tought that this wasnt right, searched the net, downloaded the new nvidia's beta 84.25 drivers and changed a setting called 'max frames to render ahead=0 (tried 1 and 2 also)' instead of 3 in the nVIDIA control panel. The mouse lag almost completely disapeared, and now i get 30-40 FPS indoors. Of course, i took care to disable all the background programs like steam, anti-virus, search desktop, etc...

Outdoors is still unplayable. it drops to 7 FPS way too often. i dont see any difference in FPS outdoor even with all the 'fade' sliders to minimum. If i turn on shadows (except the self grass shadow), and set the sliders to the maximum, theres only a 2-3 fps impact. turning down the resolution is not really helping either (+/- 5fps difference from 800x600 to 1024x768).

The game crashes to desktop every 5-10, sometimes 30 minutes and i get this error in the event viewer:

Faulting application oblivion.exe, version 0.1.0.228, faulting module oblivion.exe, version 0.1.0.228, fault address 0x00001669.

or:

Faulting application oblivion.exe, version 0.1.0.228, faulting module kernel32.dll, version 5.1.2600.2180, fault address 0x0000979d.


As a last resort, i decided to overclock my video card's memory from 400 to 460 and the GPU from 1250 to 1400. not a single frame change.
EDITED: Overclocked the Processor from 3.0 to 3.3Ghz, still, no changes in the framerate.

I'm pretty much certain that this could be fixed without buying another computer. i don't feel that i should bring back the game where i bought it, i can't wait to play and don't have to worry about those technical problems since they hold me back from being totally in the game.

sorry for the long post, but i prefered to give you all the details on what i did :) 

anyway, thank you for readind this far, here's my spec:
Enermax Liberty (ver1.3) 460 watts
Gigabyte GA-8IPE1000-G rev4.x
P4 Prescott 3.0e HT 1mb cache
4x512MB DDR400 Kingston Value Ram - PAT enabled
BFG Geforce 7800 GS OC 256mb
SoundBlaster Audigy 2 ZS
2xWesternDigital WD800JD 80GB SATA HD

thank you.
April 9, 2006 4:59:04 PM

Atari1980,

I've found 2 tweaks that save the day. My frame rate is (at least) 4 times what it was before applying these.

I'll paste below:


Quote:
------
b. NVIDIA card Coolbits tweak

This is one of the greatest driver tweaks I have ever seen. At first, I couldn't believe my results.
But the benchmarks don't lie; I nearly doubled my framerates after applying this tweak. There is no
noticeable drop in quality and no apparent side effects. I encourage everyone to apply this tweak.
It really is pretty unbelievable. Steps:

1. Download and install the latest NVIDIA ForceWare drivers.
2. Download and install the "Coolbits" registry tweak:
http://downloads.guru3d.com/download.php?det=815
(To install, unzip then double-click the .reg file to apply the registry mod)
3. Go to Control Panel -> Display -> Settings tab -> Advanced -> GeForce XXXX (your card model)
4. Expand "Performance & Quality Settings"
5. Click on "Additional Direct3D Settings"
6. Change "Max Frames to render ahead" from 3 to 0.
7. Click "Apply" then "OK" to exit the settings page.

Start Oblivion and note the huge, huge difference in input responsiveness and framerate consistency.
Please note that I have heard that 7xxx card users have not been seeing much improvement from this
tweak. It may only relate to 6xxx series cards and below.
(Huge thanks to justice7 from the Oblivion forums)

------



The second is to limit the amount of "Grass" in the game. This tweak has a pretty unbelievable effect on framerate, and honestly doesn't impact the visual quality of the game. In fact, it arguably makes it look better because with less grass, you can then tweak the grass fade distance to see grass further in the distance. The effect on framerate of this tweak has been awesome:

Quote:

This one should work for BOTH ati and nvidia. Basically its a collection of grass tweaks. The most important one is grass density. Its:
iMinGrassSize
Higher numbers means less density/less grass, lower numbers are for more grass/more density. The linked thread suggests 200 for this, Flashfire suggests 160 for a better balance of FPS and good graphics.
http://www.elderscrolls.com/forums/index.p...howtopic=2...
Note that the other two variables mentioned in that thread increase the draw distance for grass, you may or may not want to experiment with those depending on how this tweak works/looks for you.
Alternatively, if you have an uber high end system and you want to turn on more graphical options to make the game look nicer, crank up the grass density and draw distance smile.gif
Make sure that you are editing the proper oblivion.ini (NOT Oblivion_default.ini), location is above
(also, there are some reports of the game resetting the grass values in the .ini, it may be nessasary to turn on the read only attribute for the .ini file while playing, and turn it off to edit. Let me know if you can confirm this is correct or not)
April 9, 2006 5:22:52 PM

The grass tweak worked! and it didn't affect image quality at all. It managed to keep my fps between 15-25fps all the time. plus i can turn on the 'shadows on grass' feature, wich dropped the fps, but never below 15. great !

thank you very much, i really do appreciate! Now i'll be able to enjoy the game a bit. :) 

i still hope there will be some drivers(nVIDIA) and or engine (Bethesda) improvement though. Because it still crashes here and there.
Related resources
April 11, 2006 11:18:27 PM

Quote:
wich i felt was great, since i just bought a new video card.


Just wondering, was your old video card nVidia as well? If not, you might try using a utility like driver cleaner (http://drivercleaner.net) to make sure you don't have any bits of your old driver hiding somewhere on your drive (which can cause strange problems).
April 12, 2006 1:41:30 AM

yes my old videocard was nVIDIA (MSI 6600GT 128mb). i always use drivercleaner to remove old drivers when a new driver comes out from nvidia. but as i bought 2 new SATA HDs, i had to reinstall everything, so this is a fresh XP install.
April 12, 2006 7:30:23 AM

I've got tell you. I'm extremely surprised - based upon your specs - that you had such problems.

Extremely surprised.

If your system struggled then mine most certainly will.
April 12, 2006 4:08:33 PM

Quote:
yes my old videocard was nVIDIA (MSI 6600GT 128mb). i always use drivercleaner to remove old drivers when a new driver comes out from nvidia. but as i bought 2 new SATA HDs, i had to reinstall everything, so this is a fresh XP install.


Hmm. Then the only thing I can suggest is a ram issue. I assume the 4 sticks are all matched and if not matched, at least running at the same speed. Try taking two sticks out (just run 2x512 - try it both DC and non-DC) and see if that makes a difference.
April 13, 2006 12:29:01 AM

Nil, yes i tought that it could be a memory problem ran memtest86, wich discovered errors when 4 sticks (in Dual Channel) are used. each is tested fine alone or when using only 2 stick in dual memory. but this could be something else than just memory problem, i mean 285650 errors on each megabyte at 98% in test #5 (block move, 64 moves), even when raising timings and disabling PAT... (there is something i read about memtest being sometime confused on the memory size in some system: leading it to test memory that doesnt exists, wich would explain why i get so many errors) IF it would really have been the memory i guess i would have ran into more serious problems long before oblivion (in FEAR, or Doom 3 for example). i'm on the case, on the memtest86 forum.

note: lowering the timings, from 3 to 2 and raising the fsb from 200 to 210 did not worsen the situation. i get the same amount of errors, always on 98%. and what's a bit akward is that in the test,for every 1%, it takes 1-2 seconds, but at 95% it literally jumps to 98%.(and then it starts reporting errors)

BomberBill, what's your system specs?
April 13, 2006 10:19:10 PM

should work well..hope it gets fixed cuz its a great game...darn that vampire!!!
April 14, 2006 3:57:11 AM

well guys, i think i fixed the crash problem... i bought a pair of 2x 1GB DDR500 OCZ EL Gold PC4000 (running at 200mhz 2.5-3-3-5) and it hasnt crashed yet, after an hour or so of playing. But not a single framerate change :( 
!