Confused on Folder Sharing

Archived from groups: alt.sys.pc-clone.dell (More info?)

OK -- somehow I am screwing this up.

I currently have a Dell Dim 2400. It is set up for Broadband with a Lynksys
router.

I also have a new Dell Inspiron 2200 with a wireless card.

All works perfectly and I've also taken some reasonable security precautions
(MAC filtering, disabling SSID broadcasting, etc).

Now, here is what I want to do.

I have a FOLDER on my desktop. I would like to be able to share this folder.
That is, I want to be able to use this folder with my desktop or with my
wireless. Let's suppose this folder is c:\george\washington

So, now I am attempting to join the wonderful world of file sharing and I
thought I did it correctly, but maybe not.

Firstly, I turned on my desktop and then the laptop. I ran Network Setup
Wizard on my desktop. When I ran thru the steps, perhaps I should have
chosen that this computer hooks up directly to the internet. But I chose
that it hooks up to the internet via a residential gateway (the picture in
the example seemed closer to what I had, but I'm not sure). I then followed
instructions and rebooted the desktop. I then ran the Wizard on the Wireless
and I chose the same thing. (I suspect these choices might not be correct!)

I then rebooted the wireless.

I then got on the desktop, right clicked the aforementioned file in Windows
Explorer and designated it to be shared by all computers on the network.

Well, when I check on the desktop under Windows Explorer it does appear that
the folder is enabled for sharing.

But I cannot find that shared folder anywhere when I use my Wireless.

Suggestions??

Also, if I have to change some setting, do I just start all over and re-run
the Network Setup Wizard?

Mel
8 answers Last reply
More about confused folder sharing
  1. Archived from groups: alt.sys.pc-clone.dell (More info?)

    >>>>> MB writes:

    MB> OK -- somehow I am screwing this up.
    MB> I currently have a Dell Dim 2400. It is set up for Broadband with a Lynksys
    MB> router.

    MB> I also have a new Dell Inspiron 2200 with a wireless card.

    MB> All works perfectly and I've also taken some reasonable security precautions
    MB> (MAC filtering, disabling SSID broadcasting, etc).

    MB> Now, here is what I want to do.

    MB> I have a FOLDER on my desktop. I would like to be able to share this folder.
    MB> That is, I want to be able to use this folder with my desktop or with my
    MB> wireless. Let's suppose this folder is c:\george\washington

    MB> So, now I am attempting to join the wonderful world of file sharing and I
    MB> thought I did it correctly, but maybe not.

    MB> Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    MB> Wizard on my desktop. When I ran thru the steps, perhaps I should have
    MB> chosen that this computer hooks up directly to the internet. But I chose
    MB> that it hooks up to the internet via a residential gateway (the picture in
    MB> the example seemed closer to what I had, but I'm not sure). I then followed
    MB> instructions and rebooted the desktop. I then ran the Wizard on the Wireless
    MB> and I chose the same thing. (I suspect these choices might not be correct!)

    MB> I then rebooted the wireless.

    MB> I then got on the desktop, right clicked the aforementioned file in Windows
    MB> Explorer and designated it to be shared by all computers on the network.

    MB> Well, when I check on the desktop under Windows Explorer it does appear that
    MB> the folder is enabled for sharing.

    MB> But I cannot find that shared folder anywhere when I use my Wireless.

    MB> Suggestions??

    MB> Also, if I have to change some setting, do I just start all over and re-run
    MB> the Network Setup Wizard?

    Are you using any firewalls?

    What shows up in "My Network Places" in windows explorer?

    ah


    --
    Andrew Hall
    (Now reading Usenet in alt.sys.pc-clone.dell...)
  2. Archived from groups: alt.sys.pc-clone.dell (More info?)

    Andrew:

    On the desktop, there are lots of sub-folders. One says:

    Washington on the Smith Computer (XXXXXXX)

    Where Washington is the filename I'm sharing and Smith must be the name I
    used when I first got the computer and (XXXXXXX) is I guess the ISP identity
    for the computer.

    I get none of that on the laptop.

    HOWEVER, on the desktop I can do My Network Places/Entire Network/Microsoft
    Windows Network/Home and it will list The Smith Computer(XXXXXX) and Joe
    and Mary's Laptop(XXX).

    On my laptop I have that structure but when I click on HOME it says access
    denied.

    Yes, I am using a firewall, ZoneAlarm.

    However, I disabled ZoneAlarm for a few seconds to see if that would make a
    difference and it did not.

    I then added the IP addresses of the 2 computers to the trusted zone in
    ZoneAlarm.

    I am still stuck

    MB


    <ahall@no-spam-panix.com> wrote in message
    news:kpgmzm4x0rn.fsf@panix1.panix.com...
    >>>>>> MB writes:
    >
    > MB> OK -- somehow I am screwing this up.
    > MB> I currently have a Dell Dim 2400. It is set up for Broadband with a
    > Lynksys
    > MB> router.
    >
    > MB> I also have a new Dell Inspiron 2200 with a wireless card.
    >
    > MB> All works perfectly and I've also taken some reasonable security
    > precautions
    > MB> (MAC filtering, disabling SSID broadcasting, etc).
    >
    > MB> Now, here is what I want to do.
    >
    > MB> I have a FOLDER on my desktop. I would like to be able to share this
    > folder.
    > MB> That is, I want to be able to use this folder with my desktop or
    > with my
    > MB> wireless. Let's suppose this folder is c:\george\washington
    >
    > MB> So, now I am attempting to join the wonderful world of file sharing
    > and I
    > MB> thought I did it correctly, but maybe not.
    >
    > MB> Firstly, I turned on my desktop and then the laptop. I ran Network
    > Setup
    > MB> Wizard on my desktop. When I ran thru the steps, perhaps I should
    > have
    > MB> chosen that this computer hooks up directly to the internet. But I
    > chose
    > MB> that it hooks up to the internet via a residential gateway (the
    > picture in
    > MB> the example seemed closer to what I had, but I'm not sure). I then
    > followed
    > MB> instructions and rebooted the desktop. I then ran the Wizard on the
    > Wireless
    > MB> and I chose the same thing. (I suspect these choices might not be
    > correct!)
    >
    > MB> I then rebooted the wireless.
    >
    > MB> I then got on the desktop, right clicked the aforementioned file in
    > Windows
    > MB> Explorer and designated it to be shared by all computers on the
    > network.
    >
    > MB> Well, when I check on the desktop under Windows Explorer it does
    > appear that
    > MB> the folder is enabled for sharing.
    >
    > MB> But I cannot find that shared folder anywhere when I use my
    > Wireless.
    >
    > MB> Suggestions??
    >
    > MB> Also, if I have to change some setting, do I just start all over and
    > re-run
    > MB> the Network Setup Wizard?
    >
    > Are you using any firewalls?
    >
    > What shows up in "My Network Places" in windows explorer?
    >
    > ah
    >
    >
    >
    > --
    > Andrew Hall
    > (Now reading Usenet in alt.sys.pc-clone.dell...)
  3. Archived from groups: alt.sys.pc-clone.dell (More info?)

    OK, I'm guessing you're running XP Home. There is a quirk in XP Home that
    you cannot share any files that are in the Documents and Settings directory.
    This includes both My Documents AND your desktop. There is a complicated
    work around, but I wouldn't recommend it.

    It's easier to share a folder in your C: drive. Just right click on it and
    choose sharing and then follow the wizard.

    Tom
    "MB_" <mel@prodigy.invalid.net> wrote in message
    news:ayDYe.2622$P7.1850@fe06.lga...
    > OK -- somehow I am screwing this up.
    >
    > I currently have a Dell Dim 2400. It is set up for Broadband with a
    > Lynksys router.
    >
    > I also have a new Dell Inspiron 2200 with a wireless card.
    >
    > All works perfectly and I've also taken some reasonable security
    > precautions (MAC filtering, disabling SSID broadcasting, etc).
    >
    > Now, here is what I want to do.
    >
    > I have a FOLDER on my desktop. I would like to be able to share this
    > folder. That is, I want to be able to use this folder with my desktop or
    > with my wireless. Let's suppose this folder is c:\george\washington
    >
    > So, now I am attempting to join the wonderful world of file sharing and I
    > thought I did it correctly, but maybe not.
    >
    > Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    > Wizard on my desktop. When I ran thru the steps, perhaps I should have
    > chosen that this computer hooks up directly to the internet. But I chose
    > that it hooks up to the internet via a residential gateway (the picture in
    > the example seemed closer to what I had, but I'm not sure). I then
    > followed instructions and rebooted the desktop. I then ran the Wizard on
    > the Wireless and I chose the same thing. (I suspect these choices might
    > not be correct!)
    >
    > I then rebooted the wireless.
    >
    > I then got on the desktop, right clicked the aforementioned file in
    > Windows Explorer and designated it to be shared by all computers on the
    > network.
    >
    > Well, when I check on the desktop under Windows Explorer it does appear
    > that the folder is enabled for sharing.
    >
    > But I cannot find that shared folder anywhere when I use my Wireless.
    >
    > Suggestions??
    >
    > Also, if I have to change some setting, do I just start all over and
    > re-run the Network Setup Wizard?
    >
    > Mel
    >
    >
  4. Archived from groups: alt.sys.pc-clone.dell (More info?)

    Tom:

    Yes I am aware of that.

    I am sharing (trying to) such a folder and I can't make it work just yet
    (hence my post)

    Mel
    "Tom Scales" <tomtoo@softhome.net> wrote in message
    news:dmFYe.93457$xl6.30002@tornado.tampabay.rr.com...
    > OK, I'm guessing you're running XP Home. There is a quirk in XP Home that
    > you cannot share any files that are in the Documents and Settings
    > directory. This includes both My Documents AND your desktop. There is a
    > complicated work around, but I wouldn't recommend it.
    >
    > It's easier to share a folder in your C: drive. Just right click on it
    > and choose sharing and then follow the wizard.
    >
    > Tom
    > "MB_" <mel@prodigy.invalid.net> wrote in message
    > news:ayDYe.2622$P7.1850@fe06.lga...
    >> OK -- somehow I am screwing this up.
    >>
    >> I currently have a Dell Dim 2400. It is set up for Broadband with a
    >> Lynksys router.
    >>
    >> I also have a new Dell Inspiron 2200 with a wireless card.
    >>
    >> All works perfectly and I've also taken some reasonable security
    >> precautions (MAC filtering, disabling SSID broadcasting, etc).
    >>
    >> Now, here is what I want to do.
    >>
    >> I have a FOLDER on my desktop. I would like to be able to share this
    >> folder. That is, I want to be able to use this folder with my desktop or
    >> with my wireless. Let's suppose this folder is c:\george\washington
    >>
    >> So, now I am attempting to join the wonderful world of file sharing and I
    >> thought I did it correctly, but maybe not.
    >>
    >> Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    >> Wizard on my desktop. When I ran thru the steps, perhaps I should have
    >> chosen that this computer hooks up directly to the internet. But I chose
    >> that it hooks up to the internet via a residential gateway (the picture
    >> in the example seemed closer to what I had, but I'm not sure). I then
    >> followed instructions and rebooted the desktop. I then ran the Wizard on
    >> the Wireless and I chose the same thing. (I suspect these choices might
    >> not be correct!)
    >>
    >> I then rebooted the wireless.
    >>
    >> I then got on the desktop, right clicked the aforementioned file in
    >> Windows Explorer and designated it to be shared by all computers on the
    >> network.
    >>
    >> Well, when I check on the desktop under Windows Explorer it does appear
    >> that the folder is enabled for sharing.
    >>
    >> But I cannot find that shared folder anywhere when I use my Wireless.
    >>
    >> Suggestions??
    >>
    >> Also, if I have to change some setting, do I just start all over and
    >> re-run the Network Setup Wizard?
    >>
    >> Mel
    >>
    >>
    >
    >
  5. Archived from groups: alt.sys.pc-clone.dell (More info?)

    Just another thought: could the router be the problem?

    MB
    "MB_" <mel@prodigy.invalid.net> wrote in message
    news:4GFYe.1483$L45.629@fe07.lga...
    > Tom:
    >
    > Yes I am aware of that.
    >
    > I am sharing (trying to) such a folder and I can't make it work just yet
    > (hence my post)
    >
    > Mel
    > "Tom Scales" <tomtoo@softhome.net> wrote in message
    > news:dmFYe.93457$xl6.30002@tornado.tampabay.rr.com...
    >> OK, I'm guessing you're running XP Home. There is a quirk in XP Home
    >> that you cannot share any files that are in the Documents and Settings
    >> directory. This includes both My Documents AND your desktop. There is a
    >> complicated work around, but I wouldn't recommend it.
    >>
    >> It's easier to share a folder in your C: drive. Just right click on it
    >> and choose sharing and then follow the wizard.
    >>
    >> Tom
    >> "MB_" <mel@prodigy.invalid.net> wrote in message
    >> news:ayDYe.2622$P7.1850@fe06.lga...
    >>> OK -- somehow I am screwing this up.
    >>>
    >>> I currently have a Dell Dim 2400. It is set up for Broadband with a
    >>> Lynksys router.
    >>>
    >>> I also have a new Dell Inspiron 2200 with a wireless card.
    >>>
    >>> All works perfectly and I've also taken some reasonable security
    >>> precautions (MAC filtering, disabling SSID broadcasting, etc).
    >>>
    >>> Now, here is what I want to do.
    >>>
    >>> I have a FOLDER on my desktop. I would like to be able to share this
    >>> folder. That is, I want to be able to use this folder with my desktop or
    >>> with my wireless. Let's suppose this folder is c:\george\washington
    >>>
    >>> So, now I am attempting to join the wonderful world of file sharing and
    >>> I thought I did it correctly, but maybe not.
    >>>
    >>> Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    >>> Wizard on my desktop. When I ran thru the steps, perhaps I should have
    >>> chosen that this computer hooks up directly to the internet. But I chose
    >>> that it hooks up to the internet via a residential gateway (the picture
    >>> in the example seemed closer to what I had, but I'm not sure). I then
    >>> followed instructions and rebooted the desktop. I then ran the Wizard on
    >>> the Wireless and I chose the same thing. (I suspect these choices might
    >>> not be correct!)
    >>>
    >>> I then rebooted the wireless.
    >>>
    >>> I then got on the desktop, right clicked the aforementioned file in
    >>> Windows Explorer and designated it to be shared by all computers on the
    >>> network.
    >>>
    >>> Well, when I check on the desktop under Windows Explorer it does appear
    >>> that the folder is enabled for sharing.
    >>>
    >>> But I cannot find that shared folder anywhere when I use my Wireless.
    >>>
    >>> Suggestions??
    >>>
    >>> Also, if I have to change some setting, do I just start all over and
    >>> re-run the Network Setup Wizard?
    >>>
    >>> Mel
    >>>
    >>>
    >>
    >>
    >
    >
  6. Archived from groups: alt.sys.pc-clone.dell (More info?)

    This is a security restriction built in to XP Home. It's restricted on
    purpose.

    Search support.microsoft.com Somewhere on there are instructions on sharing
    them. It requires changes in Safe Mode

    "MB_" <mel@prodigy.invalid.net> wrote in message
    news:4GFYe.1483$L45.629@fe07.lga...
    > Tom:
    >
    > Yes I am aware of that.
    >
    > I am sharing (trying to) such a folder and I can't make it work just yet
    > (hence my post)
    >
    > Mel
    > "Tom Scales" <tomtoo@softhome.net> wrote in message
    > news:dmFYe.93457$xl6.30002@tornado.tampabay.rr.com...
    >> OK, I'm guessing you're running XP Home. There is a quirk in XP Home
    >> that you cannot share any files that are in the Documents and Settings
    >> directory. This includes both My Documents AND your desktop. There is a
    >> complicated work around, but I wouldn't recommend it.
    >>
    >> It's easier to share a folder in your C: drive. Just right click on it
    >> and choose sharing and then follow the wizard.
    >>
    >> Tom
    >> "MB_" <mel@prodigy.invalid.net> wrote in message
    >> news:ayDYe.2622$P7.1850@fe06.lga...
    >>> OK -- somehow I am screwing this up.
    >>>
    >>> I currently have a Dell Dim 2400. It is set up for Broadband with a
    >>> Lynksys router.
    >>>
    >>> I also have a new Dell Inspiron 2200 with a wireless card.
    >>>
    >>> All works perfectly and I've also taken some reasonable security
    >>> precautions (MAC filtering, disabling SSID broadcasting, etc).
    >>>
    >>> Now, here is what I want to do.
    >>>
    >>> I have a FOLDER on my desktop. I would like to be able to share this
    >>> folder. That is, I want to be able to use this folder with my desktop or
    >>> with my wireless. Let's suppose this folder is c:\george\washington
    >>>
    >>> So, now I am attempting to join the wonderful world of file sharing and
    >>> I thought I did it correctly, but maybe not.
    >>>
    >>> Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    >>> Wizard on my desktop. When I ran thru the steps, perhaps I should have
    >>> chosen that this computer hooks up directly to the internet. But I chose
    >>> that it hooks up to the internet via a residential gateway (the picture
    >>> in the example seemed closer to what I had, but I'm not sure). I then
    >>> followed instructions and rebooted the desktop. I then ran the Wizard on
    >>> the Wireless and I chose the same thing. (I suspect these choices might
    >>> not be correct!)
    >>>
    >>> I then rebooted the wireless.
    >>>
    >>> I then got on the desktop, right clicked the aforementioned file in
    >>> Windows Explorer and designated it to be shared by all computers on the
    >>> network.
    >>>
    >>> Well, when I check on the desktop under Windows Explorer it does appear
    >>> that the folder is enabled for sharing.
    >>>
    >>> But I cannot find that shared folder anywhere when I use my Wireless.
    >>>
    >>> Suggestions??
    >>>
    >>> Also, if I have to change some setting, do I just start all over and
    >>> re-run the Network Setup Wizard?
    >>>
    >>> Mel
    >>>
    >>>
    >>
    >>
    >
    >
  7. Archived from groups: alt.sys.pc-clone.dell (More info?)

    MB_ wrote:

    > OK -- somehow I am screwing this up.
    >
    > I currently have a Dell Dim 2400. It is set up for Broadband with a Lynksys
    > router.
    >
    > I also have a new Dell Inspiron 2200 with a wireless card.
    >
    > All works perfectly and I've also taken some reasonable security precautions
    > (MAC filtering, disabling SSID broadcasting, etc).
    >
    > Now, here is what I want to do.
    >
    > I have a FOLDER on my desktop. I would like to be able to share this folder.
    > That is, I want to be able to use this folder with my desktop or with my
    > wireless. Let's suppose this folder is c:\george\washington
    >
    > So, now I am attempting to join the wonderful world of file sharing and I
    > thought I did it correctly, but maybe not.
    >
    > Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    > Wizard on my desktop. When I ran thru the steps, perhaps I should have
    > chosen that this computer hooks up directly to the internet. But I chose
    > that it hooks up to the internet via a residential gateway (the picture in
    > the example seemed closer to what I had, but I'm not sure). I then followed
    > instructions and rebooted the desktop. I then ran the Wizard on the Wireless
    > and I chose the same thing. (I suspect these choices might not be correct!)
    >
    > I then rebooted the wireless.
    >
    > I then got on the desktop, right clicked the aforementioned file in Windows
    > Explorer and designated it to be shared by all computers on the network.
    >
    > Well, when I check on the desktop under Windows Explorer it does appear that
    > the folder is enabled for sharing.
    >
    > But I cannot find that shared folder anywhere when I use my Wireless.
    >
    > Suggestions??
    >
    > Also, if I have to change some setting, do I just start all over and re-run
    > the Network Setup Wizard?
    >
    > Mel
    >
    >
    Mel, could you clarify something: are you attempting to share the
    directory over your local network (between 2 computers behind the same
    router) or across the interner?

    I'm going to assume behind the same router (although both are possible).
    Can you "see" the host (the computer sharing the directory) from the
    client? The easiest check is (from the client) to go to a DOS prompt
    (Start -> cmd [ok]) and type: ping $hostname (where $hostname is the
    name of the host sharing the directory). If you can see it, ping will
    return a time in milliseconds. If you can't see the host by its
    hostname, try pinging its IP address (to determine the address, on the
    host in the DOS prompt run ipconfig). If you can't see the IP chances
    are it's a firewall problem; if you can, try to "find" the host from the
    client (Start -> Search -> For Files or Folders -> Computer or People).
    Now search the hostname (if you could ping it) or the IP Address. You
    should be able to figure it out from here.

    Another thought I have is are you certain you're on your wireless
    network (and not your neighbors)? This may seem like a stupid question,
    but I can literally detect 39 wireless networks (I live in a complex
    when I'm at school) from my couch and if I used the default settings for
    my router I'd probably end up on my neighbor's network since it may have
    the same SSID. I'd recommend setting a unique SSID for multiple
    reasons; but at the very least, do it so you don't end on your neigbors
    network withoud knowing it.
  8. Archived from groups: alt.sys.pc-clone.dell (More info?)

    SURPRISE SURPRISE.
    I gave up last night.

    Today I booted up and it was there and works perfectly.

    Why the time lag between setting up the network and having it show up on my
    wireless??

    Strange!!
    Apparently, I did do it right.

    Mel


    "Nicholas Andrade" <SDNick484@nospam.yahoo.com> wrote in message
    news:zzMYe.1207$9E2.854@newssvr11.news.prodigy.com...
    > MB_ wrote:
    >
    >> OK -- somehow I am screwing this up.
    >>
    >> I currently have a Dell Dim 2400. It is set up for Broadband with a
    >> Lynksys router.
    >>
    >> I also have a new Dell Inspiron 2200 with a wireless card.
    >>
    >> All works perfectly and I've also taken some reasonable security
    >> precautions (MAC filtering, disabling SSID broadcasting, etc).
    >>
    >> Now, here is what I want to do.
    >>
    >> I have a FOLDER on my desktop. I would like to be able to share this
    >> folder. That is, I want to be able to use this folder with my desktop or
    >> with my wireless. Let's suppose this folder is c:\george\washington
    >>
    >> So, now I am attempting to join the wonderful world of file sharing and I
    >> thought I did it correctly, but maybe not.
    >>
    >> Firstly, I turned on my desktop and then the laptop. I ran Network Setup
    >> Wizard on my desktop. When I ran thru the steps, perhaps I should have
    >> chosen that this computer hooks up directly to the internet. But I chose
    >> that it hooks up to the internet via a residential gateway (the picture
    >> in the example seemed closer to what I had, but I'm not sure). I then
    >> followed instructions and rebooted the desktop. I then ran the Wizard on
    >> the Wireless and I chose the same thing. (I suspect these choices might
    >> not be correct!)
    >>
    >> I then rebooted the wireless.
    >>
    >> I then got on the desktop, right clicked the aforementioned file in
    >> Windows Explorer and designated it to be shared by all computers on the
    >> network.
    >>
    >> Well, when I check on the desktop under Windows Explorer it does appear
    >> that the folder is enabled for sharing.
    >>
    >> But I cannot find that shared folder anywhere when I use my Wireless.
    >>
    >> Suggestions??
    >>
    >> Also, if I have to change some setting, do I just start all over and
    >> re-run the Network Setup Wizard?
    >>
    >> Mel
    >>
    >>
    > Mel, could you clarify something: are you attempting to share the
    > directory over your local network (between 2 computers behind the same
    > router) or across the interner?
    >
    > I'm going to assume behind the same router (although both are possible).
    > Can you "see" the host (the computer sharing the directory) from the
    > client? The easiest check is (from the client) to go to a DOS prompt
    > (Start -> cmd [ok]) and type: ping $hostname (where $hostname is the name
    > of the host sharing the directory). If you can see it, ping will return a
    > time in milliseconds. If you can't see the host by its hostname, try
    > pinging its IP address (to determine the address, on the host in the DOS
    > prompt run ipconfig). If you can't see the IP chances are it's a firewall
    > problem; if you can, try to "find" the host from the client (Start ->
    > Search -> For Files or Folders -> Computer or People). Now search the
    > hostname (if you could ping it) or the IP Address. You should be able to
    > figure it out from here.
    >
    > Another thought I have is are you certain you're on your wireless network
    > (and not your neighbors)? This may seem like a stupid question, but I can
    > literally detect 39 wireless networks (I live in a complex when I'm at
    > school) from my couch and if I used the default settings for my router I'd
    > probably end up on my neighbor's network since it may have the same SSID.
    > I'd recommend setting a unique SSID for multiple reasons; but at the very
    > least, do it so you don't end on your neigbors network withoud knowing it.
Ask a new question

Read More

Dell Wireless Desktops Computers