Solved

Can't install

I have 2 identical desktops, one installed windows 7 perfectly fine. The other goes to setup, then restarts..gets to the starting windows splash screen then resets again with a blue screen. While attempting to launch safe mode I notice the blue screen is hanging at classpnp.sys.

I have searched everywhere on the Google for a fix and came up with absolutely nothing that works.

I even downloaded another version of Win 7 and get the same thing, again the other identical desktop works perfectly fine with it.

I have tried to reset mobo to default, unplug all usb stuff, just about everything yet it still hangs...incredibly frustrating.

This is a asus p5n-D mobo..
11 answers Last reply Best Answer
More about install
  1. Bad ram or HDD would be my quess. Swap HDD and ram with the other PC.
  2. I tried the ram already.. I dunno what would be wrong with the HD as it was working perfectly fine with the Vista partition that I just swiped off of it, I got a 500 gig partition still existing on it with some essential data, but I suppose I could try a HD swap but I am not leaning toward that being the factor. Especially as I have seen a few others having this problem across the net, however never seen any kind of true solution to it.
  3. What mode is the SATA controller running in? You should see ATA, AHCI or RAID for your choices. If it is set to either AHCI or RAID, the 7 install DVD may contain an unstable driver, causing the system to bluescreen when using that controller mode? Also check to make sure your BIOS is up to date. I have seen out of date BIOS'es cause quirky issues like this.

    Edit: Also run over to www.memtest.org and grab the latest Memtest86+ version (now at 4.00 I believe). Run a full pass on your ram to make sure it's not faulty, rather than swapping it into your other PC.
  4. Well, I just updated to the most recent BIOS on it. I have read solutions relating to the AHCI problem, however I don't see an option for that ANYWHERE in the bios, I have looked all through it. Trying again with just an updated BIOS but I dunno...
  5. Well, new BIOS, same result... stop at classpnp.sys.
  6. I'll have a peek through the BIOS menu system in the manual... i'll post back if I find what I suggested earlier.

    Edit: Wow.... the only setting I could find remotely close to the AHCI settings is the NVRAID Mode menu under the Advanced section. It doesn't distinguish between AHCI and RAID mode, although when RAID is enabled, the controller must load an AHCI driver for SATA devices.
  7. Yea, I tried that, no luck unfortunately.

    So weird, works identically on one computer but not the other.
  8. Does anyone else have any hope for this?

    I don't feel like having to revert back to xp on this other pc.
  9. Best answer
    If the systems are identical, try using norton ghost and install.
  10. Hate Norton...

    Anyone else have an idea on this?
  11. so use another drive imaging program instead.... I hate Symantec too, but I still use Ghost, since it has always worked for me.
Ask a new question

Read More

Desktops Blue Screen Windows 7