Sign in with
Sign up | Sign in
Your question

how do I turn off automatic defrag?

Last response: in Windows XP
Share
May 4, 2004 2:44:24 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

I need to turn automatic defrag off, it's driving me nuts. Someone please
tell me how.

Bob

More about : turn automatic defrag

Anonymous
May 4, 2004 2:44:25 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

On Tue, 4 May 2004 10:44:24 -0400, Bob wrote:

> I need to turn automatic defrag off, it's driving me nuts. Someone please
> tell me how.
>
> Bob

Automatic defrag occurs once every 3 days and lasts a few seconds. It is
not an intense operation. Are you sure that's where your extra disk
activity is coming from? Is it possible that you have "indexing" turned on?
This feature causes more disk activity and can be quite intense - at least
until the basic index is built. Smaller bursts of activity for new
additions to be indexed.

If you have a full scale defrag occurring on a regular basis, that is not
normal in XP. Either a task has been added to Task Scheduler or there is a
third party defragmenter with its own scheduling options being used.

--
Sharon F
MS-MVP ~ Windows XP Shell/User
Anonymous
May 4, 2004 2:46:36 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Hello
Start>Programs>Accessories>System Tools>Scheduled Tasks>right click Disk
Defrag then delete or disable.

--
Hope This Helps
Haus
Not a MS-MVP
Not a MVP
Not nothing, just a good ole boy.
"Bob" <nobody@nowhere.com> wrote in message
news:o vTDUYeMEHA.2488@TK2MSFTNGP10.phx.gbl...
> I need to turn automatic defrag off, it's driving me nuts. Someone please
> tell me how.
>
> Bob
>
Related resources
May 4, 2004 4:44:08 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Hmmm. Nothing's listed in Scheduled Tasks.



"Haus" <youknow@iwillslapyou> wrote in message
news:109fen9t74rme97@corp.supernews.com...
> Hello
> Start>Programs>Accessories>System Tools>Scheduled Tasks>right click Disk
> Defrag then delete or disable.
>
> --
> Hope This Helps
> Haus
> Not a MS-MVP
> Not a MVP
> Not nothing, just a good ole boy.
> "Bob" <nobody@nowhere.com> wrote in message
> news:o vTDUYeMEHA.2488@TK2MSFTNGP10.phx.gbl...
> > I need to turn automatic defrag off, it's driving me nuts. Someone
please
> > tell me how.
> >
> > Bob
> >
>
>
May 4, 2004 4:53:36 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

"Sharon F" <sharonfDEL@ETEmvps.org> wrote in message
news:uPfsg4eMEHA.268@TK2MSFTNGP11.phx.gbl...
> On Tue, 4 May 2004 10:44:24 -0400, Bob wrote:
>
> > I need to turn automatic defrag off, it's driving me nuts. Someone
please
> > tell me how.
> >
> > Bob
>
> Automatic defrag occurs once every 3 days and lasts a few seconds. It is
> not an intense operation. Are you sure that's where your extra disk
> activity is coming from? Is it possible that you have "indexing" turned
on?
> This feature causes more disk activity and can be quite intense - at least
> until the basic index is built. Smaller bursts of activity for new
> additions to be indexed.
>
> If you have a full scale defrag occurring on a regular basis, that is not
> normal in XP. Either a task has been added to Task Scheduler or there is a
> third party defragmenter with its own scheduling options being used.
>
> --
> Sharon F
> MS-MVP ~ Windows XP Shell/User

I disabled indexing and System Restore long ago.

Your information on automatic defragging is in disagreement with another
source:

http://windowsxp.devx.com/articles/perfen/default.asp

"
The last hardware change of note is that Windows XP will automatically
perform disk defragmentation during activity lulls. As described previously,
these lulls consist of 13 minutes of no user I/O. The result of this is, of
course, more-efficient disk access.
"
This description is consistent with what I have been experiencing. In the
middle of writing code - which itself has no I/O until I save the files - my
machine will randomly start disk activity which takes 1-3 minutes. And if I
stand by/suspend my computer while it's doing this, any instances of IE and
OE lock up forever, and I can't reboot without physically turning the
machine off. So much for Windows XP's vaunted stability.

There was nothing in Task Scheduler, but since I disabled it there has been
no more unsolicited disk activity.

Bob
Anonymous
May 4, 2004 6:31:04 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

The article you refer to here. http://windowsxp.devx.com/articles/perfen/default.asp doesn't mention anything about defragging at all. If you are referring to the optimization that the article talks about (moving files to make them contiguous during luls in activity) this is rather misleading as it isn't referring to defragging but rather prefetching. There simply isn't any "automatic" defrag in XP.There are some boot optimization that take place about every 3 days but no defrag or why would you need a defrag utility? I have solved many a system slow down problem by defragmenting a system that has reached %40+ fragmentation so if there were such a program then XP would never reach these levels. Programs like Diskkeeper and Perfect Disk do have options to have defrag run at times when the OS needs it or at preselected times. When this activity takes place you should go into the task manager and then click processes to see what process is using the CPU and then track down the culprit using a process viewer. You actually answered your own post by stating that you have disabled the task scheduler so I rather suspect a program was using this to enable it's auto"something" function even though it didn't have a listing in the main GUI. Good luck.{:~)
Anonymous
May 6, 2004 4:07:32 AM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

On Tue, 4 May 2004 12:53:36 -0400, Bob wrote:

>I disabled indexing and System Restore long ago.
>
> Your information on automatic defragging is in disagreement with another
> source:
>
> http://windowsxp.devx.com/articles/perfen/default.asp
>
> "
> The last hardware change of note is that Windows XP will automatically
> perform disk defragmentation during activity lulls. As described previously,
> these lulls consist of 13 minutes of no user I/O. The result of this is, of
> course, more-efficient disk access.
> "
> This description is consistent with what I have been experiencing. In the
> middle of writing code - which itself has no I/O until I save the files - my
> machine will randomly start disk activity which takes 1-3 minutes. And if I
> stand by/suspend my computer while it's doing this, any instances of IE and
> OE lock up forever, and I can't reboot without physically turning the
> machine off. So much for Windows XP's vaunted stability.
>
> There was nothing in Task Scheduler, but since I disabled it there has been
> no more unsolicited disk activity.
>
> Bob

"Optimization" is a feature tied into XP's disk defragmenter. This process
occurs every 3 days.

http://msdn.microsoft.com/library/default.asp?url=/libr...
http://www.microsoft.com/resources/documentation/Window...

If using a third party defragmenter, check that program's settings.

--
Sharon F
MS-MVP ~ Windows XP Shell/User
Anonymous
June 11, 2004 8:23:32 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

It's a hidden task. You won't see it.

- Greg/Raxco Software
Microsoft MVP - Windows File System

Disclaimer: I work for Raxco Software, the maker of PerfectDisk - a
commercial defrag utility, as a systems engineer in the support department.

Want to email me? Delete ntloader.



"Bob" <nobody@nowhere.com> wrote in message
news:e$ijObfMEHA.2064@TK2MSFTNGP12.phx.gbl...
> Hmmm. Nothing's listed in Scheduled Tasks.
>
>
>
> "Haus" <youknow@iwillslapyou> wrote in message
> news:109fen9t74rme97@corp.supernews.com...
> > Hello
> > Start>Programs>Accessories>System Tools>Scheduled Tasks>right click Disk
> > Defrag then delete or disable.
> >
> > --
> > Hope This Helps
> > Haus
> > Not a MS-MVP
> > Not a MVP
> > Not nothing, just a good ole boy.
> > "Bob" <nobody@nowhere.com> wrote in message
> > news:o vTDUYeMEHA.2488@TK2MSFTNGP10.phx.gbl...
> > > I need to turn automatic defrag off, it's driving me nuts. Someone
> please
> > > tell me how.
> > >
> > > Bob
> > >
> >
> >
>
!