Sign in with
Sign up | Sign in
Your question

USB device "enabled" but not working

Last response: in Windows XP
Share
May 6, 2004 5:35:09 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Since I've upgraded to XP, nothing I plug into my USB
device works, including the portable USB drive, my hp
printer, or my palm pilot (hot sync not working).

I checked device manager and went through
troubleshooting: all USB ports state they are "enabled"
and "working properly". I tried disenabling and
reenabeling. No Windows Updates are available for USB
drivers for my computer.

The USB device I am using is Intel 82801BA/BAM USB
universal host controller-2442. A colleague has a
different USB device on her XP machine (Intel 24D2).

Do I have to update my USB device or is there another
fix? Can I download it for free? If not, where do I
purchase it? Many thanks....
May 6, 2004 6:21:05 PM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

Look at this link for graphic details about your USB

<http://support.fujitsu-siemens.de/KnowHow/Install.Anl/G...;

When you were checking your hardware in Device Manager, and you looked at the properties window of your device, did you go to the "resources" tab and see if there were any IRQ conflicts?

Also maybe your printer or your other peripherals that you are plugging into your USB ports need new drivers. Sometimes it's not the USBs but the printers etc. that need your attention.

Hope you get it solved.
May 7, 2004 7:56:02 AM

Archived from groups: microsoft.public.windowsxp.newusers (More info?)

You could go to control panel - add/remove programs - add/remove windows components - networking service - details - Universal Plug N Play and see if it's installed!

I have a USB hub, and it isn't seen unless the above is installed!
!