Sign in with
Sign up | Sign in
Your question

Win2k won't detect my hard drives!? HELP!

Last response: in Motherboards
Share
June 12, 2002 2:41:08 AM

god i hate this crap!!!!!

ok as you know i have the ga-7dxr ... winxp kept crashing so i decided to wipe it clean and start over. this time instal win2k instead and compare differences. Just experience so i can explain to people what the difference is.

anyway .. so i tried with raid .. win2k on setup says unknown disk. tried winxp ... samething (winxp is the original microsoft windows xp pro disk and not a copy) ... ok so i said screw raid ... took out raid and win2k still won't see my hard drives!

don't assume yet .. i'm good myself and if it was what your thinking i would have solved it by now ... the Promis controller's BIOS sees it just FINE and dandy! no problens even on the raid setup. ... and yes i installed the drivers upon setup.

just now i tried something else and that didn't work ...

fdisk ... i'll try doing that now ... see if that does anything .. but win2k does that for u ... at least i thought it did... i could be wrong .. who knows .... hmmmm ... i think i found it .... looks like a junked up files system .. i deleted that ... dam! ... nope still does not see my hard drives... says "unknown disk" and under it says "<There is no disk in this drive>" ...

win2k should recognize the drive so i can partition it and format it. I've done it all the time.

the fact that the BIOS reads it but win2k doesn't says what to you? doesn't make sense to me!!!

grrr ... gonna try the IDE controller (non-raid controller).

thanks!

<A HREF="http://www.anandtech.com/mysystemrig.html?id=9933" target="_new"> My Rig </A>
June 12, 2002 3:07:54 AM

LOL
press F6 when win asks u (during installation, when starting), and prepare a disk with the right drivers(scsi or raid, whatever u have in there).I had the same prob with an Asus A7V133 mobo with promise ATA controller, it was seen as a simulated SCSI.
Good luck.
:) 


If it works, don't fix it.
Related resources
June 12, 2002 4:16:00 AM

well,then maybe u dont install the right drivers...
it should work...i dunno what else to say.....if the bios sees them that means that they are phisically connected ok.
win2k should see them al well if u give him the right drivers @ installation, right when it starts.what drivers are those?

If it works, don't fix it.
June 12, 2002 4:32:54 AM

Is "Logical Disk Manager" and "Logical Disk Manager Administrative Service" set to "Automatic" in "Computer Management" under
"Services and Applications...Services"?

<b><font color=blue>The shortest distance between two points is under construction. :lol: 
June 12, 2002 11:12:09 AM

I'm a little confused... You have fdisk'd and formatted at least a FAT32 partition for W2K to put it's temp files on during the install, right? If not then thats your problem. If so, I'm stumped.

<i>It's always the one thing you never suspected.</i>
June 12, 2002 1:19:15 PM

sorry but i installed the correct drivers .. i tried both the ATA100 version and the ATA133. The ATA133 worked just fine before. ALso remember that winxo has those drivers already.

I tried both win2k and winxp same problem.

<A HREF="http://www.anandtech.com/mysystemrig.html?id=9933" target="_new"> My Rig </A>
June 12, 2002 1:49:18 PM

bah ... this is happening during setup .. says that there were no drives found please exit setup ... at first it did say unknown drive ... but i think it was looking at the zip drive!

i wonder if i can install win98 on a zip250? ... well anyway

i'll play with it some more when i get home i have a feeling that the second channel on the second controller is bad, or the bios is f'ed up, or something is going on where when the two drives are on sepperate channels it doesn't work.

I do know that in order to have UDMA 5 enabled on the RAID controller i have to enable onboard audio. other wise it backs to PIO 4 mode. My friend had the same problem so i wonder if this is a defected controller.

of course those are just theories...

<A HREF="http://www.anandtech.com/mysystemrig.html?id=9933" target="_new"> My Rig </A>
June 12, 2002 2:05:12 PM

dude so am i ... so ... oh and maybe some of you dont know about this?

ok try this for yourself next time you need to install windows .. for win2k and winxp and probably win98SE users give this a try.

boot from the cd and do the setup process. ya know the bluescreen.. not BSOD.. but it's a setup section and it's blue ... in win2k and winxp you can partition and format your drive from within the setup. win98SE i'm not sure about. It is so much faster. Infact ALOT faster then using a dos bootdisk and fdisk. You partition it and then do a quick format and you got winxp or win2k <b>INSTALLED</b> within an hour for a 60GB hard drive. Free tip of the day!

here is something funny i just realized. While in fdisk i noticed it only saw 2 drives. Which is as many as i have installed right? WRONG! oops forgot about the zip drive! thats an IDE drive. so fdisk saw that and thats where win2k was trying to install on the zip drive. until i removed the zipdrive (unpowered and unplugged the IDE cable) did it say "setup did not find any drives please exit setup". Now listen ... fdisk <b><fdisk recognized 2 drives></b> for the 1st drive read the partition <b><oops drive not partition but drive></b> as only 96MB and unknown system. i thought wth... i think we can figure out thats the zipdrive cos at the time i had a 100MB zipdisk in there. The second drive was the 60GB harddrive <b><and unknown system></b>... and thats it.. wheres the second drive? so my theory grows strong that the second channel (the RAID/SCSI channel) is bad. Looks like a case of a new motherboard. Which is what i suspected at first and why i have this posted here. but i will play with it some more. i'm not to excited forken up 110 bucks for something i didn't expect paying for.

thanks!

<A HREF="http://www.anandtech.com/mysystemrig.html?id=9933" target="_new"> My Rig </A><P ID="edit"><FONT SIZE=-1><EM>Edited by xxsk8er101xx on 06/12/02 10:21 AM.</EM></FONT></P>
June 12, 2002 2:41:33 PM

Quote:
win2k and winxp you can partition and format your drive from within the setup

jeeze - I didn't know about this feature. Thanks for the tip. It'll definitely save me some time.

<i>It's always the one thing you never suspected.</i>
June 12, 2002 2:59:23 PM

ya ... and even if the drive doesn't have a filesystem intacked you can still do a quick format.

I don't understand the difference between quick format and long format from within winxp/win2k but the quick format does the samething as the long format and it takes a matter of seconds instead of minutes' per GB.

you can also do this under administrato tools->computer management->disk something rather and if you have a drive partition that isn't formated you can do a quick format there also to save even more time.

it was cool cos like i had the first drive partition and i had a whole 60GB drive still unformated and a 40GB partition unformated ... did a quick format on both drives and was done in 20 seconds lol.

<A HREF="http://www.anandtech.com/mysystemrig.html?id=9933" target="_new"> My Rig </A>
June 12, 2002 3:16:04 PM

yeah, I knew about the admin tools but not about the install utility. That part is pretty exciting ( in a geeky sort of way :smile: ). Thanks again.

<i>It's always the one thing you never suspected.</i>
!