Sign in with
Sign up | Sign in
Your question

Problem with router being able to see ADSL modem

Last response: in Wireless Networking
Share
July 27, 2004 8:41:29 PM

Archived from groups: alt.internet.wireless (More info?)

I am a total newbie to networking and have set up my home network as
follows:

1 - Wanadoo Broadband (dynamic IP)
2 - D-Link 300G+ ADSL Modem
3 - 3-Com OfficeConnect 3CRWE51196

To make this work, I first connect the Modem and get the IP & ISP Gateway
address - then input this as a static address into the 3Com software along
with the other settings.

The IP address of the D-Link modem is 192.168.0.1

The other settings are as follows:
Internet Settings

PPP over Ethernet Enabled NO

Internet IP Address 84.65.67.18 Static

Subnet Mask 255.255.255.0

ISP Gateway Address 84.65.67.19 Connected

DNS 195.92.195.94 ; 195.92.195.95

Remaining Lease Time

MAC Address 00-0B-AC-E4-EC-2F



LAN Settings

LAN IP Address 192.168.1.1

LAN Subnet Mask 255.255.255.0

Gateway's DHCP Server Enabled

DHCP Range 192.168.1.2 ~ 192.168.1.254

LAN Port MAC Address 00-0B-AC-E4-EC-2E



Can please advise which settings I need to change in order to connect (see
the modem's manager) to the Modem manager through the router?



Kind regards,



Mark
July 27, 2004 8:59:27 PM

Archived from groups: alt.internet.wireless (More info?)

"Drinky" <mark_drinkwater@coldmail.com> wrote in message
news:ce5t3v$q2t$1@news8.svr.pol.co.uk...
> I am a total newbie to networking and have set up my home network as
> follows:
>
> 1 - Wanadoo Broadband (dynamic IP)
> 2 - D-Link 300G+ ADSL Modem
> 3 - 3-Com OfficeConnect 3CRWE51196
>
> To make this work, I first connect the Modem and get the IP & ISP Gateway
> address - then input this as a static address into the 3Com software along
> with the other settings.
>
> The IP address of the D-Link modem is 192.168.0.1
>
> The other settings are as follows:
> Internet Settings
>
> PPP over Ethernet Enabled NO
>
> Internet IP Address 84.65.67.18 Static
>
> Subnet Mask 255.255.255.0
>
> ISP Gateway Address 84.65.67.19 Connected
>
> DNS 195.92.195.94 ; 195.92.195.95
>
> Remaining Lease Time
>
> MAC Address 00-0B-AC-E4-EC-2F
>
>
>
> LAN Settings
>
> LAN IP Address 192.168.1.1
>
> LAN Subnet Mask 255.255.255.0
>
> Gateway's DHCP Server Enabled
>
> DHCP Range 192.168.1.2 ~ 192.168.1.254
>
> LAN Port MAC Address 00-0B-AC-E4-EC-2E
>
>
>
> Can please advise which settings I need to change in order to connect (see
> the modem's manager) to the Modem manager through the router?
>
>
>
> Kind regards,
>
>
>
> Mark
>
>
>
>

Did you configure your modem by attaching it directly to your PC ?
If so, the problem is that the modem has taken your PC's MAC address and
will only 'talk' to that MAC address.
To get round this, change your Router's IP address to 192.168.0.2
Connect your modem to the WAN port and your PC to its LAN port.
Re-configure the modem (192.168.0.1).
Once you have done this you can change your Routers IP address back to
192.168.1.1

Alternatively you may be able clone your PC's MAC address in the Routers
configuration.

Hope this helps, John.
Anonymous
July 28, 2004 4:50:00 AM

Archived from groups: alt.internet.wireless (More info?)

On Tue, 27 Jul 2004 16:41:29 +0100, "Drinky"
<mark_drinkwater@coldmail.com> wrote:

>Can please advise which settings I need to change in order to connect (see
>the modem's manager) to the Modem manager through the router?

I've been engaged in a discussion on exactly the same problem at:
http://www.dslreports.com/forum/remark,10866714~mode=fl...
I kinda screwed up the original bug report, but everything else is
accurate. You can do it with a static route on the WAN side of the
router. My BEFW11S4v4 has this feature, but it's busted. I just
tried it with a Netgear MR814v2 and found that it only supports static
routes on the LAN side. I haven't had time to survey other likely
suspcect.

I do offer a working solution in the above discussion. See:
http://www.dslreports.com/speak/print/default;10873529
You add an ethernet switch between the DSL modem and your 3Com router
WAN port. Add a cable betweent the switch and one of the LAN ports on
the 3Scum router. Setup a 2nd IP address on your workstation ethernet
card.

Make sure that your DLink modem does *NOT* have an IP address in the
same Class C IP block as the LAN side of the 3Com router. From your
list, you have it correct, with the Dlink modem at 192.168.0.1 and the
3Com router at 192.168.1.1. This will work just fine with a netmask
of 255.255.255.0 for both. Note that you cannot use DHCP for
assigning the IP addreses on the workstation.

I've done some port scanning and security checks on this arrangement
and it seems to be holding together. However, I'm not 100% certain.

Anyway, I'm finally able to dive into the EXPERT and "golden" modes in
my Alcatel Speed Touch Home DSL modem and extract channel quality
statistics. Too bad it doesn't do SNMP.


--
Jeff Liebermann jeffl@comix.santa-cruz.ca.us
150 Felker St #D http://www.LearnByDestroying.com
Santa Cruz CA 95060 AE6KS 831-336-2558
Related resources
July 28, 2004 2:18:02 PM

Archived from groups: alt.internet.wireless (More info?)

"Jeff Liebermann" <jeffl@comix.santa-cruz.ca.us> wrote in message
news:kpleg0danfvof8j0gl81uuj69prr1h77mb@4ax.com...
> On Tue, 27 Jul 2004 16:41:29 +0100, "Drinky"
> <mark_drinkwater@coldmail.com> wrote:
>
> >Can please advise which settings I need to change in order to connect
(see
> >the modem's manager) to the Modem manager through the router?
>
> I've been engaged in a discussion on exactly the same problem at:
> http://www.dslreports.com/forum/remark,10866714~mode=fl...
> I kinda screwed up the original bug report, but everything else is
> accurate. You can do it with a static route on the WAN side of the
> router. My BEFW11S4v4 has this feature, but it's busted. I just
> tried it with a Netgear MR814v2 and found that it only supports static
> routes on the LAN side. I haven't had time to survey other likely
> suspcect.
>
> I do offer a working solution in the above discussion. See:
> http://www.dslreports.com/speak/print/default;10873529
> You add an ethernet switch between the DSL modem and your 3Com router
> WAN port. Add a cable betweent the switch and one of the LAN ports on
> the 3Scum router. Setup a 2nd IP address on your workstation ethernet
> card.
>
> Make sure that your DLink modem does *NOT* have an IP address in the
> same Class C IP block as the LAN side of the 3Com router. From your
> list, you have it correct, with the Dlink modem at 192.168.0.1 and the
> 3Com router at 192.168.1.1. This will work just fine with a netmask
> of 255.255.255.0 for both. Note that you cannot use DHCP for
> assigning the IP addreses on the workstation.
>
> I've done some port scanning and security checks on this arrangement
> and it seems to be holding together. However, I'm not 100% certain.
>
> Anyway, I'm finally able to dive into the EXPERT and "golden" modes in
> my Alcatel Speed Touch Home DSL modem and extract channel quality
> statistics. Too bad it doesn't do SNMP.
>
>
> --
> Jeff Liebermann jeffl@comix.santa-cruz.ca.us
> 150 Felker St #D http://www.LearnByDestroying.com
> Santa Cruz CA 95060 AE6KS 831-336-2558

I MAY be wrong but I'm sure the ip address for the D-Link modem is only
available for configuration.
Once is has been assigned an address from your ISP it becomes a transparent
device.
Perhaps someone else who uses a 300g+ could confirm / deny this.
Anonymous
July 28, 2004 2:18:03 PM

Archived from groups: alt.internet.wireless (More info?)

On Wed, 28 Jul 2004 10:18:02 +0100, "John" <jrl @ bushinternet dot
com> wrote:

>I MAY be wrong but I'm sure the ip address for the D-Link modem is only
>available for configuration.
>Once is has been assigned an address from your ISP it becomes a transparent
>device.
>Perhaps someone else who uses a 300g+ could confirm / deny this.

I've never played with the DLink 300g+. However, my experience with:
Efficient 5260 10.0.0.1
Alcatel speedtouch 10.0.0.138
Motorola Bitsurfer 192.168.100.1
Broadmax 192.168.0.1
is that these IP addresses remain functional during normal operation.
It's just that they're difficult to access *THROUGH* a router.


--
Jeff Liebermann jeffl@comix.santa-cruz.ca.us
150 Felker St #D http://www.LearnByDestroying.com
Santa Cruz CA 95060 AE6KS 831-336-2558
July 29, 2004 3:28:49 AM

Archived from groups: alt.internet.wireless (More info?)

John,

Many thanks for the advice - brilliant. By cloning my PC's MAC address in
the routers configuration, I've not only solved my problem of now being able
to connect to my modem via the router - but also I've been able to set up
the router to accept the dynamic IP's that I get from my broadband supplier.

Many thanks,

Mark

>
> Did you configure your modem by attaching it directly to your PC ?
> If so, the problem is that the modem has taken your PC's MAC address and
> will only 'talk' to that MAC address.
> To get round this, change your Router's IP address to 192.168.0.2
> Connect your modem to the WAN port and your PC to its LAN port.
> Re-configure the modem (192.168.0.1).
> Once you have done this you can change your Routers IP address back to
> 192.168.1.1
>
> Alternatively you may be able clone your PC's MAC address in the Routers
> configuration.
>
> Hope this helps, John.
>
>
!