Problem with new BF2 patch

It took 3 hours for me to download the new patch (1.41). I go to double click on the .exe file but it never fires up. I open the task manager and open the processes tab. I see the BF2 patch but then it disappears after a few minutes. I really do not want to re-download the patch. This happened to me with the 1.3 patch but for some reason I don't remember how I got it to work. Any help would be appreciated.
6 answers Last reply
More about problem patch
  1. how long do you wait for it to start after you double click it? when i applied the 1.41 patch, i had to wait about 60-90 secs before the file started to unpack itself.

    maybe try wait for a bit - double click then walk away :D
  2. It is possible that the download could have become corrupt at some point when downloading the patch. It has happened to me a few times, a good sign that this has happened is if the file does not actually have an image and just looks like a normal dos program box. But that is fairly unlikely unless your using a very slow and poor connection like a 56K.
  3. Actually I have DSL, but I'll try to wait again.
  4. My machine took a total wobbly the first time I tried to run that patch. (dunno why I patched the game cos I don't play it) but anyway I was running eve online in the background and my machine died.

    Rebooted and tried to run the patch again. Another pc wobbly but I waited and eveeeeeentually it came to life and patched the game. Give it time.
  5. I just re-downloaded it and ran it within 20 seconds of my click. FileFront FTW. 8)
  6. Yup thought so, things often become corrupt when downloading, more so of dodgy websites.
Ask a new question

Read More

PC gaming Download Task Manager Video Games