Linksys WRT54G router + D-Link DSL 300 T cable modem

Archived from groups: alt.internet.wireless (More info?)

I am having problems getting the two above devices to work together
despite having followed the setup instructions.

I now have the modem (ip 192.168.1.1) connected to the "Internet" port
of the router (ip 192.168.1.2) using a patch cable. Using a laptop
with wireless card I am able to ping the router but not the modem.

Connecting the modem to one of the LAN ports on the router enables me
to ping the modem and access its configuration. This reveals that the
modem is connecting successfully to my ISP and obtaining an IP
address.

As it is I have wireless network connectivity but no Internet access,
whether connecting the modem to the "Internet" or a LAN port on the
router and whether using a patch or corssover cable.

Any ideas please.
8 answers Last reply
More about linksys wrt54g router link cable modem
  1. Archived from groups: alt.internet.wireless (More info?)

    You need to move the modem and the router out of the same subnet. If the
    router is at 192.168.1.2 and the modem is at 192.168.1.1, then the router
    will assume that the modem is downstream of one of the LAN ports. This is
    why cable modems are usually found at addresses like 192.168.100.1. One
    solution is to either change the address of the cable modem or the router to
    something like 192.168.2.1 (i.e. change the third number, not the fourth).

    -Yves

    "Will" <info@whawes.co.uk> wrote in message
    news:ff3a4031.0407310921.30d470f1@posting.google.com...
    > I am having problems getting the two above devices to work together
    > despite having followed the setup instructions.
    >
    > I now have the modem (ip 192.168.1.1) connected to the "Internet" port
    > of the router (ip 192.168.1.2) using a patch cable. Using a laptop
    > with wireless card I am able to ping the router but not the modem.
    >
    > Connecting the modem to one of the LAN ports on the router enables me
    > to ping the modem and access its configuration. This reveals that the
    > modem is connecting successfully to my ISP and obtaining an IP
    > address.
    >
    > As it is I have wireless network connectivity but no Internet access,
    > whether connecting the modem to the "Internet" or a LAN port on the
    > router and whether using a patch or corssover cable.
    >
    > Any ideas please.
  2. Archived from groups: alt.internet.wireless (More info?)

    "Will" <info@whawes.co.uk> wrote in message
    news:ff3a4031.0407310921.30d470f1@posting.google.com...
    > I am having problems getting the two above devices to work together
    > despite having followed the setup instructions.
    >
    > I now have the modem (ip 192.168.1.1) connected to the "Internet" port
    > of the router (ip 192.168.1.2) using a patch cable. Using a laptop
    > with wireless card I am able to ping the router but not the modem.
    >
    > Connecting the modem to one of the LAN ports on the router enables me
    > to ping the modem and access its configuration. This reveals that the
    > modem is connecting successfully to my ISP and obtaining an IP
    > address.
    >
    > As it is I have wireless network connectivity but no Internet access,
    > whether connecting the modem to the "Internet" or a LAN port on the
    > router and whether using a patch or corssover cable.
    >
    > Any ideas please.

    If possible with the Linksys, try cloning your PC's MAC address into the
    Routers configuration
  3. Archived from groups: alt.internet.wireless (More info?)

    "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message news:<cego8e$6tr$1@news.Stanford.EDU>...
    > You need to move the modem and the router out of the same subnet. If the
    > router is at 192.168.1.2 and the modem is at 192.168.1.1, then the router
    > will assume that the modem is downstream of one of the LAN ports. This is
    > why cable modems are usually found at addresses like 192.168.100.1. One
    > solution is to either change the address of the cable modem or the router to
    > something like 192.168.2.1 (i.e. change the third number, not the fourth).
    >
    > -Yves

    Thanks for the suggestion, but that didn't work. I changed the IP of
    the router to 192.168.2.1 and when I try to ping the modem I get
    "Destination net unreachable" from the command prompt and still no
    Internet access.

    I have also cloned the MAC address of my computer onto the router and
    that has no effect either.

    I have tested the cable modem connected directly to a PC via a
    crossover cable and everything works fine.

    Any other ideas? It's a shame that Linksys forgot to include any
    instructions on connecting the router to a cable modem, so I'm a bit
    stuck...
  4. Archived from groups: alt.internet.wireless (More info?)

    On 31 Jul 2004 10:21:04 -0700, info@whawes.co.uk (Will) wrote:

    >I now have the modem (ip 192.168.1.1) connected to the "Internet" port
    >of the router (ip 192.168.1.2) using a patch cable. Using a laptop
    >with wireless card I am able to ping the router but not the modem.

    I've been trying to make that work (with different hardware) using a
    static route on the WAN side of the router. See:
    http://www.dslreports.com/forum/remark,10866714~mode=flat
    One person in the thread claimed to have made it work by cloning the
    MAC address but I can't reproduce his results. A static route should
    be workable, as I proved when I kludged my Cisco 2514 router to do it,
    but apparently not with my cheapo BEFW11S4 router.

    It can made to work if you change the IP address of the modem to a
    difference class c IP block (e.g. 192.168.111.1), install a 4 port
    switch between the modem and the router, run a cable between the LAN
    port on the WRT54G and the added switch, and add a 2nd IP address to
    your monitoring computer as in:
    http://www.dslreports.com/speak/print/default;10873529


    --
    Jeff Liebermann jeffl@comix.santa-cruz.ca.us
    150 Felker St #D http://www.LearnByDestroying.com
    Santa Cruz CA 95060 AE6KS 831-336-2558
  5. Archived from groups: alt.internet.wireless (More info?)

    If you connect your computer directly to the modem, do you the same IP
    address assigned as the router when it is connected directly to the modem
    via the WAN port (viewable on the Status page)?

    Your cable modem should contain a DHCP server and, depending on what kind of
    subscription you have with the cable company, can issue one and sometimes
    more IP addresses. It is possible that it might only issue IP addresses to
    devices the cable company knows about, which is why you may need to clone
    the computer's MAC address into the router (but I guess that did not help
    you). In any case, your router should be set to automatically obtain an IP
    address via DHCP ("automatic configuration - DHCP" under internet connection
    type) and, if everything is working properly, it should obtain the same
    information as if it were a computer directly connected to the modem.

    Assuming that both your computer and router can obtain the same (or very
    similar) IP address when they are the only device connected to the modem,
    you next need to make sure that the router assigns IP addresses that are not
    in 192.168.1.x since the modem appears to be there on the WAN port. Thus,
    change the local IP address of the router to 192.168.2.1 and use a
    255.255.255.0 subnet mask. Finally, the starting address for DHCP should be
    set to something like 192.168.2.100. The first computer you connect to the
    router on a LAN port should be assigned this address and should obtain
    additional info (such as nameservers) that you can view using the "ipconfig
    /all" command in Windows.

    -Yves

    "Will" <info@whawes.co.uk> wrote in message
    news:ff3a4031.0408010415.78d199b7@posting.google.com...
    > "Yves Konigshofer" <yvesk@sStTaAnNfFoOrRdD.edu> wrote in message
    news:<cego8e$6tr$1@news.Stanford.EDU>...
    > > You need to move the modem and the router out of the same subnet. If
    the
    > > router is at 192.168.1.2 and the modem is at 192.168.1.1, then the
    router
    > > will assume that the modem is downstream of one of the LAN ports. This
    is
    > > why cable modems are usually found at addresses like 192.168.100.1. One
    > > solution is to either change the address of the cable modem or the
    router to
    > > something like 192.168.2.1 (i.e. change the third number, not the
    fourth).
    > >
    > > -Yves
    >
    > Thanks for the suggestion, but that didn't work. I changed the IP of
    > the router to 192.168.2.1 and when I try to ping the modem I get
    > "Destination net unreachable" from the command prompt and still no
    > Internet access.
    >
    > I have also cloned the MAC address of my computer onto the router and
    > that has no effect either.
    >
    > I have tested the cable modem connected directly to a PC via a
    > crossover cable and everything works fine.
    >
    > Any other ideas? It's a shame that Linksys forgot to include any
    > instructions on connecting the router to a cable modem, so I'm a bit
    > stuck...
  6. Archived from groups: alt.internet.wireless (More info?)

    info@whawes.co.uk (Will) wrote in
    news:ff3a4031.0407310921.30d470f1@posting.google.com:

    > I am having problems getting the two above devices to work
    > together despite having followed the setup instructions.

    Excuse me butting in, but as I've seen another couple of posts in the
    same thread also repeating the same wording...

    The DSL-300T is *not* a cable modem. It's an ADSL modem.

    Do ensure that you're running current firmware. The device is fairly
    new, and there have already been a couple of updates. The current
    version is v1.00B02T02.UK.20040618.Find it here:
    <ftp://ftp.dlink.co.uk/dsl_routers_modems/dsl-300t/>

    The reason for the updates is that the processor in the device is
    common to other T series D-Link products (DSL-504T, DSL-G604T et al)
    and runs the BusyBox Linux kernel. There are many functions available
    in the early firmware releases which are not appropriate to a modem
    but were included - I guess it uses code common across the model
    range. These functions have now been 'turned off' - see the Release
    Notes for info.

    Hope this helps


    --

    Richard Perkin
    To email me, change the AT in the address below
    richard.perkinATmyrealbox.com

    It's is not, it isn't ain't, and it's it's, not its, if you mean it
    is. If you don't, it's its. Then too, it's hers. It isn't her's.
    It isn't our's either. It's ours, and likewise yours and theirs.
    -- Oxford University Press, Edpress News
  7. Archived from groups: alt.internet.wireless (More info?)

    Thanks for the help everyone. I have now got it working and am posting
    from a laptop connected to the WRT54G wirelessly.

    It transpired that I had done something silly and switched off the
    DHCP server in the modem, mistakenly believeing that I did not want
    DHCP running on both router and modem.

    In fact, with the router set to "Automatic configuration - DHCP", DHCP
    does need to be enabled on the modem. A bit obvious - just goes to
    show it is easy to lose sight of the easy solution sometimes I
    suppose...

    Anyway, for anyone experiencing a similar problem in future, the
    working setup is as follows:

    Modem - ip 192.168.2.1, DHCP server enabled, connected to "Internet"
    port of router via cat 5 patch cable

    Router - ip 192.168.1.1, DHCP server enabled

    Desktop PC connected to port 1 of router via cat 5 crossover cable,
    set to obtain IP address via DHCP.

    Laptop with wireless card, set to obtain IP address via DHCP.

    All working great.

    Thanks again for your help.

    Regards

    Will

    Richard Perkin <f000nurdle@hotmail.com> wrote in message news:<2n5ltlFsc96vU1@uni-berlin.de>...
    > info@whawes.co.uk (Will) wrote in
    > news:ff3a4031.0407310921.30d470f1@posting.google.com:
    >
    > > I am having problems getting the two above devices to work
    > > together despite having followed the setup instructions.
    >
    > Excuse me butting in, but as I've seen another couple of posts in the
    > same thread also repeating the same wording...
    >
    > The DSL-300T is *not* a cable modem. It's an ADSL modem.
    >
    > Do ensure that you're running current firmware. The device is fairly
    > new, and there have already been a couple of updates. The current
    > version is v1.00B02T02.UK.20040618.Find it here:
    > <ftp://ftp.dlink.co.uk/dsl_routers_modems/dsl-300t/>
    >
    > The reason for the updates is that the processor in the device is
    > common to other T series D-Link products (DSL-504T, DSL-G604T et al)
    > and runs the BusyBox Linux kernel. There are many functions available
    > in the early firmware releases which are not appropriate to a modem
    > but were included - I guess it uses code common across the model
    > range. These functions have now been 'turned off' - see the Release
    > Notes for info.
    >
    > Hope this helps
    >
    >
    >
    > --
    >
    > Richard Perkin
    > To email me, change the AT in the address below
    > richard.perkinATmyrealbox.com
    >
    > It's is not, it isn't ain't, and it's it's, not its, if you mean it
    > is. If you don't, it's its. Then too, it's hers. It isn't her's.
    > It isn't our's either. It's ours, and likewise yours and theirs.
    > -- Oxford University Press, Edpress News
  8. Archived from groups: alt.internet.wireless (More info?)

    Hi there!!!

    I've just read all this thread and i plan to buy exactly the same
    equipment as you did Will.

    I just wanted to know if the DSL-300T modem provides a nice stable
    connection?

    Did you have any more problems with the modem/router after configuring
    or everything is just rocking?

    Thanks for the help!!


    --
    saga
    brought to you by http://www.wifi-forum.com/
Ask a new question

Read More

Routers Modem Wireless Networking