Sign in with
Sign up | Sign in
Your question

D-Link DI-624 disconnecting - solution!

Last response: in Wireless Networking
Share
August 3, 2004 3:05:22 AM

Archived from groups: alt.internet.wireless (More info?)

Ok, I searched and searched and was unable to find a solution anywhere..
I stumbled into it!

This message is here for archival purposes so that others who search as
much as I may find it one day.

Read reviews of the D-Link DI-624 or DI-624+ wireless router at Amazon,
epinions, etc. and you'll see hundreds of reviews about two major issues;
1) frequent loss of connection terminals connected via 802.11g
2) frequent 'resetting' of the router itself - breaking the connections to
all wired and wireless connections.

My symptoms; I have revision A and when I first attempted to use it, and
request to the DHCP server for an IP address from a WIRED connection
caused a reset of the router. I upgraded to the latest firmware (against
tech supports advice, I had no choice but to do it over a wireless
connection) and the resetting problem was fixed.

As for dropped connections - it was VERY annoying.. large downloads were
unable to complete, games closing when connection is lost, MSN relogging
in constantly, etc, etc.

The connection would come back in a few seconds time - I don't believe my
wired connections were ever being lost at this time (although many peoples
accounts claim theirs were). Note, this is now just connections being
lost, the router was not visibly restarting itself anymore.

Signal strength was always 'Excellent' (laptop was just a few feet from
the router).

Note, I'm using XP and these instructions are for XP (SP1).

D-Link's site does not admit to this issue although I could find literally
hundreds of accounts of it in various newsgroups, web forums, and review
sites.

The router was feature-packed and affordable, so I didn't want to give up
just yet.

solution:
The following worked for me, try it and see if it works for you;

log into the web-based admin tool of the router. Click on 'Tools' at the
top, then 'Misc.' on the left menu..
set the following:
UPNP Settings = Disabled
Gaming Mode = Disabled
PPTP = Disabled
IPSec = Disabled

You may be able to turn the above back on, the below instructions are what
really fixes things, but getting rid of those options simplifies the
problems a bit - plus, if you have no need for them (and most people
won't) might as well turn them off (why are they all enabled by default?)

Now, even more important, go to the computer whose connection is being
lost.. go to your network connections, right-click on the wireless
connection and view its properties. Under the 'authentication' tab, you
should see a check-box option for "Enable IEEE 802.1x authentication for
this network" - UNCHECK IT!!

This solution will hopefully help others who stumble into it in their
searches. It also applies to a couple of models of gateway routers that
were rebranded D-Link DI-624's.. for some reason tech support has no clue
how to fix it - consumers report having to pay shipping charges 2-ways to
end up with a new router and the same problems.

Oddly enough, many reviews mention the issue and still give the glowing
review - I guess they don't mind losing their connection for a few seconds
every 10-15 minutes - to me, it made the product utterly useless.

Good luck to everyone who purchased this router! I was minutes away from
giving up, but it works fine now! It's been 30 hours or so with no
dropping of the wireless connections!

Some keywords will follow to help other find this post: lost connection
dropping dropped lost losing D-Link DI-624 DI-624+ RevA RevB RevC
RevisionA RevisionB RevisionC wireless router Airplus ExtremeG 2.4GHz G
Plus 802.11g 802.11 WAN WLAN fix solution solved problem crashes crashing

Good luck all!

---
email: my_nick@canada.com // my_nick = mork
Anonymous
September 17, 2004 6:42:27 PM

Archived from groups: alt.internet.wireless (More info?)

I tried this and it did seem to help. Unfortunately, about 1 minute after
unchecking the 802.1x box, the D-Link Config Utility generated a failure
message and would not restart. It appears that this protocol is required, at
least by the DWL-G650B4 v2.53 drivers that I have installed.

I do have a third-party config utility and that seems to work w/o the 802.1x
box being checked.

--
John Bissell

"mork" <my_nick@canada.com> wrote in message
news:o psb4nuzdqttcg7w@bender.futurama...
> Ok, I searched and searched and was unable to find a solution anywhere..
> I stumbled into it!
>
> This message is here for archival purposes so that others who search as
> much as I may find it one day.
>
> Read reviews of the D-Link DI-624 or DI-624+ wireless router at Amazon,
> epinions, etc. and you'll see hundreds of reviews about two major issues;
> 1) frequent loss of connection terminals connected via 802.11g
> 2) frequent 'resetting' of the router itself - breaking the connections to
> all wired and wireless connections.
>
> My symptoms; I have revision A and when I first attempted to use it, and
> request to the DHCP server for an IP address from a WIRED connection
> caused a reset of the router. I upgraded to the latest firmware (against
> tech supports advice, I had no choice but to do it over a wireless
> connection) and the resetting problem was fixed.
>
> As for dropped connections - it was VERY annoying.. large downloads were
> unable to complete, games closing when connection is lost, MSN relogging
> in constantly, etc, etc.
>
> The connection would come back in a few seconds time - I don't believe my
> wired connections were ever being lost at this time (although many peoples
> accounts claim theirs were). Note, this is now just connections being
> lost, the router was not visibly restarting itself anymore.
>
> Signal strength was always 'Excellent' (laptop was just a few feet from
> the router).
>
> Note, I'm using XP and these instructions are for XP (SP1).
>
> D-Link's site does not admit to this issue although I could find literally
> hundreds of accounts of it in various newsgroups, web forums, and review
> sites.
>
> The router was feature-packed and affordable, so I didn't want to give up
> just yet.
>
> solution:
> The following worked for me, try it and see if it works for you;
>
> log into the web-based admin tool of the router. Click on 'Tools' at the
> top, then 'Misc.' on the left menu..
> set the following:
> UPNP Settings = Disabled
> Gaming Mode = Disabled
> PPTP = Disabled
> IPSec = Disabled
>
> You may be able to turn the above back on, the below instructions are what
> really fixes things, but getting rid of those options simplifies the
> problems a bit - plus, if you have no need for them (and most people
> won't) might as well turn them off (why are they all enabled by default?)
>
> Now, even more important, go to the computer whose connection is being
> lost.. go to your network connections, right-click on the wireless
> connection and view its properties. Under the 'authentication' tab, you
> should see a check-box option for "Enable IEEE 802.1x authentication for
> this network" - UNCHECK IT!!
>
> This solution will hopefully help others who stumble into it in their
> searches. It also applies to a couple of models of gateway routers that
> were rebranded D-Link DI-624's.. for some reason tech support has no clue
> how to fix it - consumers report having to pay shipping charges 2-ways to
> end up with a new router and the same problems.
>
> Oddly enough, many reviews mention the issue and still give the glowing
> review - I guess they don't mind losing their connection for a few seconds
> every 10-15 minutes - to me, it made the product utterly useless.
>
> Good luck to everyone who purchased this router! I was minutes away from
> giving up, but it works fine now! It's been 30 hours or so with no
> dropping of the wireless connections!
>
> Some keywords will follow to help other find this post: lost connection
> dropping dropped lost losing D-Link DI-624 DI-624+ RevA RevB RevC
> RevisionA RevisionB RevisionC wireless router Airplus ExtremeG 2.4GHz G
> Plus 802.11g 802.11 WAN WLAN fix solution solved problem crashes crashing
>
> Good luck all!
>
> ---
> email: my_nick@canada.com // my_nick = mork
Anonymous
September 17, 2004 6:42:28 PM

Archived from groups: alt.internet.wireless (More info?)

On Fri, 17 Sep 2004 14:42:27 GMT, "John Bissell"
<bissell@nospam.alum.mit.edu> wrote:

>I tried this and it did seem to help. Unfortunately, about 1 minute after
>unchecking the 802.1x box, the D-Link Config Utility generated a failure
>message and would not restart. It appears that this protocol is required, at
>least by the DWL-G650B4 v2.53 drivers that I have installed.
>
>I do have a third-party config utility and that seems to work w/o the 802.1x
>box being checked.

If you're using WPA encryption, 802.1x authentication is required.



--
Jeff Liebermann jeffl@comix.santa-cruz.ca.us
150 Felker St #D http://www.LearnByDestroying.com
Santa Cruz CA 95060 AE6KS 831-336-2558
Related resources
Anonymous
September 17, 2004 9:35:18 PM

Archived from groups: alt.internet.wireless (More info?)

Nope, I'm using 128-bit WEP.

--
John Bissell

"Jeff Liebermann" <jeffl@comix.santa-cruz.ca.us> wrote in message
news:076mk0hvrhfc6p6c87v1su911ins1ipqk0@4ax.com...
> On Fri, 17 Sep 2004 14:42:27 GMT, "John Bissell"
> <bissell@nospam.alum.mit.edu> wrote:
>
> >I tried this and it did seem to help. Unfortunately, about 1 minute after
> >unchecking the 802.1x box, the D-Link Config Utility generated a failure
> >message and would not restart. It appears that this protocol is required,
at
> >least by the DWL-G650B4 v2.53 drivers that I have installed.
> >
> >I do have a third-party config utility and that seems to work w/o the
802.1x
> >box being checked.
>
> If you're using WPA encryption, 802.1x authentication is required.
>
>
>
> --
> Jeff Liebermann jeffl@comix.santa-cruz.ca.us
> 150 Felker St #D http://www.LearnByDestroying.com
> Santa Cruz CA 95060 AE6KS 831-336-2558
Anonymous
September 17, 2004 11:56:46 PM

Archived from groups: alt.internet.wireless (More info?)

Hello

I have just solved the problem of losing the wireless connection to a D-Link
DI-624, by changing the Super G mode setting of the router to Super G
without Turbo. Since doing this, the connection has been stable for two
days.

Regards

John T
Anonymous
March 29, 2009 8:03:17 PM

Thanks!!!
I just bought a Lenovo Y530 and I could not connect to the web using my D-Link DI-624. Disabling the Gaming and UPNP modes appears to have fixed the problem after a reboot of the modem, router, and computer.
Thanks for taking the time to post the info!
January 10, 2012 1:03:06 PM

This router can't into wpa
May 2, 2012 8:33:44 PM

Man, you are a freakin' lifesaver!! Your tip on the router changes did the trick, but only after WEEKS of pulling my hair out trying to figure out this issue. Like you said, D-Link had NOTHING on their site about this and I had also come across hundreds of message board entries about the same issue. For me, it was happening specifically when using BitTorrrent or FrostWire apps; everything else ran just fine until I opened one of those apps, and then, it would immediate start dropping my connections.

I didn't have to modify any of my authentication settings as I use WEP2 (only WPA requires the 802.1x authentication), so I disabled the router features you mentioned, restarted the router, and I've been stable now for HOURS - while running BitTorrent.

You. Totally. Rock.

Thanks!

-Ron
email: Teknoshamn@aol.com





Mork said:
Archived from groups: alt.internet.wireless (More info?)

Ok, I searched and searched and was unable to find a solution anywhere..
I stumbled into it!

This message is here for archival purposes so that others who search as
much as I may find it one day.

Read reviews of the D-Link DI-624 or DI-624+ wireless router at Amazon,
epinions, etc. and you'll see hundreds of reviews about two major issues;
1) frequent loss of connection terminals connected via 802.11g
2) frequent 'resetting' of the router itself - breaking the connections to
all wired and wireless connections.

My symptoms; I have revision A and when I first attempted to use it, and
request to the DHCP server for an IP address from a WIRED connection
caused a reset of the router. I upgraded to the latest firmware (against
tech supports advice, I had no choice but to do it over a wireless
connection) and the resetting problem was fixed.

As for dropped connections - it was VERY annoying.. large downloads were
unable to complete, games closing when connection is lost, MSN relogging
in constantly, etc, etc.

The connection would come back in a few seconds time - I don't believe my
wired connections were ever being lost at this time (although many peoples
accounts claim theirs were). Note, this is now just connections being
lost, the router was not visibly restarting itself anymore.

Signal strength was always 'Excellent' (laptop was just a few feet from
the router).

Note, I'm using XP and these instructions are for XP (SP1).

D-Link's site does not admit to this issue although I could find literally
hundreds of accounts of it in various newsgroups, web forums, and review
sites.

The router was feature-packed and affordable, so I didn't want to give up
just yet.

solution:
The following worked for me, try it and see if it works for you;

log into the web-based admin tool of the router. Click on 'Tools' at the
top, then 'Misc.' on the left menu..
set the following:
UPNP Settings = Disabled
Gaming Mode = Disabled
PPTP = Disabled
IPSec = Disabled

You may be able to turn the above back on, the below instructions are what
really fixes things, but getting rid of those options simplifies the
problems a bit - plus, if you have no need for them (and most people
won't) might as well turn them off (why are they all enabled by default?)

Now, even more important, go to the computer whose connection is being
lost.. go to your network connections, right-click on the wireless
connection and view its properties. Under the 'authentication' tab, you
should see a check-box option for "Enable IEEE 802.1x authentication for
this network" - UNCHECK IT!!

This solution will hopefully help others who stumble into it in their
searches. It also applies to a couple of models of gateway routers that
were rebranded D-Link DI-624's.. for some reason tech support has no clue
how to fix it - consumers report having to pay shipping charges 2-ways to
end up with a new router and the same problems.

Oddly enough, many reviews mention the issue and still give the glowing
review - I guess they don't mind losing their connection for a few seconds
every 10-15 minutes - to me, it made the product utterly useless.

Good luck to everyone who purchased this router! I was minutes away from
giving up, but it works fine now! It's been 30 hours or so with no
dropping of the wireless connections!

Some keywords will follow to help other find this post: lost connection
dropping dropped lost losing D-Link DI-624 DI-624+ RevA RevB RevC
RevisionA RevisionB RevisionC wireless router Airplus ExtremeG 2.4GHz G
Plus 802.11g 802.11 WAN WLAN fix solution solved problem crashes crashing

Good luck all!

---
email: my_nick@canada.com // my_nick = mork

September 20, 2012 9:53:14 AM

Mork said:
Archived from groups: alt.internet.wireless (More info?)


set the following:
UPNP Settings = Disabled
Gaming Mode = Disabled
PPTP = Disabled
IPSec = Disabled


Oddly enough, many reviews mention the issue and still give the glowing
review - I guess they don't mind losing their connection for a few seconds
every 10-15 minutes - to me, it made the product utterly useless.

Good luck to everyone who purchased this router! I was minutes away from
giving up, but it works fine now! It's been 30 hours or so with no
dropping of the wireless connections!

Some keywords will follow to help other find this post: lost connection
dropping dropped lost losing D-Link DI-624 DI-624+ RevA RevB RevC
RevisionA RevisionB RevisionC wireless router Airplus ExtremeG 2.4GHz G
Plus 802.11g 802.11 WAN WLAN fix solution solved problem crashes crashing

Good luck all!

---
email: my_nick@canada.com // my_nick = mork



Just trying your settings mentioned above... hope they work!!! if you don't hear back from me they have worked
September 20, 2012 9:56:26 AM

Quote:
Archived from groups: alt.internet.wireless (More info?)

Hello

I have just solved the problem of losing the wireless connection to a D-Link
DI-624, by changing the Super G mode setting of the router to Super G
without Turbo. Since doing this, the connection has been stable for two
days.

Regards

John T




Haven't tried this yet, but i will if mork's suggestions don't work

thanks again you rocking life savers
!