Sign in with
Sign up | Sign in
Your question
Closed

Changing msconfig without windows

Last response: in Windows 7
Share
August 16, 2010 12:57:45 PM

Hi,
I have an ASUS notebook running windows7 and 4g memory. I changed the msconfig boot.ini /MAXMEM from its default (an uncheked box, but I presume 4096) to 256 while trying to get a program to load.
Saved and rebooted, now all I get is a BSOD with a stop error.
since I cant get back into windows , would anyone know how to change this parameter back to its default? restore points dont work, automatic repairs dont work either.
Cheers

More about : changing msconfig windows

a b $ Windows 7
August 16, 2010 2:42:09 PM

Can you boot safe mode/ command prompt
Score
0
a b $ Windows 7
August 16, 2010 5:12:58 PM

during boot hold the F4 or F8 key down and see if you can boot into safe mode and go into msconfig and reset things
Score
0
Related resources
August 16, 2010 8:07:01 PM

Hi
unfortunately, it wont even boot in safe mode.
Score
0
a b $ Windows 7
August 16, 2010 8:18:21 PM

Do you need an anchor for your boat?
Can you tell us what the stop error is reporting?
Score
0
August 16, 2010 8:19:40 PM


About the only thing I can get via a limited diagnostic menu is a command prompt window
Score
0
a b $ Windows 7
August 16, 2010 8:20:14 PM

get a new hdd and reinstall windows

it's usually not a good idea to mess with settings in msconfig unless you really know what you are doing
Score
0
August 16, 2010 8:23:36 PM

Thanks for your replies,
The error is a
stop 0x0000074 - not sure how many 0's , it all flashes accross quickly
Score
0
a b $ Windows 7
August 16, 2010 9:07:17 PM

I take it you've tried the "Use last good configuration" boot option? Unfortunately Windows 7 doesn't use a boot.ini file, so even if you could access the file system I'm not sure where this paramater is stored.

Basically, as I see it, the error message is telling you that you don't have enough memory to start Windows. If you've set the maximum memory to 256MB that's not surprising. Presumably you also chose the option to "Make these changes permanent". I'm really not sure what you can do now if the automatic repair options don't help. You may be looking at a format and reinstall.

Let this serve as a warning to others. If you must mess with the boot options then don't chose to make the changes permanent until you have tested them.
Score
0
a b $ Windows 7
August 16, 2010 9:17:21 PM

A couple of things to try.

1. I saw a post from someone with a similar problem. The could get into Safe Mode, but it took about an hour. So you may just need to be patient.

2. If you can get that command prompt again try:

bcdedit /deletevalue truncatememory
Score
0
August 16, 2010 9:38:56 PM

Thanks ijack,
prior to posting on this forum, I did a bit of hunting around and was able to run the bcdedit command without parameters, and it did diplay a page of output but i dont recall seeing anything remotely similar to /maxmem. but when I get home tonight, I'll try "bcdedit /deletevalue truncatememory".
I was kind of hoping there would be a bcdedit command to set /maxmem to 4096 or a default value.
thanks, if I can avoid a full rebuild, I'd be jumping with joy!
Score
0
a b $ Windows 7
August 17, 2010 6:22:59 AM

You should find the line:

truncatememory 0x10000000

in the BCDEdit output. I presume that removing this value will have the desired effect (and then when you boot you'll need to make sure that it's also altered in msconfig). But forgive me if I don't actually try it on my system!
Score
0
a b $ Windows 7
August 17, 2010 9:05:03 AM

If you can get to a command prompt, type sfc/scannow see if it fixes the core files before ou start deleting files
Score
0
a b $ Windows 7
August 17, 2010 9:10:30 AM

No-one has suggested deleting any files - merely the configuration parameter that is causing the problem. There is nothing wrong with the core files, so nothing for sfc to correct, it's just a matter of that parameter that is limiting RAM.
Score
0
August 17, 2010 9:18:24 AM

Hi,

You maybe able to use a free linux based operating system to boot up your computer. Then edit the file manually from in there. Knoppix is free and reads NTFS so its worth a shot. Information on how to get and install knoppix can be found here option 3 :
http://www.mypchealth.co.uk/GuideRecovery.php
Score
0
a b $ Windows 7
August 17, 2010 9:21:53 AM

I would be wary of editing a non-booting NTFS system from Linux. But, in any case, it's not a matter of editing a file. I'm not quite sure where Windows 7 boot parameters are stored but I would be extremely wary of changing them other than via bcdedit or EasyBCD. It's a bit like the registry - you may be able to change it without using regedit, but I wouldn't recommend trying.
Score
0
August 17, 2010 11:31:08 AM

before I did anything, I ran bcdedit to check the truncatememory parameter. it was indeed 0x10000000
then i tried running "bcdedit /deletevalue truncatememory"
rebooted and got the same BSOD screen
did it again and checked bcdedit output but it still displayed 0x10000000 truncatememory even though the "bcdedit /deletevalue truncatememory" command was accepted.
I even tried setting it to 4GB with "bcdedit /set truncatememory 0x1FFFFFFFF "
still get the BSOD
Also tried it using the UUID with the command "bcdedit /deletevalue {4c21825f-e04b-11dd-b760-00195876517a} truncatememory" but no change
Score
0
a b $ Windows 7
August 17, 2010 12:02:54 PM

Oh dear. I tested that command in a command prompt within a running Windows system and it removed the line. I wonder if something is setting it back again as you try to boot. Did you check the output after running the command but before rebooting?

The only other thing I can think of trying at the moment is Safe Mode. Does it actually BSOD when you try to get to Safe Mode or is it just that it doesn't appear to start? It can take a long time (reportedly an hour or more) to start Safe Mode under these conditions.

Edit: I found another thread that implied that you can't delete that value from a recovery console but you should be able to change it. Try:

bcdedit /setvalue truncatememory 0x100000000

(or even try a lesser value). The value that you gave is not 4GB.
Score
0
August 17, 2010 9:26:38 PM

yes, I checked bcdedit after making the change,(but before rebooting) and it did not display the changed value-still had the original value there.

Even in safe mode it goes to BSOD quickly.

I'll try bcdedit /setvalue truncatememory 0x100000000 tonight when I get home.
Thanks, much appreciated


Score
0
August 18, 2010 9:33:47 PM

it didnt accept the command with /setvale, but accepted /set
bcdedit /set truncatememory 0x100000000
even though the command was accepted , when I ran bcdedit, it still showed the old value.
I bit the bullet and reloaded Windows.
Thanks for all your time & assistance.
Score
0
a b $ Windows 7
August 19, 2010 6:38:54 AM

Sorry it didn't work out, but I learnt a few new things too. Bet you never do that again!
Score
0

Best solution

May 29, 2012 11:25:39 PM

I ran into the same problem and solved it...

The correct syntax should be:

bcdedit /deletevalue {default} truncatememory

where "{default}" is the name of the identifier where "truncatememory" is listed by "bcdedit". Also set it to something else by typing:

bcdedit /set {default} truncatememory 0x100000000

Remember to always take a backup before you start:
bcdedit /export c:\bcd_backup
To restore it type:
bcdedit /import c:\bcd_backup

and a help file can always be found when typing
bcdedit /?
or more specific help about an option:
bcdedit /? <option>
e.g. "bcdedit /? /set"

Now my Windows is booting without a BSOD..
Cheers!
//StarChild
Share
June 3, 2012 5:20:53 PM

StarChild0 said:
I ran into the same problem and solved it...

The correct syntax should be:

bcdedit /deletevalue {default} truncatememory

where "{default}" is the name of the identifier where "truncatememory" is listed by "bcdedit". Also set it to something else by typing:

bcdedit /set {default} truncatememory 0x100000000

Remember to always take a backup before you start:
bcdedit /export c:\bcd_backup
To restore it type:
bcdedit /import c:\bcd_backup

and a help file can always be found when typing
bcdedit /?
or more specific help about an option:
bcdedit /? <option>
e.g. "bcdedit /? /set"

Now my Windows is booting without a BSOD..
Cheers!
//StarChild



Thanks a lot for sharing this. I face the same issue just today tweaking the startup in msconfig then went to blue screen. Cannot go to safemode. I did exactly what you said, it is solved now. /suwanna
Score
0
June 20, 2012 2:50:00 PM

I am a newbie to this and I too made the mistake of disabling the boot manager display timeout option on my win 7 os. Was on the verge of format /reinstal but then found a way to get it back again.
I put in a win 7 disk and booted from it and went to repair option. In it chose command prompt and typed in ' bcdedit '. It showed all that was there to be known about the Boot Manager status etc.. The last entry in the boot manager list showed timeout as 0. Then again typed ' bcdedit /timeout 30 '. Then checked the 'bcdedit' again. rebooted and the boot option was back to 30 secs again. Booted sucesfully into the working os. Thankyou.
Score
0
January 26, 2013 2:36:16 AM

Thanks Starchild for sharing your solution !! It worked just fine for me and am really really glad that I came across this thread. Thanks to all the people associated with this forum where such solutions are shared for really nasty issues and which are not provided by the manufacturer/creator of such softwares !!!
Score
0
March 15, 2013 6:28:33 PM

StarChild0 said:
I ran into the same problem and solved it...

The correct syntax should be:

bcdedit /deletevalue {default} truncatememory

where "{default}" is the name of the identifier where "truncatememory" is listed by "bcdedit". Also set it to something else by typing:

bcdedit /set {default} truncatememory 0x100000000

Remember to always take a backup before you start:
bcdedit /export c:\bcd_backup
To restore it type:
bcdedit /import c:\bcd_backup

and a help file can always be found when typing
bcdedit /?
or more specific help about an option:
bcdedit /? <option>
e.g. "bcdedit /? /set"

Now my Windows is booting without a BSOD..
Cheers!
//StarChild


YOU SAVED MY LIFE. THANK YOU.
Score
0
!