Sign in with
Sign up | Sign in
Your question

Windows Vista with Warcraft 3

Last response: in Video Games
Share
June 29, 2007 3:49:29 AM

Hi, I am having a problem with warcraft under vista. I have tried running the game under 98/ME mode and windows XP /w Sp2 mode no luck, neither one of them works. Please help me, I hate switching windows

More about : windows vista warcraft

June 30, 2007 2:35:35 PM

just out of curiosity, you do have the game up to date, yes?

I run it no worries on my rig (vista x64) without having compatabilty modes checked. What exactly is the problem your having?
July 1, 2007 4:15:47 AM

After I open TFT, I get the TFT screen and then it just hangs I do get the loading circle but it never ends.... I don't even know what to do no more...
Related resources
January 21, 2009 9:35:23 PM

Can i get help with warscraft3 it is hangs no loading
January 22, 2009 6:33:39 PM

Did you try uninstalling and reinstalling? Are you running under administrator? Older games (not designed to be run on vista) must be run under administrator or they will not work.
Anonymous
September 7, 2009 2:13:38 PM

THE ANSWER!!! Spread the word!!!

You are not the only one with these symptoms: Running Vista x64. Warcrat 3 on launch fails to initialize Directx and tells you to install 8.1 or higher. You Reinstall the game, drivers and directx. Enable compatability mode and Run as Admin. Nothing works.

Well the answer came to me in a flash today when I was thinking about old DOS games that I could run in earlier versions of Windows. I thought 'What ever happened to good old OpenGL?' Then it dawned on me... Warcraft 3 came out during the Directx 8.1 days when OpenGL was still a valid and competitive API for hardware graphic acceleration!! I thought War3 MUST have a 'switch' or regedit that could force OpenGL.

Command line switches were usually pretty to figure out so on a hunch I did this...

THE ANSWER

I opened a run box and typed "C:\Program Files (x86)\Warcraft III\War3.exe -opengl"

HOLY CRAP it started up no problem! And here's the real kicker... I get better performance in OpenGL anyway...go figure.

Anyway this problem is everywhere on Google if you do a search so I'll be posting this info everywhere.
Sorry the answer came later than you hoped but I hope it's still of use to you.

Yours truely... A fat white guy in China.
Anonymous
December 26, 2009 5:15:36 AM

it doesnt work for me......How can do......still show me to have directX 8.1 or higher and ask me to inside the cd for the game.......can u help me????i got no problem with directX other...
Anonymous
December 26, 2009 5:23:06 AM

plez help me.........
!