Sign in with
Sign up | Sign in
Your question
Closed

Far Cry. Why is it lagging!

Last response: in Video Games
Share
August 15, 2007 5:51:25 AM

So I just bought my new computer about four months ago. I put it all together and it runs great.

System Specs....

2.6ghz AMD Dual Core 5000+
2x512mb Wintec Ampx
Gigabyte S-series sli ready (don't know model numba)
160 Sata WD Hard Drive
HP CD Writer
HIS Ice-Q 512ddr2 600mhz

blah blah. This is all above the minimum system requirements for Far Cry. I installed it with its latest patch. Today I went to play it and it is lagging kinda badly. Everything is at high (assuming it can handle it). Just for the sake of checking, I turned of Anti-alaising and vertical syncing. It is set at 1280x1024x32. I can't figure out why it is still being crappy. Background programs are turned of too so that isn't it. Someone help! Sorry about the long thread.

-Dustin

More about : cry lagging

August 15, 2007 9:50:30 AM

You need a faster graphics card. You only have an ati 2600 and you need a nvidia 8800 or 9200 when it comes out. Those are 8-16 times faster than yours respectively.
August 15, 2007 11:28:01 AM

FARCRY, NOT CRYSIS.

The only thing I could think of is RAM, are you running Vista (probably need more, vista pretty much needs 2gigs atleast for gaming), or XP (that would be sufficient).
Related resources
August 15, 2007 5:21:07 PM

I have an 1650 Radeon. I just bought it. You would think a $110.00 grapics card could handle it?
August 15, 2007 6:25:21 PM

It's not the best, but it should run it fine. For Crysis, you will probably want something better (as that will probably close to minimum.)
August 15, 2007 7:08:46 PM

I am running xp currently. I am also going to be getting 2 1gb sticks soon.
August 15, 2007 8:23:40 PM

I heard dual core can make things laggy.

But have you updated your video drivers and forced V-sync off?

I played far cry on highest with this pc with 1gb ram and a G6600. So you should play it easily at highest (don't enable HDR, wich might be a little to much, but you find that out soon enough if you type \r_hdrrendering 7)
August 17, 2007 3:37:27 PM

If you are still tracking this thread (after not getting too much help) have you: Installed AMD's dual-core optimizer patch? Have you tried setting an affinity to have the game run on just one core? Have you taken the red pill or the blue pill?

I would start with those first mang. Your system shouldn't be lagging at all, as that game is old.
August 18, 2007 10:27:29 PM

I know it shouldn't be. I played it perfectly on my dads 3800+ Processor with 512mb ram. WTF!!!
August 21, 2007 2:22:51 AM

Its your CPU.....Enter the game, CRTL ALT DEL, select the FARCRY.EXE process, right click, set affinity to CPU 0 or 1, return to game. Otherwise download a program called WINXPLauncher 2.0. It pre sets affinity on the game so it only runs off 1 cpu.
August 21, 2007 5:30:59 AM

It's not his CPU, runs fine on my system and I can at least run the game on a Athlon XP 2200+ and a 9250, with 512MB ram... Not to mention my current rig. Something is wrong, I mean, maybe you can't max out settings, but you shouldn't be lagging, and you should be able to have some good stuff on at that resolution. I would your various drivers, and also your temps on the CPU, mobo, and GPU...
August 21, 2007 5:52:43 AM

fender22 said:
It's not his CPU, runs fine on my system and I can at least run the game on a Athlon XP 2200+ and a 9250, with 512MB ram... Not to mention my current rig. Something is wrong, I mean, maybe you can't max out settings, but you shouldn't be lagging, and you should be able to have some good stuff on at that resolution. I would your various drivers, and also your temps on the CPU, mobo, and GPU...



I meant the Dual Core is causing problems. Far Cry is not designed to run on a dual core system.
August 21, 2007 11:52:54 PM

Snail said:
I meant the Dual Core is causing problems. Far Cry is not designed to run on a dual core system.


Yes Yes, I know, but It runs on Max Max Max settings on my system, if you'll notice, it's an Athlon X2 4600+, So, it should work anyways, make sure you have the dual core optimizer from the AMD site...
August 22, 2007 5:29:17 AM

fender22 said:
Yes Yes, I know, but It runs on Max Max Max settings on my system, if you'll notice, it's an Athlon X2 4600+, So, it should work anyways, make sure you have the dual core optimizer from the AMD site...



ok cool....just making sure we are all talking the same talk :-)
August 22, 2007 8:43:30 AM

underbyte18 said:
So I just bought my new computer about four months ago. I put it all together and it runs great.

System Specs....

2.6ghz AMD Dual Core 5000+
2x512mb Wintec Ampx
Gigabyte S-series sli ready (don't know model numba)
160 Sata WD Hard Drive
HP CD Writer
HIS Ice-Q 512ddr2 600mhz

blah blah. This is all above the minimum system requirements for Far Cry. I installed it with its latest patch. Today I went to play it and it is lagging kinda badly. Everything is at high (assuming it can handle it). Just for the sake of checking, I turned of Anti-alaising and vertical syncing. It is set at 1280x1024x32. I can't figure out why it is still being crappy. Background programs are turned of too so that isn't it. Someone help! Sorry about the long thread.

-Dustin



There's nothing more disappointing then getting a new rig and finding it doesn't cut it how you thought. Your vid card and ram, mate. Upgrade both, I'm afraid.

August 22, 2007 11:49:11 AM

strange, should run maxed no probs with those specs. It ran fine on my 6600gt a few years ago. Have you got your drivers up to date? installed the amd dual core optimizer? is your hdd badly fragmented? try defragmenting.
August 22, 2007 1:23:21 PM

Actually, like Impreza, I run a 6600GT with 2 gig of top ram and run Far Cry flat out with no probs whatsoever. In fact, there's only any hint of slowdown during a couple of the missions, and even then it's minor.

I didn't see your card at first, but yeah, for sure, I'm surprised at the slowdown.
September 6, 2010 8:23:23 PM

Snail said:
Its your CPU.....Enter the game, CRTL ALT DEL, select the FARCRY.EXE process, right click, set affinity to CPU 0 or 1, return to game. Otherwise download a program called WINXPLauncher 2.0. It pre sets affinity on the game so it only runs off 1 cpu.


Was looking everywhere for this answer. I LOVE YOU!!! Was getting 15-20 fps now I'm getting 150-250 fps. Far Cry definitely does not work with Quad Core Processors :|
September 6, 2010 11:08:53 PM

This topic has been closed by Mousemonkey
!