Sign-in / Sign-up
Your question

Problem solved....

Tags:
  • PC gaming
  • Games
  • Video Games
Last response: in PC Gaming
August 18, 2007 10:28:07 PM

About a week ago, I downloaded a demo of the game Infernal from Steam. I thought it was pretty fun, so I decided to buy it. (got a really good deal on Amazon). I went to play the demo again, before I got the whole game, and it started up fine. I clicked on New Game, and Normal difficulty. It started loading. When it got done loading, it told me "A problem caused the program to stop working correctly. Windows will close the program and notify yo uif a solution is availiable."

I just brushed it off, and played a different game. The full version of the game arrived a few days later. I installed it, it got started and everything, but when it finished loading the first level, it did the same thing.

So I decided to uninstall the game and the demo, and try again. Same problem. I turned down all the settings and tried again. Same problem. I right clicked, and chose to rrun it as administrator. Same problem.

I was a little frustrated. So I decided to re-install Windows (I know, it seems drastic. But I didn't have much on there anyway.) I got that done a while ago. After re-installing all the drivers and stuff, I installed the game. I was really expecting it to work, since there couldn't be any problems as it's a completely new install. But, same problem. I disabled the firewall. Same problem.

I really don't know what the problem is, and it's a little frustrating, especially since it was working fine when I first downloaded it. I would appreciate it if anyone could help me, and thanks to anyone who can give input.

My System:
Gigabyte GA-P35-DS3R
E6550@3.41Ghz (cooled by Tuniq Tower)
2Gb GeiL ddr2 800@974
Sapphire x1950 pro
74 GB Raptor
Antec 900
Windows Vista Home Premium 32bit

And... I did do a little bit with the bios on my x1950 pro. But I put it back the way it was. I just wanted to see if I could change the voltage. I don't think that would really cause this, as I pretty much didn't change anything....

Thanks again for your help.



EDIT: I found out it was the new ATI drivers. The 7.8 drivers. I went back to 7.7 and it all works fine.

More about : problem solved

August 18, 2007 10:59:25 PM

You might want to check if the PhysX program is interfering, it installed on my machine but for lack of PhysX hardware it's dormant. Not sure if Vista handles it differently than XP. You could also try the Omega Drivers (provided Vista ones are availible), I have never had problems with them and they work better than the ATi ones IMO. It is possible the card may have been damaged in the voltage change, but if it is working fine on other titles that seems unlikely. I am unsure of more, as I won't put Vista on my machine yet.

Damn, while I was still typing.
August 19, 2007 1:40:26 AM

Well, thanks for your help. I actually couldn't increase the voltage in the bios anyway... so yeah.

I think I might check out the Omega drivers, if you really think they're better.

And I really do appreciate your help. I love how there is always someone to help you on the forums here, no matter what the problem is.