Problems running game from virtual drive

A friend of mine recently gave me his copy of Age of Empires III: The War Chiefs (he barely played it, and never online), and I installed it on my PC with no problems. I decided to make an .iso of the game and run it from a virtual drive as I do with all of my other games. However, I will be playing this game and suddenly my monitor goes black, and begins to act as if the computer is turned off (switches between digital/analog signal, goes into power save mode). My keyboard and mouse are rendered useless, I can't do anything with them. While this is going on, I can still hear all the background sounds from the game (villagers collecting wood, talking, water, birds, etc.) but I can't do anything to close the game out. The first time this happened, I brushed it off as a one time thing and restarted my computer. Right after I saw the Windows Vista circle logo, the monitor went black again and nothing happened. I unplugged my keyboard/mouse and the computer didn't recognize them when I plugged them back in (num lock key and optical mouse didn't light up). I tried the monitor on my old computer and it worked right away. I unmounted the game from the virtual drive and played with the disc in the physical drive, and the same thing happened. For me to fix this, I have to hold the power button until shut down, restart in safe mode, then restart again.

Does anybody know what's happening to make my monitor just cut off from my PC? I was thinking it might be some copy-protection from the game itself, it's one of those "Games for Windows" titles. I was looking at the box art for the game Company of Heroes, another Games for Windows title, and there was some fine print on the back that said something about using protection against virtual drives. I'm going to uninstall/reinstall tonight and see what happens. I'm running Windows Vista Home Premium, Athlon 64 x2 5400+, 3GB DDR2 RAM, RADEON x1950 pro 256MB graphics card...
2 answers Last reply
More about problems running game virtual drive
  1. did you ever install any other games with starforce on them?
  2. On my PC, I have installed MVP Baseball 2005, Battlefield 2, Age of Empires III, Age of Empires III: The War Chiefs, Rise of Nations: Rise of Legends, and Pro Evolution Soccer 6. I have no idea which ones use StarForce...

    Also, I uninstalled and reinstalled, same stuff happened. I looked in the age of empires support forum www.agecommunity.com and it seems like a lot of people are having this problem, maybe due to an onboard sound card.
Ask a new question

Read More

PC gaming Games Video Games