Sign in with
Sign up | Sign in
Your question

Bioshock + AVG Free edition

Last response: in Video Games
Share
August 29, 2007 7:40:59 AM

Heres another tale to add to the bisohock drama.

I run AVG free (virus guard) on vista 64 bit and guess what, AVG just detected bioshock.exe as an obfustat virus and moved it to the vault. NOW I CANT PLAY BIOSHOCK!

After restoring the file etc etc .... vista tells me i dont have permission to run the file, tried all the usual (run as admin, change actual permission for folder and file) and cant get it to run.

So anyone who buys bioshock should consider removing AVG first!
August 29, 2007 1:55:02 PM

Bet those morons at 2k didn't adequately test this. I mean it's pathetic that you don't catch this when avg and vista is a pretty common setup for most gamers. Nice job developing a great game with a crap launch 2k.
August 29, 2007 2:13:32 PM

Makes me kinda glad I just said, "Sod it" and got it for my newly replaced 360… shame the console will stop working again but I should long be finished the game by then. Oh as far as the game is concerned it is not too bad, got a bit bored with it now though but that is to kind of be expected once you get over the wow effect of the game.
Related resources
August 29, 2007 2:50:22 PM

yeah I understand what you are talking about, but you know how it goes. The PC gaming industry has lacked creativity for some time now and we are in dire need of something that will wow us a little! How many times can you place the same first person shooter blah blah. You know what was a really innovative game. American McGee's Alice. That game reminds me a bit of bioshock. Great games. Just upset as hell about the DRM garbage left on the computer. Thats so rediculous.
August 29, 2007 2:57:07 PM

Bumping this, 'cause my friend needs a solution.

She hit heal with AVG (unfortunately, "heal" with AVG means "Destroy all things related to this object").

She's running Vista and has already tried uninstalling and re-installing twice (I'm a little bit worried about the DRM and SecuROM flipping a ****).

Any links to fixes are appreciated.

~T3h DRAY!
August 29, 2007 7:59:46 PM

Uninstall AVG not Bioshock - worked for me having had the "permissions" message from Windows (XP)
August 29, 2007 9:56:59 PM

You don't need to delete AVG (it's actually more the fault of AVG than Bioshock for detecting a virus where none is).

Launch AVG control center and double click on resident shield. Unmark the "Turn on Resident Shield" and click on APPLY. Then you can start Bioshock.

After playing, just re-enable it to be safe.
August 30, 2007 11:16:07 AM

Yea im all good now .. took the hard route though and uninstalled AVG and re-installed Bioshock (which didnt require re-activation .. yay) and all was good
August 30, 2007 7:56:11 PM

This happened to me with the demo and the next day an AVG update that was not an automatic download as usual fixed the problem, so try manually updating AVG (if you haven't already done this) if you are still running into the problem and it may be fixed.

Best,

3Ball
September 1, 2007 1:34:12 AM

I'll take the 1 in 10 000 risk of getting a virus when downloading a file, rather then making my dual core system feel like a single core P3 1ghz any day.
September 3, 2007 2:56:10 PM

It's not AVG's fault, it's user error. I have AVG and it came up with the same warning, but it doesn't move/heal the file unless you tell it to, and you shouldn't do that with googling first. Game files often flag up on AV.

Do not uninstall your AV protection because of this.
!