Sign in with
Sign up | Sign in
Your question

BioShock demo is fine on VISTA 32 , but i get an error in XP 64

Last response: in Video Games
Share
September 1, 2007 4:17:39 PM

When i click on the icon , i get this error :
This application has failed to start because d3dx9_33 was not found. Re-installing the application may fix the problem. i have this error in MARVEL ULTIMATE ALLIANCE too

i dont get this error in VISTA 32 ,
September 1, 2007 7:01:20 PM

so no one can help?
September 2, 2007 2:37:34 AM

Update your DX9
Related resources
September 2, 2007 11:32:11 AM

interesting , i began to install the DX which was with the Demo , but in the middle of installation i got this error

An internal system occured
Please refer to DXError.log and DirectX.log in your windows foler to determine problem .
September 2, 2007 12:21:57 PM

i downloaded the latest from microsoft and it said u have a newer version than this one and its ok now :D 
thanx again Emp
September 2, 2007 3:11:58 PM

Np
September 2, 2007 4:33:53 PM

can any one help my steam account keeps crashing when trying 2 connect
September 2, 2007 5:05:00 PM

why do u ruin my thread m8 ? make a new thread and ask
September 2, 2007 5:15:53 PM

thats strange i still get that error when i want to plau MARVEL ULTIMATE ALLIANCE , why ?
September 2, 2007 9:02:31 PM

Install C++ 2005 Runtimes, got the same error today when trying to play bioshock on my fresh XP installation.
September 3, 2007 10:42:26 AM

is it in here ? :
http://www.microsoft.com/downloads/details.aspx?FamilyI...

i isnstalled it and its same again , well next i donwloaded Visual C++ 2005 Express Edition, and it has 3 options, GRAPHICAL IDE , MICROSOFT MSDN 2005 EXPRESS EDITION , MICROSOFT SQL 2005 EXPRESS EDITION 64 , the frist one has a Tick , the other 2 dont have , i am going to tick the 64 edition too , lets see what will happen....
September 3, 2007 3:11:43 PM

well when the download was finished , i had something like this in program files :

VISUAL C++ 2005 EXPRESS EDITION ---> MICROSOFT STUDIO TOOLS---> VISUAL STUDIO 2005 COMMAND PROMPT , and when i go to it , its a black page and it has something like this :

C:\ PROGRAM FILES (X86) MICROSOFT VISUAL STUDIO 8\VC

there is another thing added too (in program files) :
MICROSFT VISUAL STUDIO 2005---> VISUAL STUDIO TOOLS ---> VISUAL STUDIO 2005 REMOTE DEBUGGER (X64)

so what shall i do ?

September 3, 2007 3:39:41 PM

thanx i downloaded it , but still the same , thats strange because i got the same error with bioshock but it was fixed but it doesnt work for MARVEL ULTIMATE ALLIANCE , maybe this game doesnt support 64bit afterall ?
September 3, 2007 4:33:10 PM

I used it in Vista 64... So I don't know.
September 3, 2007 5:19:25 PM

thats funny , in vista 32 when i click to install it nothing happens
September 3, 2007 6:28:45 PM

lol i can install marvel ultimate in vista 32 , but because i have installed it in xp64 and its in he hard disk , when i click on the icon it goes to the game (i used that c++ 2005 sp1 tough) thanx any way
September 4, 2007 2:47:43 PM

Upgrade your DX9 and reinstall your graphics drivers. I run XP 64 and that game and all other games (all newer titles) run great.
September 4, 2007 5:26:11 PM

it doenst let me to install DX9 , although my DX9 version is C
!