Sign in with
Sign up | Sign in
Your question

Battlefield 2 reduces my cpu speed

Last response: in Video Games
Share
September 8, 2007 6:49:33 PM

Hi, i installed the battlefield 2 demo some months ago and since I was able to play it on full specs on my notebok i bought the full game. Now here's the kicker:

When playing i get either ok framerates or the worst lag ever (this more often than ok frames), that almost prevents me from exiting the game, both in single and multiplayer....

I scanned my systemspecs and discovered that my 1,86 ghz cpu was reduced to 760 mhz.

Here's a few samples:
This is what it should look like...


This is how it looks after running bf...


And this is how it looks in EAsy info..


I have updated the chipset drivers and reinstalled battlefield without result. I guess its a hardwareproblem... maybe, but i run farcry in all the highest definitions and oblivion on medium, and the demo ran perfectly... :S

specs:
Zepto znote 1032b (msi motherboard)
1,86 ghz centrino cpu
geforce go6600 with the latest drivers
1 gig ddr2 so-dimm ram

anyone willing to give it a shot?
a c 82 à CPUs
September 8, 2007 7:18:48 PM

it could be overheating, and hence CPU throttling kicks in, not sure if your cpu supports throtting. Try using rmclock to see if it is throttling. (personally I can't interpret the screen on that prog. but it may be obvious that it is throttling) Else try and use TAT (possibly for your cpu), to see if it is hitting high temps.
September 8, 2007 7:37:04 PM

its obviously throttling... the cpu sped goes haywire when i move objects on screen... from 1800 mhz to a stable 790 when idle.
how do i fix that? it has not been a problem in other games O.o
Related resources
September 8, 2007 8:17:12 PM

to find out for sure, just download a temperature checking utility. you can use either speedfan (i dont know if it supports your mobo though, it is a bit flaky sometimes), nvidia's monitoring program, or just google "cpu temperature monitor". if the cpu goes up to (or over) around 72 degrees celsius, then your cpu is definitely throttling, and it is not battlefields fault. if it does get that hot, try to run the game in a very cool place (air conditioning or just pop it in the freezer) with good ventilation around the laptop (make sure you are not running it on top of a blanket with the ventilation holes blocked, or something like that). if the cpu stays under 70 degrees, and it still drops the speed, then there actually might be a problem, but try that out and get back to us.
September 8, 2007 9:22:03 PM

well, according to speedfan (the only monitor working for me :p ) my cpu runs stable about 56 degrees celcius all the time. my harddrive varied from 33 to 40 degrees celcius, and the problem is still the same, even with all videosettings to a minimum. i can feel the air from the fan getting hotter, but that might be my harddrive.
September 8, 2007 9:34:40 PM

hi i had a some what same problem with my gateway laptop

what i did was go in to the bio's and turn off or disable the power saving option. i think there may have been a option to turn off cpu throttling in the bio's too.
i plug mine in when playing games and stuff so i dont care about battiery life.
a b à CPUs
September 8, 2007 9:37:45 PM

First you need more ram, then you need to disable Speedstep to keep your CPU from throttling. If, like on a Dell laptop, disabling Speedstep causes your machine to stay at the lowered frequency, leave it enabled and download RMClock. In the Advanced CPU Settings tab uncheck "Enable Enhanced Halt state" this will keep your CPU from throttling due to Speedstep.
If heat is an issue get some canned air and blow the dust bunnies out of the vents.
http://cpu.rightmark.org/products/rmclock.shtml
September 8, 2007 10:21:56 PM

The ram was no issue on the demo, neither in singelplayer or online.
Disabling speedstep do cause the cpu to lock on the lower frequency, but RMclock does not allow me to change the enhanced halt state in advanced. I dont think heat is an issue, oblivion and other heavy games run just fine.
Is there another way around the throttling issue?
a b à CPUs
September 8, 2007 10:44:41 PM

I thought Speedstep on the Dell's was a bitch. If RMClock doesn't do it I don't know what else will,sorry.
Did you re-enable Speedstep in the bios before attempting to use RMClock?
September 9, 2007 10:18:36 AM

Yes i did re enable speedstep. The enhanced hat state is not aviailable (faded checkboxes) :( 
I will google around a bit and look for alternative solutions, but if anyone else get a bright ie let me know :) 
thanks for the help so far.
September 9, 2007 10:34:59 AM

But one question remains..... why did the demo run just fine???? Usually its the other way around: demos running slower due to unfinshed\unpolished programming. Not that this has anything to do with that :p 
September 9, 2007 12:08:21 PM

sorry for the triple post, but i googled around and found a program called speedswitchXP

http://www.diefer.de/speedswitchxp/index.html

It makes the computer run i max performance. I think it works somewhat like rmclock. Now i got ok framerates, some lag, but that might be the ram. I ran everything on high ettings, short of antialiasing and dynamic lightning. But then the game quit to desktop, with 256 colors and 800 by 600 res. Too hot to handle it seems :) 
September 9, 2007 4:15:47 PM

It's called speed step. It you run the game it will clock back to your original clocks anyway. I would just leave as is.

You can also change it in your power settings if you want.
!