Sign in with
Sign up | Sign in
Your question

help with BioShock Audio

Last response: in Video Games
Share
September 23, 2007 1:28:58 AM

just got the game / and have a new pc...
soudn works in the main menu and first cut scene, after the crash, during gameplay, so sound?? :ange: 

More about : bioshock audio

September 25, 2007 4:18:25 PM

:ange:  any1, I wanna play the game :bounce:  , haha
Related resources
September 26, 2007 10:58:02 PM

I've had trouble with BS on Vista. What OS are you using? Running Vista in "XP SP2 compatability" mode solved the sound issues for me.

In addition to sound problems the game crashed frequently on startup and lost all custom setting as well. I switched off the "Aero" interface in favor of "Basic" and now the game starts quicker and has not crashed since I made the change.

The games seems to be running solid now. Time will tell, I only made the changes yesterday.

BS is a pretty darn cool game once it is running good.
September 29, 2007 2:20:18 AM

"Aero" interface in favor of "Basic?

what you mean

right now, the game starts in a small window and most of the time crashes, too,
September 29, 2007 10:25:40 PM

lennyx said:
"Aero" interface in favor of "Basic?

Vista has a fancy 3d desktop called Aero that uses the 3d part of a video card.
Older versions of Windows are 2d only (flat).

You can revert to a "2d" desktop by switching from "Aero" to "Basic".
This tells you how to do it:

http://www.vistaclues.com/turn-off-the-fancy-windows-vi...

Example of Aero:


January 28, 2008 7:07:21 PM

lakedude said:
Running Vista in "XP SP2 compatability" mode solved the sound issues for me.


How do you do that?
January 28, 2008 7:27:48 PM

Right Click the Program Icon, properties - Select the Compatibility Mode tab in th epop up menu, click the checkbox in the top/center. then use the Drop Down to choose which mode.
January 19, 2009 6:38:59 AM

Hi there

I know it's been a while since this forum was open, but i'm facing the same problem. The sound works just fine until the crash and the Bioshock "logo" disappears. I currently have the beta version of windows 7, do you think that this could be the issue.

Greetings


an troubled gamer
May 2, 2009 5:13:15 PM

i have windows vista 64 bit
6 gb ram
600 gb hard drive
pentium dual core processors
geforce 8600 video card
running the downloaded version

the game menu and first video had sound but one the bioshock sign came up with the water dripping off of it the sound stopped. all drivers are updated. i tried switching the compatibility to windows xp sp2 and the sound started to work but now the game is windowed and the edges get cut off.
Anonymous
May 25, 2009 4:53:30 PM

who have real tek on board ?
so in windows vistas (64) goto /start /konfigu /sound /record /stereomix /enebel /.
in game go to /
opsions / sound /use reverb off /use creative eax off audio /than restard. game.

ok and vga is ....

vga / turn win background to ( 1024x768.depends of jour pc) to 16 bits .
in the game in enything jou wand end kan do whit jour pc .
sorry vor my poor lengwitsh ha ha lol .
i hoope enywan have some good ad this .
my pc con fig is .....
aser aspire whit a/ i7 procecor / 6 ghz onboard memddr3 /1ghrdati radeon ddr3 vga / and / 1000gig hd /for me it workt !!.
so i hoope eny wan have somthing from this .afz dre




Anonymous
May 25, 2009 8:55:17 PM

sory steriomix / =/ able......../ and the whole thing /and then it works ...
greedings drĂȘ .^_^.
May 28, 2009 4:09:12 AM

Bioshock sound is a mess, I solved the issue once by changing my output quality in the control menu.
May 28, 2009 4:09:28 AM

That is of course, I had to lower my quality.
May 31, 2009 9:58:03 PM

lakedude said:
I've had trouble with BS on Vista. What OS are you using? Running Vista in "XP SP2 compatability" mode solved the sound issues for me.

In addition to sound problems the game crashed frequently on startup and lost all custom setting as well. I switched off the "Aero" interface in favor of "Basic" and now the game starts quicker and has not crashed since I made the change.

The games seems to be running solid now. Time will tell, I only made the changes yesterday.

BS is a pretty darn cool game once it is running good.


Hi Lakedude

I am currently running Win7 RC 64bit and also had the same sound issue, As soon as the plane crashed my soud went dead.

I installed windows virtual pc and virtual windows win xp. I installed the game on the virtual pc and placed the shortcut in the program files open to all users.

All I get is "Bioshock cannot be launched from a remote session".

How did you get it to work or have I done it wrong?
Note: I purchased the game through steam. I dont know if this makes any difference.

Does anyone have any tips?
August 31, 2009 12:45:51 AM

Hey Everone, I found a solution that at least worked for me, i was having the same issue that everyone else is posting with no sound for bioshock. it sounds weird but all i had to do to fix the issue is plug something into my microphone port. i just plugged a pair of headphones into it and it the sound starting working. sounds strange but it worked for me. hope this helps someone.
Anonymous
September 27, 2009 1:46:10 AM

igot2board said:
Hey Everone, I found a solution that at least worked for me, i was having the same issue that everyone else is posting with no sound for bioshock. it sounds weird but all i had to do to fix the issue is plug something into my microphone port. i just plugged a pair of headphones into it and it the sound starting working. sounds strange but it worked for me. hope this helps someone.


this worked for me too!!!!!!!!!!!!
October 5, 2009 1:08:36 PM

Hy, this is a copy from another forum, its work for me

.....Open start, than Controll panel, Sound, Than recording( My OS is set to norwegian so i don't know exactly the name of the menu, but it is the one in the middle and it has options with recording) In the recording window there will be a few options, right-click in the background of the window and press "Show offline units" (again i have norwegian OS don't know exactly what it says" press "Show offline units and you will have a new option called something like Stereo Mix. Enable Stereo Mix, and hopefully it will work.....

With "Audio CD", make the same thing.
October 26, 2009 12:24:53 AM

NTG said:
Hi Lakedude

I am currently running Win7 RC 64bit and also had the same sound issue, As soon as the plane crashed my soud went dead.

I installed windows virtual pc and virtual windows win xp. I installed the game on the virtual pc and placed the shortcut in the program files open to all users.

All I get is "Bioshock cannot be launched from a remote session".

How did you get it to work or have I done it wrong?
Note: I purchased the game through steam. I dont know if this makes any difference.

Does anyone have any tips?






NTG,

i too have windows 7 RC and had the same sound issue. i tired starting the game with Xp SP2 but then it wouldnt start at all. did you find a solution?
October 26, 2009 3:46:23 PM

I've never had to touch BS compatability settings; check the ingame settings and make sure the sound is set correctly from there.
Anonymous
November 1, 2009 3:44:49 PM

Quote:
this worked for me too!!!!!!!!!!!!


This worked for me also.
Anonymous
November 30, 2009 2:11:43 AM

Real solution is not playing the game in XP compatibility mode.

May seem odd enough... The problem is with REALTEK integrated cards, ultimate solution here:
http://nocturne.noctalis.com/codex.cgi?Windows_7_No_Sou...

Worked for me perfectly, simple and fast. Hope will help.
Anonymous
November 30, 2009 2:13:17 AM

Quote:
This worked for me also.


Eh!
That's exactly the problem: stereo mixing goes ON when plugging microphone, you can do that also in the Control Panel without plugging in the mic.. See my link above.
February 10, 2010 5:42:36 PM

I know this thread is out of date, but try and download the 1.1 patch and it will fix the sound issue. I just did and it works fine now.
March 18, 2010 4:24:21 AM

tuesday0180 said:
I know this thread is out of date, but try and download the 1.1 patch and it will fix the sound issue. I just did and it works fine now.


i did this all it gave me was some new plasmids it did nothing for the sound problem
March 26, 2010 12:17:17 AM

badzombie said:
i did this all it gave me was some new plasmids it did nothing for the sound problem



I also used windows 2000 compatibility as recommended by the bioshock customer service team I contacted. It worked for me.

Just right click the game icon and go to compatbility mode and check windows 2000 and see if that works.
April 14, 2010 7:38:25 AM

Hey there,

I bought Bioshock a day after it was released and had this same problem... last week i went through your forum input and went home and tried it! it worked!! i've been waiting so long for a solution! I've finished the game and started Bioshock 2 today!!!!

your input is greatly appreciated!!! You F*$"ing GENIUS!!!!

Dane (South Africa)
November 4, 2011 3:55:49 AM

ATTENTION BIOSHOCK PLAYERS!!!! I have been through it all and tried all the fixes for the no sound issue. I too have Windows 7 64Bit OS and my sound would mess up after the first cut scene. This fix works 100%. If you think you have all your audio drivers up to date, check again. Go to your motherboards manufacturers website, search for your model number, and download the Audio drivers, this worked for me after trying everything!!! If you do not know what motherboard you have go to google and serach "CPUID" and download the respective installer for your system. Have fun!!!
November 4, 2011 3:57:18 AM

I know im so latee!! but if anyone needed the help this will work for sure.
!