Sign in with
Sign up | Sign in
Your question

Bioshock crash when picking up Plasmid/Tonic...

Last response: in Video Games
Share
September 23, 2007 7:55:21 PM

Hi all

I've got a problem with bioshock (for PC). There seems to be about a 70-80% chance of a crash when picking up plasmids/tonics, or any other vial that gives abilities. I've had it crash once when harvesting a sister, but i think that time it may have been heat related (forgot to turn up fans after starting the game)

Basically is, i'll pick it up, and that brief second that the game pauses before the pop-up shows up is when it mostly freezes. Sometimes it'll give my PC a hard lock up, other times it'll boot me to desktop with windows saying there was a problem with my graphics drivers.

System specs:

Intel C2D x6800
SLi 8800GTX
evga 680i motherboard
4GB ram
Create X-Fi fatality
Vista ultimate

All drivers are up to date.

If anyone's seen this before, please let me know, it's making the game hard to play, i have to save every time i come to a vial in fear of a lockup, and really just slows the pace of the game down.



Thanks for your time.

EDIT: Forgot to add, playing at 1920x1200 wide, all features high
September 23, 2007 8:00:55 PM

I have a similar issue just like yours, but in my case the game crashes even before it starts the first level !
but still can't figure out whats wrong..
So you can consider yourself Luckier :D 
September 23, 2007 8:23:26 PM

weird, have you tried lowering the settings, Its unlikely to make a difference but it might, you should certainly try reinstalling the game you could also make certain that you don't have any old drivers or anything clogging up your system
Related resources
September 27, 2007 5:54:51 PM

Just an update, still haven't been able to fix the problem. tried lowering settings, all drivers were uninstalled before updated.
September 30, 2007 2:38:54 AM

Welcome to the club! Stop wasting your time on this, as you'll never be able to fix it. The game code is just a mess. Even the X360 version has all kinds of problems. Go to the forums section of this website so you can marvel at all the problems this game causes.

http://forums.2kgames.com/forums/forumdisplay.php?f=42

I wonder if this game was play tested at all. Anyway, I've decided not to bother with it again until a patch is released.
October 5, 2007 12:49:02 AM

luckily for you i have a solution for yo :) 
i have a similar system to yours:
C2D E6850
SLI 8800gtx
4gb ram
vista x64 ultimate...

I also had the EXACT problem you have...the simple solution is to disable sli for as long as you play bioshock....and i mean disable sli...not selecting single-gpu mode in the bioshock sli profile....since we quite have the same system i think this will fix your problem...
ch40s
!