Sign in with
Sign up | Sign in
Your question

StarCraft (original) Widescreen Problem!

Last response: in Video Games
Share
October 26, 2007 8:07:27 PM

Hey guys,

im talkin about an old game thats resolution cannot be changed. when i run SC on my widescreen, it stretches >< i would rather have 2 black bars on the sides so that the image isnt stretched. i have an ATI x1300 PRO - pci-e. monitor is a samsung 931bw, 19" widescreen resolution 1440x900 if that matters. can anyone help me?

o yeah, and im a newbie at software/programming related stuff. id love to learn.
thanks!

-Xae
October 27, 2007 4:11:06 AM

If your monitor does not support 1:1 Bit Mapping or Aspect Ratio, then you need to play it in a window.

Check the OSD menu under something like advanced video (my NEC LCD2690 has it in a "Screen Position" icon and is part of "Expansion") for these options.

To play it in a window download DxWnd 1.034 from the following site:

http://www.nynaeve.net/?p=52
October 30, 2007 4:28:34 AM

thanks for your reply.

i didnt have such option in my OSD menu. darn...

i did find that site quite a while ago but playing it in window is just not the same. also, the window comes out to be very tiny. when i play its a bit more choppy windowed. also has a small lag i believe. i guess im stuck huh?
Related resources
October 30, 2007 4:35:43 AM

Yeah i get used to the widescreen.
October 30, 2007 9:03:11 AM

>.<

If anyone has a simple solution, please keep me notified! Thanks!

-XaeLee
October 31, 2007 8:44:07 AM

Hello,

Hmm... well so far I've been able to get the program Catalyst, for my OS + graphics card, but I still cant seem to find an option that lets me keep the native ratio. the link was not specific enough to help me, or perhaps my Catalyst driver doesn't come with it. Would someone be so kind to help me out a lil more? thanks!!
October 31, 2007 7:43:45 PM

From what I've seen, it isn't possible to preserve the ratio with ATI's drivers (seems to be the consensus based off google searches). You can either allow it to stretch the game, or display it in all it's 640x480 glory, centered on your monitor surrounded by beautiful black borders.

This is the only report I have ever seen on successfully running SC at a resolution other than 640x480.
http://forums.extremeoverclocking.com/t189465.html
The program used was 3danalyzer.

If you try widescreen it may fail, so you may want to choose the highest resolution that still maintains the 4:3 ratio and is less than 1440x900, e.g., 1024x768, and using ati's catalyst control to frame it. Experiment, and i'll do the same as well when I get home.

UPDATE: It doesn't appear possible to run it at a resolution other than 640x480. I see no option in 3danalyzer that let's you control resolution.
November 2, 2007 7:03:03 AM

Hello!

ahh i see, but in fact, i do understand it can only be played at a 640x480 resolution, and i do want to play it at that resolution, centred on the screen. if i do that i can just change my computer resolution before i play so its centred bigger or something haha, anyway not important. i just want to know how to make it not stretch across my stupid widescreen. is there ANY way for me to get black boarders? is there any way for me to play this game on my computer without stretching it?

just yesterday i went to my friends house and i played starcraft there... he had the 4:3 ratio monitor... and i got so confused! i couldn't judge where to put my stuff because everything wasnt stretched across a widescreen.

i'm beginning to give up. it's not THAT big of a deal, but its just been something poking at me since i got this new computer. playing new games great =D but then my favorite classic... yeeeaah =(

thanks to those who posted! i appreciate the advice and stuff. even though there hasnt been a solution for me yet, im learning a lot and exploring more about computers and stuff. if theres any way i can contribute back, please just ask!

EDIT: oops, a lil side note. when i run my monitor on a 4:3 ratio resolution, my monitor still stretches it across full screen, thx!
November 2, 2007 8:34:54 PM

Hey, can you post a screenshot of catalyst? Also, what are you running this on? Laptop? Desktop? Make sure your have the latest ATI drivers (and therefore version of catalyst). Be aware, that on that site I linked to they have it in "Advanced" mode, rather than "basic". I used to own an ATI card, but no longer, so it's a little harder for me to walk you through this. Maybe some current ATI owners can drop in.
November 3, 2007 7:31:12 AM

Hello,

Im running this on a Desktop. i cant seem to figure out how to post a screenshot, ill figure it out after i post this. i have the latest drivers for my videocard, i usually check my drivers about weekly (get bored of homework easly haha). i am using the advanced settings as well on this side.
November 3, 2007 7:33:55 AM

lol dang... i cant figure it out. for now ill spell it out.


Top Menu: (v) = scroll down menu
View(v) Hotkeys(v) Profiles(v) Preferences(v) Help(v)

Graphics Settings: (appears as a tab, but there are no other tabs)
Welcome
+Information Center
-Graphics Software
-Graphics Hardware
Display Manager
Display Options
+Monitor Properties 0
-Attributes
-Adjustments
-Avivo(TM) Color
+Monitor Properties 1
-Attributes
-Adjustments
-Avivo(TM) Color
+3D
-Standard Settings
-Anti-Aliasing
-Adaptive Anti-Aliasing
-Anisotropic Filtering
-Catalyst (R) A.I.
-Mipmap Detail Level
-All Settings
-More Settings
Color
+Avivo(TM) Video
-Presets
-Basic Color
-Basic Quality
-Theater Mode
-All Settings

Buttons at bottom:
[Basic...] [OK] [Apply] [Discard] [Defaults]
November 4, 2007 12:56:39 AM

You can take a screenshot by pressing "Print screen" this will take a screenshot of your whole desktop and put it on the clipboard. Pressing ALT+Print Screen will take a screenshot of only the window that you currently have open. Simply paste it into paint or what not, and save as a jpg.

You should navigate to Monitor Properties 0>Attributes and then select "Use centered timings" (assuming monitor 0 is the one you play starcraft on). If you don't see that option there, take a screenshot and post it. Or, do your best to describe what you do see.
November 4, 2007 4:48:38 AM

Hello,

haha, dont worry, i know how to take screenshots, its just i cant find out a way to put the file on this thread. anyway, so far i see...

+monitor properties
attributes

then away from the graphics setting panel, at the top there is a scroll down menu that identifies my two graphics cards. it looks like...
Graphics Adapter: [1. radeaon... [V]]

next there is the monitor information. there are no options or menus in this small section, it goes as follows:
MONITOR INFORMATION
display data channel (ddc): supported
display Name: syncmaster
maximum reported resolution: 1920x1080
maximum reported refresh rate: 75 Hz

then there is the monitor attributes. it has a few options. heres how it looks:
MONITOR ATTRIBUTES
(check box) [ ] use extended display identification data (edid) or driver defaults
Maximum resolution:
[1440x900 [v]]
Maximum refresh rate:
[75 Hz [v]]
(those were scrolldown menus)

thats it for now. so as you can see, there is nothing to select as "Use Centered Timings"
November 6, 2007 12:20:22 PM

i got an ati x1400 on my notebook.
fulllscreen on vista but 2 black bars on xp.
want fullscreen on xp dunno how.

!