Sign in with
Sign up | Sign in
Your question

Dragon's Lair 3D working flawlessly....then not!

Last response: in Video Games
Share
November 7, 2007 7:51:46 AM

Hi everybody, I'm new to this forum. :-)
I own a HP 2.4GHZ Quad Core, Nvidia 8600GT 512, 4GB Ram, Windows Vista Home Premium Italian Language.
Some days ago I installed international version of Dragon's Lair 3D and it worked perfect in Italian language.
Then, few days later, suddendly, it no longer started. :-(
When I launch it I have the options menu, then I click play and DL3D.exe simply doesn't start anymore...
It says 'the program is not responding' and I have to close it by Task Manager.
I uninstalled programs I had installed the day Dragon's Lair 3D no longer worked (Vampire Bloodlines), I set every compatibility tab and administrator, I re-installed Nvidia drivers, I set affinity and priorities, I uninstalled and re-installed the game even in English language, I edited keyboard ini and dl3d.ini....
I tried everything to make it work again to no avail.

I first experienced this problem when launching the game in multitasking along with 'xmpeg' and 'nero burning' and checking the 'only show this option menu when pressing shift' in Dragon's Lair 3D option window but this may be a coincidence since I already tried to launch these programs and other games together before without problems.

Before it worked normally without any modification or intervention at all. It worked smoothly out of the box.

Can anybody help me resurrect my beloved game?
Thanks everybody in advance and Greetings to you all.
Al
November 8, 2007 1:49:36 AM

ok, first off... you have an HP. secondly... is dragons lair 3d available for linux? haha. sorry man, that's not denough information for me. I would try the easiest way to completely uninstall and reinstall dragons lair by doing this....

1. completely uninstall, then manually remove any remaining folders and if you're advanced enough, any left over registry items.

2. shut down, wait 10 seconds, restart.

3. reinstall.

4. repeat step 2.

5. try to play game.


now thoes are precautionary steps that shouldn't need to be taken now. but i bet shista (vista) is your primary problem... nothing is compatible with it yet. and it just sucks... so like i said before... is DL3D available for linux? if it is, i suggest you at very least do a dual boot with Ubuntu, and shista. so you can play other games and have an operating system that isn't completely frustrating.
November 8, 2007 6:24:22 AM

Thanks for your answer.

Actually I already tried to unistall and delete leftovers (including registry ones, launching regedit and a search with Dragon's Lair 3D and deleting all the strings one by one) BUT I have not shut down and waited 10 seconds.

Unfortunately this game is not available for Linux so I'll try out your step by step exactly as you suggested since
those steps may be the difference. :-)

Btw, do you know of any good registry explorer/viewer to install that may help me out better identify the Dragon's Lair 3D strings?

Thanks again. ^_^
Related resources
November 9, 2007 8:43:36 AM

I tried the steps you suggested but changed nothing. :-(
I even disabled the administrator check that constantly buzzes in Vista to no avail.
There must have been some change down in the bowels of S-Vista that is now not easily trackable and changeble....
Thanks anyway for your suggestions.
November 9, 2007 11:38:29 PM

ok, first off... it'll prolly work in xp... don't expect any fixes (for a game that old) in shista. secondly, the steps i provided to you are mostly just general pc rules... or "electronics rules" it takes approximately 10 seconds for the charge to completely dissapate from all of your parts... if you really want to discharge all the electricity from ANY device... disconnecto the power source and hold the power button to the device on... pretty simple, but those steps are just the PROPER way of doing it... to ensure a "clean" install... and i quote "clean" because it really shouldn't matter that you completely shut down in this day in age... If you really want to play DL3D, I suggest you set up a dual boot with an opperating system that will support it... I belive the last time I installed that game it was on windows xp service pack 1. but i'm not sure, that was back in the day... so try a dual boot... give most of your hd to your current/prefered OS and some 20 gigs or less to your secondary OS. (20 gigs to provide pleanty of space for extra games)

and good luck. I didn't really do any research on the subject... maybe do a google search for "dragons lair vista" and see what happens... if that doesn't work tag it with "install" as well. that may be the difference. :-p and it MIGHT work on linux, go to ubuntuforums.org and search "dragons lair" and see what comes up... never know, thoese linux users are pretty good at getting almost anything to work on ubuntu. :-p
November 9, 2007 11:45:01 PM

k. just updated my page to see your latest reply.... dual boot is prolly going to be your best option for now. Shista is not great, basically the only adopters are buisnesses that are worried about security issues (because xp is no longer supported as of 08) and people that want to play the latest games with dx10.... and can afford rediculously fast hardware to support the monster turd.

"longhorn" was shista's code name back in 2000 or so... when we all had 128 megs of ram in our $2k pc's and that was huge, they stated that "longhorn" would require a minimum of 1gig... they were retarded to release that figure. anyway, yeah, i hate windows... but xp may be your only bet. i'll stop ranting now.
November 10, 2007 8:03:43 AM

Dragons lair uses Safedisc version 2. Bloodlines uses Safedisc version 4.

I would speculate that Safedisc tried to update itself, and now no longer recognizes the older version.
November 10, 2007 8:47:41 PM

you think it could have been blocked from finishing/doing the update by a firewall or something like that? i've had stupid stuff happen to me like that when i ran windows. :-p
November 12, 2007 9:20:04 AM

Actually I did many (many) search in Internet before posting here; I tried every kind of word associated with Dragon's Lair 3D.
I also thought about SafeDisc 2/4 problems but I even tried it with a NoCD.exe and uninstalled Vampire but the problem persisted anyway.
When I looked inside the error log of Vista I found out that the very first time it didn't work the message was "the program cannot recognize windows" so it seems that this game no longer found the OS!
But all the other error messages in the following attempts are "program doesn't respond" and no more messages like the first.
I've uninstalled and uninstalled, deleted every possible entry associated in the registry, I think I totally nuked the game in the system but when re-installing again, there it is the problem again...
!