Promise RAID controller problem

I've got a MSI KT3 Ultra-ARU board which has the Promise PDC0276 Raid controller.

I just picked up a WD 120GB drive and stuck it in my box. This drive hasn't caused any problems yet as far as I can tell, my problem is with my striped raid array.
I've always had a problem with my array not booting properly. I'd get a "Boot device not found" error, but setting the bios to "try other boot devices" fixed the problem early on so I never paid it much attention.
After installing the WD drive on my other IDE channel (which also has another drive on it), I booted the system using my WinXP CD in order to create a partition on the WD drive. That all worked fine, so I went to boot into Windows and my usual boot error poped up, followed by another boot error. Usually the system will find the striped array and boot Windows, but not anymore. I haven't changed anything hardware wise about the array to this point. Even removing the WD drive changes nothing.
Reading through the Promise manual I noticed that my array didn't have the "*" beside it, which is supposed to designate a bootable array I guess. As far as I know the array has never had the "*" symbol. Since the manual said it was possible to delete the array and recreate it with all the same settings without data loss, I tried that. Still no "*".

So how do I define an array and make it bootable? I haven't been able to find any way of defining an array using the Promise utility except the "automatic" option. Hope someone has an idea or two! Thanks!


- Alec

"Something is only impossible until it's not."
4 answers Last reply
More about promise raid controller problem
  1. well I'm not sure what to say...

    other than make sure the RAID card is in the boot sequence verify the jumpers on your HD(s?) WD Has this PM2 jumper that many don't know how to use correctly. what are your other drives?

    I always tough this controler was bootable but there might be revisions I don't know of.
  2. I will double check the WD drive's jumpers, but I'm pretty sure they're correct. Besides, my array won't boot even with the WD drive disconnected.

    I've got two Maxtor 40GB drives on the striped array, both are jumpered to "master". I've got another Maxtor 60GB drive as the master on IDE1, with the WD drive being the slave. DVD drive and CDRW drive are on IDE2.

    The boot sequence has the raid array as the only bootable device, but it's never worked properly. As I said, it would always give me a boot device not found error, but eventually it would find the array and boot from it. Strange that it doesn't do this now.

    - Alec

    "Something is only impossible until it's not."
  3. Ideas?

    - Alec

    "Something is only impossible until it's not."
  4. Your detection of the array device is a function of Bios. Try setting your boot device to SCSI. If you check device Mgr you'll see thats where your promise drivers are loaded.
    Hope you Bios has the option and it works. Best Luck.

    Mister "G"
Ask a new question

Read More

Motherboards Western Digital Controller