Sign in with
Sign up | Sign in
Your question

NIC will network but no internet

Tags:
  • Routers
  • Linksys
  • Networking
Last response: in Networking
Share
Anonymous
February 4, 2001 12:42:41 AM

Ok, so I awhile back I got a Linksys network card and Linksys router to go with my cable modem and 3Com NIC I have my other machine. Set it all up, the router worked perfectly with this machine (the 3Com), but the Linksys card will only network for some reason. It will not connect either through the router or directly to the cable modem. It also will also not bring up the router settings page (the 192.168.1.1 thing). But there are no problems moving files and such between the computers. I have also tried the 3Com card in the other machine, and it has the same results, no internet. I've tried the obvious of unistalling and reinstalling all the drivers/network setting/etc., pulling the card, different cables, etc. I've tried with just Client for MS network-the NIC card-and TCP/IP under network settings, and also with adding things like Netware, Windows Logon, IPX/SPX, NetBEUI and Dial-Up (which Linksys recommends for some reason), and then everything in between just to be sure. I've checked all the TCP/IP setting a hundred times now and they match the settings of my other computer and the computer of another guy I know using the same cable internet: DHCP-on, IP-auto, DNS-none, Gateway-none, not much to screw up there.

Another thing is I did have the 3Com card in the other machine for a short while a few months ago, and had no problems (took about 1 minute and I was on). And I haven't done any major system changes since (installing some games, which of course could still cause a problem). I also tried reinstalling Windows after the first few weeks of trying (haven't reformatted yet, that will be next if I don't get anything better to try here). And I've tried Internet Explorer, Outlook, IM, Napster, pinging Ip's...Nothing works. When I did have the 3com card in it did detect a remote computer with the Diagnostic software. Also If I try to run the Linksys Diag program, it stops at 'Internal Loopback Test' saying "Contact your dealer or Network Everywhere" (Config Test, I/O Test, and ID Test pass). Another note, before going to this I did have a Diamond Homefree network sharing these computers (don't see how that could matter since it's all deleted, but who knows).

I'm 99% sure it has to be a setting seeing that the modem and cable work with the other system, it doesn't work without the router so that's not it, the NIC can still network, so can't be defective (right?). But seeing that all the settings should by everyway i've seen it be right also, it's really got me stumped.
Are there more settings that could cause a problem other than what's in Network Settings?
Why will it go through the router to the other computer, but not to the router settings itself?
Is there any way it could be a virus?
Would it help if I took the computer outside and ran it over with my car? :) 
I've emailed Linksys support, nothing back (though it's probably not thier problem since the other card won't work either). And I don't at all wan't to talk to the people at my ISP since thier all morons.
Any help would be very (very, very, very, very) much appreciated (I have had this for about a months so far, and am not closer at all to an answer).

More about : nic network internet

Anonymous
February 4, 2001 12:45:31 AM

Forgot system info:
Intel 440bx mobo (With Celery 366)
Linksys LNE100TX 10/100 NIC
Windows 98
Time Warner Roadrunner for ISP

Thanks
February 4, 2001 2:51:59 AM

ok, my first reaction to your problem was a corrupt tcp/ip protocol. i've seen this type of problems at work and personally at home. try installing from a different windows cd. this is definetely an os caused problem. try restoring your registry or better yet format your system.

If you can't beat 'em kill 'em
athlon "SLOTA" thunderbird 700@1050mhz
Anonymous
February 5, 2001 5:23:24 AM

I can't tell ..did you try a different NIC in the comp with the Linksys 100TX NIC or no? I've had serious problems with those NICS.

***Hey I run Intel... but let's get real***
Anonymous
February 6, 2001 12:38:50 AM

Sorry, I didn't make that very clear in my post. Yes I did try a 3Com card in that system, and it had the same problems.
I think I am going to reformat that computer and see if that works (I want to put windows 2000 on it anyway). I'll post if that works.
Anonymous
February 7, 2001 1:05:51 AM

Yep, I love computers :)  Reformatted, and about 30 seconds later I was on the internet.
Thanks for the replies all.
!