Sign in with
Sign up | Sign in
Your question

HELP ME with Timeshift

Last response: in Video Games
Share
January 22, 2008 8:08:05 AM

I need some help guys.
I really want to try out this game but no matter what I try, I just can't get it to work!!!
First of all, after installation finishes, I run the game and I get a message saying that I have the wrong drivers but I push continue anyway and the game starts. Everything looks cool in the menus, I make the graphic changes I see fit and then press Start new game.
A progress bar comes up saying loading and then a second bar comes up saying "Loading shaders" or something like that. Midway through that second bar, the images freezes. I can hear the sound of the cinematic playing, and if I let it run through, I finally go into the game. The image is still stuck on the loading screen but the sound is as if I'm in the game playing!!!! What the hell is going on?? If I alt+tab the game to windows and back, my monitor freaks out and starts fliping resolutions!! (the screen is blank but it's an old CRT so I can hear the clicking of the rez change).

HELP ME!!!

I tried updating the game also. I got from ver.1.0 to 1.1 but the same thing happens. Then i tried version 1.2 but the same happens there as well!!! My 7800GTX should be able to handle it. I must point out that I don't have the latest drivers from Nvidia but the ones that came before. I'll try updating the drivers today and hopefully it will work.

Any suggestions from ppl that have played the game and had similar problems???
Any help would be greatly appreciated.
Thank you all for your patience.

More about : timeshift

January 22, 2008 11:48:40 AM

I only have the XB360 version, but is there a way to disable cinematics?
January 22, 2008 11:53:54 AM

I don't think so. Anyways, I've been in the oficial forums of the game and there are tons of ppl complaining about the same problem. Some fixed it by installing the new NVidia beta drives but most couldn't launch the game and simply returned it! Way to go Sierra!! Two patches into the game and ppl are returning it to the stores rahter than more ppl buying it.
I'm still trying to make it run. Gonna try the beta drivers my self along with some clean uninstall of the previous (using a utility) and Sierra willing, i might get some playing tonight
Related resources
January 22, 2008 3:08:30 PM

Quote:
First of all, after installation finishes, I run the game and I get a message saying that I have the wrong drivers but I push continue anyway and the game starts. Everything looks cool in the menus, I make the graphic changes I see fit and then press Start new game.


If you get message about 'wrong drivers' maybe you should check it out, not ignore it? Have you tried leaving the graphics settings at default? You do NOT have reccommended system, only minimum! 1Gb RAM is a bit small. You may be selecting graphics options you cannot achieve. Reccomended is Shader 4.0, you only have Shader 3.0.

Mike.
January 22, 2008 3:12:07 PM

Might as well keep trying to figure out the problem. You can try and take it back, but no retail outlet will accept an open game (hell EB Games won't even take it back unopened).

The cinematic is pre-rendered if I remember correctly, so maybe it's a codec problem that screws up the graphics driver? Just a thought....

See Mike's previous post... he hit the nail on the head.
January 22, 2008 3:12:21 PM

If it's a shader error (or bug) then its probably one of the followings.
-requirements issue: Mike99*
-driver issues = fix by reinstalling drivers
-Clock issues = some game are sensitive to overclockings. Try setting the card back to normal clock speed.
-Coding issue = Try installing the latest game patch from Sierra.
-Codec = The forum should let you know which codec is used if its a common issue *like exfileme said*

You've already tried(or will try most of them) but It's a pretty narrow issue. Not a million ways to fix it.
!