Sign in with
Sign up | Sign in
Your question

The Witcher

Last response: in Video Games
Share
January 27, 2008 8:28:06 AM

The Witcher, a great game, right?

Yep, but i am having this really bad problem with the game, that just wont go away. I have patched the game to 2.1, read all the solutions that google gave me, and still, the game will randomly crash my computer when i hit to load a save file. This is the only game/program that crashes on my computer, so i think it is safe to say there is a solution to this.

My pc should be able to handle this game, i have played Bioshock, COD 4, and other games with everything set to max, and no crashes at all.

If anyone has any solutions, post here.

More about : witcher

January 27, 2008 9:29:46 AM

ok, is this vista or xp, 32 or 64 bit? list your specs and all background programs you run
January 27, 2008 10:22:59 AM

Its XP 32 bit, 3 gig ram, 8800 gt oc2 slightly overclocked, 2.87 amd 5200+.

As for programs, the usual, riva tuner, steam, msn, fraps, antivirus, deamon tools (i don't play with the original cd).

Thats about it.
Related resources
January 27, 2008 2:44:42 PM

Sounds like it may be the memory problem, I've read about this before, and i think there's a fix for it in the official Witcher forums.

Basically it's a 32 bit OS problem where the game won't recogise more than 2 gig of ram.

I think the fix go's: Start Command Line Console and write this (this DOES NOT apply to 64bit OSes):
"BCDEDIT /set IncreaseUserVa 3072"

But check the official forums, I'd provide you the link but i'm on such a horrible connection right now that it'll never load.

Hope this helps

P.S. this seems to fix some crashes even if you only have 2 gig's of ram, cant think why but it seems to work click here
January 27, 2008 2:58:31 PM

I think that might be the solution, but where do i type it exactly? Command Promt? Or the Run command? Because both are giving me a "cant find" error. And also, my card has 512 megs of ram on it, should i set it to a lower value or wont windows run out of addressing space?
January 27, 2008 3:22:42 PM

I think it's a console command in the game, hit the ~ key ingame or in the options menu, that should bring down the console, i think you may have to enable console in one of the game settings for the ~ to bring down the console thouh.

The memory is system memory not graphics memory and you have 3 gig's of memory so hopefully this should help.
January 27, 2008 4:37:14 PM

Actually its a command that effects all windows applications i think, the witcher doesn't even have a console.

I figured out why it isn't working for me btw, "BCDEDIT /set IncreaseUserVa 3072" is a vista command, i will see if it can be done in XP.
January 27, 2008 4:39:32 PM

And here it is:

"Step 1 -- Back up your system

Please begin by making a full backup of your computer.


Step 2 -- Become familiar with the Windows XP Recovery Console

Before making this change to your Windows XP configuration, be sure you are familiar with running the Windows XP Recovery Console. Anytime you make changes to the configuration of your computer, there is a possibility of making a mistake that could cause problems booting your computer. The Windows Recovery Console can be used to repair these mistakes. I recommend you practice using the Windows Recovery Console before beginning this procedure.

For more information about the Windows Recovery Console, refer to:

Description of the Windows 2000 Recovery Console, Microsoft Knowledge Base Article 314058.

Using Recovery Console, Microsoft TechNet.

Recovery Console, The Elder Geek.

Windows 2000 / XP Recovery Console, World of Windows Networking.


Step 3 -- Make a copy of boot.ini

In the step 4, you will edit the boot.ini file, normally located in C:\. I recommend you make a backup copy to c:\boot.ini_2gb before editing the file. If necessary, you can restore boot.ini to its previous state using this backup file.


Step 4 -- Edit boot.ini to enable 3 GB addressing

To enable the 3 GB addressing, edit the boot.ini file, which is normally in C:\. You may need to enable display of hidden files and folder in order to see this file in the Windows file Explorer:

1. In Windows file Explorer, choose the Folder Options command from the Tools menu.

2. Choose the View tab.

3. Select the Show hidden files and folders radio button under Hidden files and folders.

4. Click OK.


To enable the 3 GB addressing, you must add the /3GB option to the appropriate line in the boot.ini file:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems] multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="..." /3GB


Step 5 -- Increase the size of your paging file

You should also increase the size of your paging file to at least 4096 MB (4 GB). It is necessary to increase the size of the your paging file beyond 3 GB because it is shared by all processes on your computer, not just The Panorama Factory.

For instructions on how to increase the size of your paging file, see the January 13, 2003 entry on the page Increase swap file size for Windows NT, 2000, XP and Vista.


Step 6 -- Restart your computer

Please double-check your changes to boot.ini before restarting your computer!"


How safe is this exactly? I don't want to mess up my computer just to play one game :)  .
January 28, 2008 4:25:00 PM

I would like to say that this worked and the game no longer crashes, thanks for the idea GeOMan :) .
January 28, 2008 7:46:46 PM

Hmm, the computer game me a blue screen referring to the nvidia driver. I may know what happened, the computer ran out of addressing space and address the memory on the graphic card.

I guess i need a 64 bit OS here, right?
January 29, 2008 2:07:08 AM

Glad it helped.

For the latest problem i don't think it'd start addressing to the graphics card if it ran out of system memory, it may have been a non related graphics driver problem.

Funny thing is I played the witcher for like a week solid and had 1 crash, maybe i just got lucky. I've been working in the middle of nowhere for the last 3 weeks, and i'll be building a Vista64 rig with 4 gig ram when i get back so i'll now probably not even have to use the fix now that you've figured it out fully, the irony of it al (;
January 29, 2008 2:07:10 AM

Hi
If you are running The Witcher on High settings or custom settings that go above the equivalent of Medium setting then you will almost undoubtedly have these problems with crashing as it is a problem with the game. I have read a couple of times in the forums, that people can only over come those problems by setting the game to medium. It really is unfortunate for this to be the case for such a good game.

I hope that I am referring to the same problem and that this helps.
January 29, 2008 3:04:51 AM

I am stuck on the killing the beast in the first part of the game and the walkthrough says to drink a swallow, where do you get a swallow, or what is it talking about?
January 29, 2008 4:19:29 AM

You have to make a swallow potion.
January 29, 2008 6:54:05 AM

GeoMan said:
Glad it helped.

For the latest problem i don't think it'd start addressing to the graphics card if it ran out of system memory, it may have been a non related graphics driver problem.

Funny thing is I played the witcher for like a week solid and had 1 crash, maybe i just got lucky. I've been working in the middle of nowhere for the last 3 weeks, and i'll be building a Vista64 rig with 4 gig ram when i get back so i'll now probably not even have to use the fix now that you've figured it out fully, the irony of it al (;


What i mean is, with the /3GB switch, windows addressed 3 gigs of physical ram, and since 32 bit systems can only address a little over 3 gigs, it may have ran out of addressing space for the graphic card memory. So i can either go down to 2 gigs, or get a 64 bit OS.

At least, thats how i see it.
January 29, 2008 8:08:44 AM

I'm not sure that's it. I think the fix only affects system ram, not graphics ram, it'll only try address as much graphics ram as you have, say 512 or like a max of 1 gig, but than again this fix is out of my depth as far as knowhow so you may well be right.
!