Sign in with
Sign up | Sign in
Your question

Problems with Crysis on ATI HD3850 (GeCube)

Last response: in Video Games
Share
January 28, 2008 12:54:56 AM

I saw somebody mention this same problem on the forums at the Crysis Web site, but nobody had responded. I'm having the same problem, so I thought I'd ask here. Maybe this is a known issue.

I'm actually trying out the pre-release demo for Crysis that I got from a PC Gamer DVD late last year. First, most of the little logo movies that run by before you even get to the game are choppy and odd (EA, nVidia, Intel). There are a few text statements that look fine, and the logos for Crytek and "M for Mature Audiences Only" appear fine. The menu before you get into the game is also choppy. I mention all this because that other poster described the exact same problems (he also happened to have the same graphics card: ATI HD3850).

I have an AMD Athlon 64 X2 Dual Core Barton 5000+, overclocked slightly to 3.0 Ghz, 2 Gb RAM, and the aforementioned GeCube HD3850 graphics card. I've also updated to the most recent version of Direct X 9. Crysis wants me set me at "medium", which would be fine.

When I get into the game, many of the shapes are transparent; talking to people usually means staring at a ghostly shape with two perfectly-rendered white eyeballs. Weird and frightening, but not in the good way.

Any thoughts? Is it my setup, or just an old demo?

Thanks as always to the group.
January 28, 2008 11:14:09 AM

Definitely try newer demo as that card probably wasn't out when that demo was released and there's just been a big patch anyway. Have you updated the drivers, think there were some crysis issues which were resolved in the latest ATI patch. Also it's unlikely you have a Barton core, think they were in the socket 754.
January 28, 2008 12:18:47 PM

spanner_razor said:
Definitely try newer demo as that card probably wasn't out when that demo was released and there's just been a big patch anyway. Have you updated the drivers, think there were some crysis issues which were resolved in the latest ATI patch. Also it's unlikely you have a Barton core, think they were in the socket 754.


Thanks spanner_razor. I'll take a look at the newer (non pre-release) demo. Hopefully that will do the trick. I do have updated drivers for my HD3850, but you're right: I said "Barton" and I meant "Brisbane." Potato/potahto, right? ;) 
Related resources
January 28, 2008 12:43:44 PM

it's all good, i'm still wallowing in a 1950 pro and 939 4600, it's less than spectacular on neverwinter nights 2. Next uni loan installment I reckon I'll get an 8800GT or similar.
January 30, 2008 5:59:05 PM

Well, an update: all the demo versions I downloaded perform with exactly the same problems I described above. The good news is that I was able to solve the transparency problem by moving my "shader" quality from medium to high, leaving all the other settings on medium (where the game assigned them). But those logo/trailer movies are still awful to sit through: all but 2 are staggered, pixelated messes. I'll keep looking for a solution there.

But I think I can run this game, which means I think I can buy this game. Whee!

Thanks for the help.
January 30, 2008 7:04:06 PM

What drivers are you using? 8.1 is the latest Catalyst set.
January 31, 2008 12:04:39 AM

Yep, it's 8.1. I just rebuilt this machine, so all my drivers are fully updated. I've seen the same issue with the logo movies described by a handful of other folks in various forums, usually with 3850 cards, but not always. One person suggested renaming those movies so that they are skipped, which I did, and that actually helped the initial menu run better as well (once you get in-game, the menu runs fine). I wonder if there's some video codec conflict or what-not with some of those movies. Who knows.

Thanks for the comment.
February 16, 2008 10:11:43 AM

I had the EXACT same problems, but once I installed the latest drivers from feb. 13th the movies and menus run smoothly, and everybody has their polygons in place :)  I have a hd2600 XT with all settins on medium, and shaders on high.
March 11, 2008 3:30:28 AM

I had the same problem with an 8600GTS.

Solution: In your video menu set "Shadow Detail" or something to *HIGH*, anything lower will make everything freakishly freaky.
March 11, 2008 4:10:50 PM

spanner_razor said:
it's all good, i'm still wallowing in a 1950 pro and 939 4600, it's less than spectacular on neverwinter nights 2. Next uni loan installment I reckon I'll get an 8800GT or similar.


You should be spending it on books, staples and hole reinforcers! lol

Mines buying me some new clothes among other things, all hail SLC (student loans company)!
March 11, 2008 4:13:05 PM

wolfy01 said:
I had the same problem with an 8600GTS.

Solution: In your video menu set "Shadow Detail" or something to *HIGH*, anything lower will make everything freakishly freaky.


how freaky? lol
!