Sign in with
Sign up | Sign in
Your question

bioshock issues

Last response: in Video Games
Share
February 7, 2008 12:03:41 AM

hey guys,

I'm trying to help a friend to get bioshock working on his pc... it's a pirated copy that doesn't require mounting/installing or anything, just a folder with everything in it and a registry key. It worked on my computer, but on his the menu screens don't have a pointer or cursor or anything, and in game is completely black with random polygons occasionally (the game runs and sounds work, just no display). I double checked the directory structure and I'm sure all the files are in the right places. I know his video card is a radeon x300, but I know next to nothing about ati cards and i couldn't find any sort of control panel or anything to fool around with. I also told him to try playing the UT3 demo to see if the problem was related to the game engine but I don't know what happened with that yet. Unfortunately I don't know any of his other specs, but his rig plays source engine games and shouldn't have any problems running bioshock.
any suggestions?

Thanks!

More about : bioshock issues

February 7, 2008 12:16:39 AM

His video card only supports Shader Model 2.0b, Bioshock requires 3.0.
Also it's pirated. Get a proper copy.

http://www.paolofranchini.com/shshock/index.php has a patch/hack/update that will allow the game to run on cards with SM 2.0
February 7, 2008 10:37:59 AM

lol....
Related resources
February 7, 2008 2:24:09 PM

hmm... dont get me started on the DRM in the real game.... (i'm still fuming)
February 7, 2008 2:30:00 PM

Quote:
... . it's a pirated copy that doesn't require mounting/installing or anything, just a folder with everything in it and a registry key...


Buy a real copy and stop pirating. You people are the reason game developers are more inclined to build console games over PC games.
February 7, 2008 6:35:14 PM

rwillis said:
hey guys,
... it's a pirated copy that doesn't require mounting/installing or anything, just a folder with everything in it and a registry key.
Thanks!


I dont think you will get many fans or help on this site taking about that.......
February 8, 2008 1:32:43 PM

you're an idiot. i hope you die in a fire
February 8, 2008 2:06:12 PM

Buy the game, that will help in making it work.
February 11, 2008 1:39:50 AM

I do like this guy's as-a-matter-of-fact honesty though ...

Anyway, ya ... buy the game ... unless you are willing to work for free in your real life.
February 13, 2008 3:03:11 PM

Dude, really? You get what you paid for. Like others have said, you won't get any help or support for that here. Go out and buy the game and you'll see how nice it plays. It's not Bioshock issues, it's your issues. Hope your pirated copy has a mean virus on it that destroys your friend's computer.
February 13, 2008 3:58:39 PM

From what ive heard Bioshock has one of the better copy protection systems (however one prone to bugs). From what ive gathered it operates on a credit system where by you use one when you install and recover that credit when you uninstall. This limits each CD key to 2-3 installs and also requires an online account. All of which make illegal copies a pain in the a*se. So yeah, just buy it!

Also, the "I'm trying to help a friend" line is like saying "I've got a friend who was caught masturbating by his mum"...seriously!
February 29, 2008 6:24:04 PM

I'm looking forward to ThE fUtUrE when I really want to play this game again for nostalgias sake.
So I install it onto my machine (maaaaaan It's going to be sooooo smooth playing this five year old game now on my 16 core CPU 8xGPU beast).
Hold on....
WhaaaaaaaaT?
The servers are no longer active? They shut them down 2 years ago? I can't PLAY WITHOUT ACTIVATING IT???
WWWTTTTTFFFFFF?
March 1, 2008 4:26:08 AM

rwillis said:
hey guys,

I'm trying to help a friend to get bioshock working on his pc... it's a pirated copy that doesn't require mounting/installing or anything, just a folder with everything in it and a registry key. It worked on my computer, but on his the menu screens don't have a pointer or cursor or anything, and in game is completely black with random polygons occasionally (the game runs and sounds work, just no display). I double checked the directory structure and I'm sure all the files are in the right places. I know his video card is a radeon x300, but I know next to nothing about ati cards and i couldn't find any sort of control panel or anything to fool around with. I also told him to try playing the UT3 demo to see if the problem was related to the game engine but I don't know what happened with that yet. Unfortunately I don't know any of his other specs, but his rig plays source engine games and shouldn't have any problems running bioshock.
any suggestions?

Thanks!
Stop hurting the PC gaming industry.
!