Sign in with
Sign up | Sign in
Your question

Crysis running poorly

Last response: in Video Games
Share
March 20, 2008 11:49:57 PM

hey wtsup every1,

i built a new system recently, and was most looking forward to playing crysis on it. it consists of:

Intel Core 2 Duo E8400
Asus P5KC
4GB 800Mhz Ram
SparkleVision O.C 9600GT (connected to monitor via HDMI cable)
500GB HDD
20X Samsung DVD-RW Drive
OCZ 600W PSU
19'' HD Ready Samsung TV/PC Monitor

I installed crysis and patched it up to the latest version (1.2) and the following settings applied:

1440x900 Resolution
All Settings on High (Except Water/Sound "Very High")
No AA
No Vsync
No Blood
Subtitles Enabled

At first it played great, but as you shift from the night to the day it starts to lag and play really jumpy. Not to slow like a slideshow, but not smooth enough to enjoy. I would have assumed that with my new system i should at least be able to run it at high with no AA smoothly. But i guess i got it wrong.

Any ideas or help would be great please!!!

More about : crysis running poorly

March 21, 2008 2:06:01 AM

I'm assuming you have the latest drivers for your video card as well. (If not, try that first) Anyway, you have discovered Crysis's main criticism, that it's too damn system hungry!

You might also want to make sure that you don't have any sort of software programs overriding Crysis's graphical settings. For example, you may inadvertently have AA enabled through NVIDIA control panel and not realize it.

Most importantly, you probably shouldn't expect to jack up the graphics in crysis all that far unless you have a really really beefy system!
March 21, 2008 1:35:28 PM

thanx mate, forget to mention im using vista home premium 64bit and running the game from the 64bit folder. and yeh ive fully updated my system in every aspect, but i never really thought about that nvidia control panel tip, much appreciated! also, im not really expecting much since when i click on auto detect optimal settings in crysis itself, it chooses all high.
Related resources
March 21, 2008 1:47:37 PM

aaah, ive read in a few places not to use the 64bit executable, supposedly its a difference of a good 10fps or so. give the 32bit exe a try and see how it goes
March 21, 2008 2:05:34 PM

I can't believe it. I looked forward to Vista so long for 64bit goodness. Build this S939 system around it with XP OEM, and waited for Vista to come out.

Well, needless to say, I will be using XP for quite a while, and no, won't be building another PC until Vista is sorted out or Win7 is out.

Downloading Ubuntu as we speak...

I just cannot believe that your ace system you built plays Crysis worse than my 2+ year old XP box. And I use the "very high" settings hack, and get 25ish FPS at 1440x900. Vista is a huge step backwards for Intel to sell chips and for DRM to thrive.

I am so dissappointed, my geeky ambitions are put on hold for 2+ years, bummer.
March 21, 2008 3:24:23 PM

thanx alot for all the help i really apreciate it guys.
March 21, 2008 5:25:21 PM

I had a lot of issues with Vista, so before you start pulling out all your hardware piece by piece and testing it, you might want to try it on XP (although obviously you won't be running it in DX10, but something to consider before you drive yourself crazy with the hardware aspect).
March 22, 2008 7:19:15 AM

just to let you know, i installed vista sp1 last and gained 7fps on the gpu test. if that helps you at all XD
March 22, 2008 7:31:44 AM

Vista knocked about 7FPS off for me on Crysis. XP FTW
October 27, 2008 8:59:59 AM

hey,

I'm having the same problems. built a PC, and was hoping it would be able to handle Crysis, but the game runs very poorly

Specs:
Motherboard (if that helps?) Gigabyte EP45-DS4p
CPU: Intel Quad core Q6600 2.4GHz
Ram: 4 Gig
Graphics: ATI Radeon HD 3870
OS: Vista 64bit, service Pack 1
HDD: 500gig

not sure if i need to give any more info. Is this system suitable to run the game or have i missed the mark?
I've tried dialling down all the settings ( it recommends i play on high) still no good. background objects flicker alot. I read elsewhere that dropping your Res to 1280 x 1024 would help but it made it so much worst.
have the latest drivers for graphics.
not sure where to go from here.
October 29, 2009 6:12:42 PM

I'm having the same issues but I've figured it out!!!

My setup that I'm currently typing on right now does it to every game!!!

What I believe is our problem is that our 2 processor or 4 processor systems doesn't set the program's affinity to a single core and instead plays hot potato with it.

Heres my specs:
Intel Qx6700 @ 3200 MHz, 2 GB Corsair Dominator 1066MHz, 1KW BFG PSU, MSI P6N Diamond latest bios, cheap hard drive, cheap dvd burner....

I dont' know if I'm missing a driver or something but any time I load up any kind of graphically intense game it plays like *** until I alt tab out and set the program's affinity to a single core!!!

I got fed up with using that alt tab method each time I started the games etc.. so I found an easier solution. By running IMAGECFG.EXE -A 0X1 or 0X2 or OX4 or OX8 (each OXn representing a core on my quad core, followed by the exe path ie) "C:\Program Files\Steam\steamapps\common\left4dead.exe"

Now each time I start left4dead the program will only use a single core and stop that hot potatoe game. Because before each core would get a chance to service it and it would be a choppy and crashy game I tell you.

So here's a screenshot and a link to that imagecfg. I hope this helped.



ImageCFG.ZIP Link

Btw I just built a new machine with an i7 975 quad core with the Nahelem chipset and it doesn't require this stupid imagecfg thing to run things, it actually just works! Hurray, except I'm waiting for it to be RMA'd cuz it fried when I unplugged the stinking PS/2 keyboard.... :( 
!