Sign in with
Sign up | Sign in
Your question

Might and Magic 7 Resolution problem

Last response: in Video Games
Share
June 11, 2008 5:41:29 PM

Hi, I'm having trouble starting the game..
After i start it, I get an error saying "To run this application, the resolution of the screen should not be less than 800x600"..
I have done all things nessesary to run in XP.. Changing compatibility and downloaded the latest patch (v1.2).
I don't know what it is, if its my widescreen, my graph gforce 8600 GT or dualcore.. Please help me, i love this game to much :p 
June 11, 2008 6:26:24 PM

My bet is the widescreen resolution is giving it fits.
June 11, 2008 6:29:16 PM

I just recently reinstalled Mechwarrior 4 Mercs only to discover that I had to jump through more hoops than a circus lion to get it to work on my current computer. At least without everything being fat and ugly.

After 1 official patch, 3 unofficial patches, a registry edit, an uninstall, reinstall, repatching, and tweaking I finally got it to work... mostly. The combat looks fine now, but the between missions screen is kinda funky.

Long story short, old games hate teh widescreenz
Related resources
June 11, 2008 7:39:49 PM

Hm, is there a way to make the w-screen "act" like a normal screen just to make the game work? just realized there was a window-mode for the game as well, thought it should work with that, but still it didn't =/
June 11, 2008 9:28:41 PM

Well... if you don't mind everything being short and fat and probably a bit ugly, you can set your resolution to 1024x768 in windows. That might work. If it doesn't then it probably isn't the widescreen causing the issue.
June 12, 2008 9:32:29 PM

well that didn't work as well =/ god dammit, someone else have any theories or anything?
July 3, 2008 6:39:03 PM

Bibbi said:
Hi, I'm having trouble starting the game..
After i start it, I get an error saying "To run this application, the resolution of the screen should not be less than 800x600"..
I have done all things nessesary to run in XP.. Changing compatibility and downloaded the latest patch (v1.2).
I don't know what it is, if its my widescreen, my graph gforce 8600 GT or dualcore.. Please help me, i love this game to much :p 


++++++++++++++++++++++++++++++++++++

Download and use this patch:
http://telp.org/mm7/tavern/anyboard/posts/19648.html

Then right click on game executable and under Compatibility tab select "Windows 98/Windows ME" in "Compatibility Mode" Box

And make sure nothing is checked under "Display Settings"

Had same problem before doing the above, im running game fine under XP on a 24 inch Dell Widescreen...looks SWEET..

Good Luck
January 3, 2009 9:13:27 PM

Yeah I have the same problem, but sometimes it seems to work for me.
I first started having it with Age of Empires II, which is understandable, being such an old game.
But then I started having the problem with Call of Duty 4 on my 22" widescreen.
No idea what it is, but it doesn't let me open the game for a while, then it randomly works :S
Anonymous
March 28, 2009 5:44:08 PM

[*** up and randomly started the game but now after 50 tries i got tired of it. what shall i do? I also have some small lag when i tried to play "Left 4 Dead" dunno if it is something with my 3d thingy cause in "dxdiag" i tested the direct 3D and it randomly closed the tests for me and just told me "you touched a keyboard key" and all i can do is to press "ok". Also when that came up the "To run this application, the resolution of the screen should not be less than 800x600" came up in the background aswell. Please help!
November 25, 2009 9:48:00 PM

SOLUTION

I ended up solving this myself. This can be done with any program. I was trying to get Total Annihilation to work.

1) Restart your PC after installing the program.

2) Open the registry editor by typing regedit in the run box and pressing ok/hitting enter.

3) Backup your registry by selecting File > Export, then ensure that the export range "All" is selected. Save the registry backup to an easy to find location.

4) Press Control + F to access the find feature. Uncheck the "Data" option to lower the range of your search to Keys and values only.

5) Type the full name of the program in question (e.g. Total Annihilation) and press "Find Next"/hit enter.

6) Upon finding the program's folder branch (e.g. HKEY_CURRENT_USER\Software\Cavedog Entertainment\Total Annihilation) find the values labelled: DisplaymodeHeight and DisplaymodeWidth. If not these values then it will be the values with data resembling screen resolutions. (e.g. 640 and 480).

7) Change the height to a value greater than or equal to 800 and the width to a value greater than or equal to 600. To do so double-click on the values and select "decimal" (Unless you're pro with hexadecimal) then enter the desired resolution and press "Ok". (Of course no values greater than your screen resoltuion!)

8) Close the regisrty editor and you should now be able to operate the program without receiving the error.

I will be posting this on every damn message board I can find about this issue. - Gehirn
!