Sign in with
Sign up | Sign in
Your question

RedHat sound Issue

Last response: in Linux/Free BSD
Share
June 16, 2004 8:06:48 PM

I have a "Intel Corp. 82801BA/BAM AC'97 Audio" Sound chip and am running RedHat 7.3. I am also running KDE 3.0.5a

I am attempting to get my sound working but I do not hear anything when I try playing something with xmms. Xmms will only play without error messages when "Arts" is selected. in KDE, Arts is set to start on kde startup. and sound IO is se to autodetect. All Defaults.

I tried running sndconfig but I hear nothing
Any ideas on what I might do to try to fix this problem?

:lspci | grep audio
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 04)

:lsmod | grep audio
i810_audio 25504 0
soundcore 6468 2 [i810_audio]
ac97_codec 13248 0 (autoclean) [i810_audio]

/var/log/messages:
kernel: Intel 810 + AC97 Audio, version 0.24, 18:18:19 Feb 19 2004
kernel: PCI: Found IRQ 10 for device 00:1f.5
kernel: PCI: Sharing IRQ 10 with 00:1f.3
kernel: i810: Intel ICH2 found at IO 0xef00 and 0xe800, MEM 0x0000 and 0x0000, IRQ 10
modprobe: modprobe: Can't locate module sound-service-0-3
kernel: i810_audio: Audio Controller supports 6 channels.
kernel: i810_audio: Defaulting to base 2 channel mode.
kernel: i810_audio: Resetting connection 0
kernel: ac97_codec: AC97 Audio codec, id: ADS96 (Analog Devices AD1885)
kernel: i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not present), total channels = 2
kernel: i810_audio: setting clocking to 41290
modprobe: modprobe: Can't locate module sound-service-0-0
modprobe: modprobe: Can't locate module sound-slot-1
modprobe: modprobe: Can't locate module sound-service-1-0
modprobe: modprobe: Can't locate module sound-slot-1
modprobe: modprobe: Can't locate module sound-service-1-0

Linux version 2.4.20-30.7
Red Hat Linux 7.3

More about : redhat sound issue

October 24, 2004 10:22:50 PM

What version of redhat? If it uses ALSA (the advanced linux sound architecture) then you need to run the command as root: alsaconf

Then don't forget to turn up your sound volumes using something like kmix in kde so that no channels are muted.

----------
<b>It is always brave to say what everyone thinks. </b> <i>Georges Duhamel</i>

TKS
!