Sign in with
Sign up | Sign in
Your question

Black screen while playing BF3, DMC , and Farcry 3...

Last response: in Video Games
Share
March 12, 2013 9:04:54 PM

Hello I've noticed I've been getting a blackscreen while playing these games after about 15-30mins in. The black screen lasts about 3 seconds then goes back to the game followed by some lag for a few seconds then it goes back to normal. I only notice it seems to happen with these games(Battlefield 3, Devil May Cry, and Farcry 3), My PC specs are:

Geforce 550 ti (314.14 beta driver)

q6600 CPU

4gb ddr2

Windows 7 32-bit

Antec 650w PSU
March 14, 2013 6:54:22 AM

Any suggestions on what it could be?
March 14, 2013 7:12:57 AM

DaveB_55 said:
Hello I've noticed I've been getting a blackscreen while playing these games after about 15-30mins in. The black screen lasts about 3 seconds then goes back to the game followed by some lag for a few seconds then it goes back to normal. I only notice it seems to happen with these games(Battlefield 3, Devil May Cry, and Farcry 3), My PC specs are:

Geforce 550 ti (314.14 beta driver)

q6600 CPU

4gb ddr2

Windows 7 32-bit

Antec 650w PSU


Well to start your troubleshooting let me ask you a few questions.
Did this black screen start appearing since you installed the new 314.14 driver?

Are you monitoring your Frames Per Second with a program like FRAPS?
Knowing if your getting only 20-28 fps does make a difference.

Is windows itself running on Balanced power mode, or High Performance?
Check your control panel and set to high performance

Since these games do use the hardware and generate heat, when is the last time you cleaned the dust from your video card? If your capable, check your thermal paste on the GPU, it may be crusty.

Do you have clean system? (use Emsisoft Emergency Kit, its free)

Are you using an up to date security suite? (Webroot, Kaspersky, NOD32)
Have you checked for Windows Updates?
When is the last time you have done a defrag? (if you have an SSD, DO NOT defrag it.)
Have you ran CCleaner in the past 5 months?
Do you have a temperature program like SpeedFan? or HWinfo32?
visit filehippo.com for most of these downloads and google the rest.

My last question is why you are running 32 bit instead of 64?
!